OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Ambicom Woes
Asterix
post Aug 4 2007, 08:03 AM
Post #1





Group: Members
Posts: 19
Joined: 27-July 07
From: A Small Village in Virginia
Member No.: 18,507



So, I bought an AmbiCom WL1100C-CF wifi card for my Cacko-running SL-C1000, having read about how great it is. Well, it's great, but the one I got has old firmware so doesn't support WPA-PSK. It works fine with WEP, but I ain't running that with my home network. So, I search the interwebs and find that there are firmware updates! Hooray! Now my hurdle: running hostap_diag wlan0 returns this:
CODE
# hostap_diag wlan0
Host AP driver diagnostics information for 'wlan0'

ioctl[PRISM2_IOCTL_HOSTAP]: Connection timed out
Could not communicate with the kernel driver.
#

The same thing happens with wifi0 instead of wlan0.

Cardctl gives me this:
CODE
# cardctl config 0
 Vcc 0.0V  Vpp1 0.0V  Vpp2 0.0V
# cardctl info 0
PRODID_1="AmbiCom"
PRODID_2="WL1100C 802.11b CF-Card"
PRODID_3="2.2"
PRODID_4=""
MANFID=d601,0002
FUNCID=6
# cardctl ident 0
 product info: "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
 manfid: 0xd601, 0x0002
 function: 6 (network)
# cardctl status 0
 3.3V 16-bit PC Card [suspended]
#

If I try to resume the card, it just goes back to suspended.

Trying to reflash:
CODE
# prism2_srec -v wlan0 pk010101.hex sf010802.hex
S3 CRC-16 generation record: start=0x007E17FE len=2 prog=0
[lots of goop about the firmware I'm not going to type]
Start address 0x00000000

ioctl[PRISM2_IOCTL_HOSTAPD]: Connection timed out
Missing wlan component info
Could not read wlan RIDs
#


And ideas about how I can get hostap_diag to see this card so there's hope I can reflash it to a new enough version so it'll support WPA? I've scoured the forums and nobody else seems to have this problem. I've seen hints that the card's firmware can be updated with Windows, but I can't find out how. I have access to a Windows XP laptop that has a PC slot and I have a PC-to-CF adapter, so I'd happily upgrate the firmware with Windows if I could find out how.

When I temporarily reset my network for WEP, the card works great.

Asterix
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Asterix
post Aug 4 2007, 08:38 AM
Post #2





Group: Members
Posts: 19
Joined: 27-July 07
From: A Small Village in Virginia
Member No.: 18,507



Replying to my own post...

I found this site, http://linux.junsun.net/intersil-prism/, which is all full of good info. I'll read it all and try what is suggested there and get back here.

Asterix
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd September 2014 - 12:23 AM