OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Newbie Install Woes, stuck in a getty loop!
Wildherb
post Aug 11 2007, 02:15 PM
Post #1





Group: Members
Posts: 92
Joined: 9-January 06
Member No.: 8,887



Hello, this is my first post on this forum but I've had my 3100 for nearly 2 years and been through just about all the ROMs except OpenBSD so I thought I'd give it a try because I like X and want to use a 'native' system rather than a bolt-on or cut-down system.

I have decided to use 4.1 for now and I'm using this method to load the installer, and I've put the install sets on a CF card as I dont have an ethernet card for my Z (wireless only)

# insmod zbsdmod.o
# cp bsd.rd /proc/zboot

Everything seems to go OK. I get to calibrate the X screen and invited to reboot. At this point I copy the config file to /mnt/mtdflash2/pcmcia/config and reboot. The reboot gets as far as this, then gets stuck in a loop of getty messages.

init: kernel security level changed from 0 to 1
init: can't exec getty 'usr/libexec/getty for port /dev/ttyC0: no such file or directory
init: can't exec getty 'usr/libexec/getty for port /dev/ttyC1: no such file or directory

I've been through this twice with the same results. Any ideas what I can do?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
ZDevil
post Aug 22 2007, 04:19 AM
Post #2





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Well, i don't actually have big problems with suspend and resume. The On/Off buttons works just fine.
Suspending by zzz works as expected. No issue so far (finger crossed).
Lid suspend has been reported to be broken under the current 4.2.
If the screen goes dark after resume, probably it's just because the backlight is turned off. Run a simple script with wsconsctl display.backlight=100 will bring the view back.
I do the same to adjust backlight (up and down) as well. (i.e. wsconsctl display.brightness+=1 and wsconsctl display.brightness-=1)

Good to see that some of us are building new stuff for 4.2!
I've already started a feed dedicated to 4.2. It is being constantly updated every day.
http://www.oesf.org/forums/index.php?showtopic=24586
All the packages there are compiled with optimization flags, so they are supposed to run faster than those without.
A million thanks to jpmatrix for offering the space to host the packages.

How about we compiling things in a kinda concerted fashion? We don't actually have to port things all on our own. You can ask jpmatrix for the detail of uploading your packages. smile.gif
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 07:44 PM