OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Openbsd Trouble Compiling
jocasmi
post Sep 8 2007, 01:33 AM
Post #1





Group: Members
Posts: 99
Joined: 4-December 06
From: Barcelona, Spain
Member No.: 13,088



Hi, I've used OpenBsd in many occassions, and now I want to return again to it, having seen that a lot of people have interest on OpenBSD, and Developers are doing a great work, with big respect to the Zaurus Community.

So I get the last snapshot in my home PC.

I want to be able to use in my desktop the common apps that I use in my zaurus daily.

So I start to set up the environment to compile the apps from source, in order to get Kde pwmanager (there's no port of package for it).

The first issue appears when compiling qt-x11, because pwmanager wants a specific version, and also because OpenBSD puts libraries in a different dir than Linux does.

After setting the QTDIR in .profile, i was able to successfully compile QT.

When I back to compile Kde pwmanager, the ./configure complains about the system doesn't have nor libjpeg6b neither libbzip2 installed, and then stops with a warning of "fatal error can't configure".

These libraries are installed from their sources.

I don't understand why ./configure doesn't find them. I'm care about that such a case may repeat with other compilation and other libraries.

Any OpenBSD user could tell me if this is an isolated issue, or something general that needs to be configured in a different way?

Thanks in advance.
Go to the top of the page
 
+Quote Post

Posts in this topic
jocasmi   Openbsd Trouble Compiling   Sep 8 2007, 01:33 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th July 2014 - 11:34 AM