OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Libraries Dependencies Problem
xdivider
post Sep 23 2007, 04:30 PM
Post #1





Group: Members
Posts: 44
Joined: 28-August 04
Member No.: 4,412



Hi, was playing with the 4.2 snapshot yesterday but couldn't run a lot of programs like X which required 4.1 libs. I installed 4.1 lafter that and while trying to grab some precompiled packahes, i found that a lot of the packages required libraries like libX11.so.10.0 that was in 4.2. So did I miss any steps in installing 4.1? I did install 4.1 ipk->install OpenBSD->ftp install of 4.1-> trying to pkg_add from the depositories.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
ZDevil
post Sep 24 2007, 02:37 PM
Post #2





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



QUOTE(xdivider @ Sep 24 2007, 02:30 AM)
Hi, was playing with the 4.2 snapshot yesterday but couldn't run a lot of programs like X which required 4.1 libs. I installed 4.1 lafter that and while trying to grab some precompiled packahes, i found that a lot of the packages required libraries like libX11.so.10.0 that was in 4.2. So did I miss any steps in installing 4.1? I did install 4.1 ipk->install OpenBSD->ftp install of 4.1-> trying to pkg_add from the depositories.
*

Yes, the 4.2 system cannot use 4.1 packages ... tongue.gif
So may want to use the 4.2 packages in my feeds and start from there.
Go to the top of the page
 
+Quote Post
xdivider
post Sep 24 2007, 06:27 PM
Post #3





Group: Members
Posts: 44
Joined: 28-August 04
Member No.: 4,412



QUOTE(ZDevil @ Sep 24 2007, 10:37 PM)
QUOTE(xdivider @ Sep 24 2007, 02:30 AM)
Hi, was playing with the 4.2 snapshot yesterday but couldn't run a lot of programs like X which required 4.1 libs. I installed 4.1 lafter that and while trying to grab some precompiled packahes, i found that a lot of the packages required libraries like libX11.so.10.0 that was in 4.2. So did I miss any steps in installing 4.1? I did install 4.1 ipk->install OpenBSD->ftp install of 4.1-> trying to pkg_add from the depositories.
*

Yes, the 4.2 system cannot use 4.1 packages ... tongue.gif
So may want to use the 4.2 packages in my feeds and start from there.
*



When I installed the 4.2 snapshot directly, there was a lot of programs like X that needs 4.1 libs. So The correct install path for 4.2 is openbsd install -> 4.1 -> 4.2 upgrade b4 installing 3rd parties?
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 09:56 AM