OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3 >  
Reply to this topicStart new topic
> Bluetooth Under Debian Eabi, it works!
Chero
post Oct 2 2007, 10:22 PM
Post #16





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



QUOTE(jpmatrix @ Oct 2 2007, 10:31 PM) *
QUOTE(Chero @ Oct 2 2007, 09:41 PM) *
QUOTE(jpmatrix @ Sep 25 2007, 11:11 PM) *
1) i've just tried my Belkin FT0820 Bluetooth CF and :
it has 4 lines of complains about serial_cs: unknown symbol serial8250_xxxx sad.gif


I had the same with my billionton card so
I switched to kernel 2.6.22 . Now the messages are gone !
(symbol spectrum wifi also works like a charm)

Now I'll have to figure out what's next, cause the usual "setserial" doesn't seem to work ... sad.gif

Any hints ?

Chero.


kernel 2.6.22 ??? where is it ? where is it ??? smile.gif

to have my belkin work under angstrom, i had to type:
hciattach /dev/ttyS4 bcsp

hope this helps!


I'll check it out this evening. (my bluetooth card is at home)

Where is the kernel :
I downloaded the latest spitz images from the angstrom site.
Then I first copied the modules from the hdimage1.tgz to the correct place.
I put updater.sh together with ZImage.bin on an SD card and flashed the new kernel.
(don't put the hdimage on the card !!!!)

Chero.
Go to the top of the page
 
+Quote Post
ZDevil
post Oct 3 2007, 02:21 AM
Post #17





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Off topic:

How is the 2.6.22 kernel running in general? What are the major improvements over 2.6.20 (like sound, speed, etc)?
I am trying the older 2.6.17 kernel with fastfpe and cpufreq, and I now find the way to force the system to load my Ambicom WL1100C. Generally I find the system with the 2.6.17 kernel more responsive than the 2.6.20 in titchy, at least when running xfce4 (so many gnome stuff) and iceweasel.
Go to the top of the page
 
+Quote Post
Chero
post Oct 3 2007, 03:59 AM
Post #18





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



QUOTE(ZDevil @ Oct 3 2007, 12:21 PM) *
Off topic:

How is the 2.6.22 kernel running in general? What are the major improvements over 2.6.20 (like sound, speed, etc)?
I am trying the older 2.6.17 kernel with fastfpe and cpufreq, and I now find the way to force the system to load my Ambicom WL1100C. Generally I find the system with the 2.6.17 kernel more responsive than the 2.6.20 in titchy, at least when running xfce4 (so many gnome stuff) and iceweasel.


- Not sure whether speed is different - I haven't been testing this.
- The mouse is still "rotated".
- both my wifi cards are recognized out of the box, without having two interfaces (wlan0 and wifi0)
- my bluetooth-CF forces the serial_cs module to load without errors
- sound : I'll check that one

so in general I think it has some benefits.

Chero.
Go to the top of the page
 
+Quote Post
ZDevil
post Oct 3 2007, 04:09 AM
Post #19





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Where is the download location? I tried to find it but get lost ...

The only place I can find is here http://www.angstrom-distribution.org/unsta...spitz/20070917/, but which one?

[ ] Angstrom-x11-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz 17-Sep-2007 09:48 17M
[ ] Angstrom-x11-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz.md5 17-Sep-2007 09:48 170
[ ] Angstrom-x11-office-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz 17-Sep-2007 10:29 45M
[ ] Angstrom-x11-office-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz.md5 17-Sep-2007 10:29 177
[ ] Angstrom-x11-pimlico-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz 17-Sep-2007 09:53 20M
[ ] Angstrom-x11-pimlico-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz.md5

Also does hwclock work in 2.6.22? I cannot access the system clock after switching to 2.6.17 (complaint about missing /etc/rtc ).
Go to the top of the page
 
+Quote Post
Chero
post Oct 3 2007, 04:44 AM
Post #20





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



QUOTE(ZDevil @ Oct 3 2007, 02:09 PM) *
Where is the download location? I tried to find it but get lost ...

The only place I can find is here http://www.angstrom-distribution.org/unsta...spitz/20070917/, but which one?

[ ] Angstrom-x11-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz 17-Sep-2007 09:48 17M
[ ] Angstrom-x11-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz.md5 17-Sep-2007 09:48 170
[x] Angstrom-x11-office-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz 17-Sep-2007 10:29 45M
[ ] Angstrom-x11-office-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz.md5 17-Sep-2007 10:29 177
[ ] Angstrom-x11-pimlico-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz 17-Sep-2007 09:53 20M
[ ] Angstrom-x11-pimlico-image-glibc-ipk-2007.9-test-20070917-spitz-installkit.tgz.md5

Also does hwclock work in 2.6.22? I cannot access the system clock after switching to 2.6.17 (complaint about missing /etc/rtc ).


I used the big one. Not sure if it's any different for the others, I suppose the only difference are the included apps.

I suppose it does : I didn't loose time-settings on reboot and I can use it to query the clock. (I use "date" to change settings, not sure what is called by it but it works)

Chero.
Go to the top of the page
 
+Quote Post
ZDevil
post Oct 3 2007, 04:51 AM
Post #21





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Thank. I just choose the small one. Will start over again.
The 2.6.22 kernel seems to have the cpufreq patch. Can you play with dvfm? smile.gif

dvfm 16 4 1 2 1 # 416 mhz
dvfm 16 5 1 2 1 # 520 mhz
dvfm 16 6 1 2 1 # 624 mhz
Go to the top of the page
 
+Quote Post
Chero
post Oct 3 2007, 07:19 AM
Post #22





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



dvfm: command not found sad.gif
Go to the top of the page
 
+Quote Post
jpmatrix
post Oct 3 2007, 07:32 AM
Post #23





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(Chero @ Oct 3 2007, 05:19 PM) *
dvfm: command not found sad.gif


same for me!

i've just upgraded titchy to kernel 2.6.22
tried my belkin bt CF card and ... it works!
though i had to hciattach /dev/ttyS4 bcsp


bad news: i've broker my X server
i wanted to disable auto X login on boot
so i update-rd.c -f remove xdm
then apt-get remove xdm

now /opt/kdrive/Xfbdev complains about libXfont.so.1 that it cannot found............
any help please???????
Go to the top of the page
 
+Quote Post
ZDevil
post Oct 3 2007, 07:37 AM
Post #24





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



QUOTE(jpmatrix @ Oct 3 2007, 05:32 PM) *
QUOTE(Chero @ Oct 3 2007, 05:19 PM) *
dvfm: command not found sad.gif


bad news: i've broker my X server
i wanted to disable auto X login on boot
so i update-rd.c -f remove xdm
then apt-get remove xdm

now /opt/kdrive/Xfbdev complains about libXfont.so.1 that it cannot found............
any help please???????


How about reinstalling the libxfont1 package?
Go to the top of the page
 
+Quote Post
Chero
post Oct 3 2007, 07:54 AM
Post #25





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



QUOTE(ZDevil @ Oct 3 2007, 05:37 PM) *
QUOTE(jpmatrix @ Oct 3 2007, 05:32 PM) *
QUOTE(Chero @ Oct 3 2007, 05:19 PM) *
dvfm: command not found sad.gif


bad news: i've broker my X server
i wanted to disable auto X login on boot
so i update-rd.c -f remove xdm
then apt-get remove xdm

now /opt/kdrive/Xfbdev complains about libXfont.so.1 that it cannot found............
any help please???????


How about reinstalling the libxfont1 package?


Did you only remove xdm or also the so-called not longer needed packages ?
Maybe just apt-get install xdm again and only remove it from rc.d.

At least your BT card works .... wink.gif

Chero.
Go to the top of the page
 
+Quote Post
ZDevil
post Oct 3 2007, 08:23 AM
Post #26





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



QUOTE(Chero @ Oct 3 2007, 01:59 PM) *
- Not sure whether speed is different - I haven't been testing this.
- The mouse is still "rotated".
- both my wifi cards are recognized out of the box, without having two interfaces (wlan0 and wifi0)
- my bluetooth-CF forces the serial_cs module to load without errors
- sound : I'll check that one


My ambicom wifi card cannot work again after switching to 2.6.22. Falling back to 2.6.20 it works just fine. Why? wacko.gif
Go to the top of the page
 
+Quote Post
jpmatrix
post Oct 3 2007, 09:30 AM
Post #27





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(Chero @ Oct 3 2007, 05:54 PM) *
QUOTE(ZDevil @ Oct 3 2007, 05:37 PM) *
QUOTE(jpmatrix @ Oct 3 2007, 05:32 PM) *
QUOTE(Chero @ Oct 3 2007, 05:19 PM) *
dvfm: command not found sad.gif


bad news: i've broker my X server
i wanted to disable auto X login on boot
so i update-rd.c -f remove xdm
then apt-get remove xdm

now /opt/kdrive/Xfbdev complains about libXfont.so.1 that it cannot found............
any help please???????


How about reinstalling the libxfont1 package?


Did you only remove xdm or also the so-called not longer needed packages ?
Maybe just apt-get install xdm again and only remove it from rc.d.

At least your BT card works .... wink.gif

Chero.


playing with apt-get i succeed in reinstalling things... but now i can only log to X as root... it says my usual user is forbidden...
i guess i'd find the answer on google but feel free to help me wink.gif

guys we're trashing this bluetooth thread! what about opening a new kernel 2.6.22 thread?

and using wifi thread for wifi related problems ? wink.gif i'll try my asus wl110 with kernel 2.6.22 to see if it continues to work though smile.gif
Go to the top of the page
 
+Quote Post
Chero
post Oct 3 2007, 09:50 AM
Post #28





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



Good suggestion about a new thread - you took the words right out of my mouth ...
Can't test anything now - I'm creating a rootfs tarball
My kids are using both my home-boxes and all I have left is my second Zaurus, so feel free to start the thread already.

Edit : new thread created

Chero.
Go to the top of the page
 
+Quote Post
jpmatrix
post Oct 3 2007, 12:30 PM
Post #29





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



tested download speed with my belkin FT0820: speed seems limited to 9342 B/s .... (that was the same with angstrom)
with my MSI 6970 USB BT dongle, speed limit was about 43 Kb/s !
little bit disappointed....where is the bottleneck ? CF bus ? belkin limit ??
Go to the top of the page
 
+Quote Post
jpmatrix
post Oct 7 2007, 04:32 AM
Post #30





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



each time i plug my belkin cf bt card or when i resume from suspend, i've to type
hciattach /dev/ttyS4 bcsp
for it to work

do you know a way to do that automaticaly ?
Go to the top of the page
 
+Quote Post

3 Pages V  < 1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th July 2014 - 10:49 PM