OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> Installing Debian Base, Without Needing A Network Connection!
relapse808
post Dec 14 2007, 12:28 PM
Post #16





Group: Members
Posts: 70
Joined: 20-August 06
From: Phoenix, Arizona
Member No.: 10,881



cd ..
mkdir media/card .. because the SD card is automatically mounted under /media
mount dev/mmcblk0p1 media/card .. see above
dpkg-deb -x media/card/zaurus-hardware-support.deb .. I did this and it took some time, but no messages on the screen. There are in the usual method.
loadkeys usr/share/keymaps/zaurus/spitz.kmap.gz .. If you look at kernel messages on reboot this command is issued and the keys work.
depmod .. I did this and there was a pause before the prompt returned.

This step isnt working for me. when I do the dpkg it complains that I am not telling it where to extract to. Can anyone help? When I do a iwconfig I get stats for wifi0 and wlan0. I have a ambicom CF card wifi network card. If I do a ifconfig nothing happens. I did edit the blacklist file as stated and I am not sure if its doing any good. Im sorry for the questions but im still a noob at this.


EDIT: one more question....when I try to do the mkdir media/card I get multiple errors stating "FAT: Direcotry bread(block xxx) failed."
Go to the top of the page
 
+Quote Post
tux
post Dec 15 2007, 04:07 AM
Post #17





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



[quote name='relapse808' date='Dec 14 2007, 08:28 PM' post='172669']

dpkg-deb -x media/card/zaurus-hardware-support.deb .. I did this and it took some time, but no messages on the screen.

This step isnt working for me. when I do the dpkg it complains that I am not telling it where to extract to. Can anyone help?
[quote]

cool.gif I was lazy in one of my posts and did not put the complete command:

dpkg-deb -x media/card/zaurus-hardware-support.deb . sad.gif

In my defense, I was referring back to the original TitchyLinux installation page and forgot that readers might not be aware of that.

To make it absolutely clear: the . at the end of the command line is the destination for the unpacking, not a full stop.

Hope this helps with the dpkg-deb command. biggrin.gif

If I was going to install Titchy again, I would use the original method from the Titchy site. YMMV but I find it less fiddly than the method in this thread. smile.gif
Go to the top of the page
 
+Quote Post
relapse808
post Dec 15 2007, 10:49 AM
Post #18





Group: Members
Posts: 70
Joined: 20-August 06
From: Phoenix, Arizona
Member No.: 10,881



i need some help. I have got to the part where i need to do the apt-get update and get a error stating invalid skb->cb magic. What can I do about this? Its coming from the wireless card and I get the same error trying to ping my gateway.

Also worth noting is I have now installed debian the original way from the network instead of off the sd card.


edit : ok the blacklist got the card to work but now I cannot ping my gateway. Also after a reboot I lost the zaurus key config and tab will no longer make a / Can someone please help me.
Go to the top of the page
 
+Quote Post
tux
post Dec 15 2007, 01:13 PM
Post #19





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



QUOTE(relapse808 @ Dec 15 2007, 06:49 PM) *
i need some help. I have got to the part where i need to do the apt-get update and get a error stating invalid skb->cb magic. What can I do about this? Its coming from the wireless card and I get the same error trying to ping my gateway.

Also worth noting is I have now installed debian the original way from the network instead of off the sd card.


edit : ok the blacklist got the card to work but now I cannot ping my gateway. Also after a reboot I lost the zaurus key config and tab will no longer make a / Can someone please help me.

cool.gif If you repeat the command from the TitchyLinux installation page that starts loadkeys you'll get your keymap back. About the wifi problem you probably need to edit /etc/network/interfaces file. Try the command nano etc/network/interfaces. You should already have one and can edit it to suit. smile.gif

Here is my interfaces file from my TitchyLinux install with comments: wink.gif

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
# if you later install dhcp clients then you can comment out the iface line with static in it and the other lines with the IP information
# You would then uncomment the following line

#iface eth0 inet dhcp


# You need to use the following lines at first
iface eth0 inet static
address an available address on your wifi network
netmask 255.255.255.0
network your router IP with 0 as the last figure
broadcast your router IP with 255 as the last figures
gateway your router IP

# wireless-* options are implemented by the wireless-tools package
wireless-mode managed
wireless-essid your network's essid
wireless-key1 your wep key If you are using wep, otherwise comment it out.
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers your router IP

However you might prefer to look through this forum for wifi problems or at the Wiki pages that ZDevil and friends have set up to guide Debian installation. He has put an example interfaces file on there. biggrin.gif

Good luck! cool.gif

OOPS! Don't forget to do depmod -a after a reboot until you have finished all this post-install fiddling. smile.gif
Go to the top of the page
 
+Quote Post
relapse808
post Dec 15 2007, 01:43 PM
Post #20





Group: Members
Posts: 70
Joined: 20-August 06
From: Phoenix, Arizona
Member No.: 10,881



hahah. the problem was so easy. What i was doing was resetting the device with the button. I removed the battery and then rebooted which actually corrected everything and Ijust finished the install. Thanks for the help.
Go to the top of the page
 
+Quote Post
t1tough
post Jan 18 2008, 08:59 PM
Post #21





Group: Members
Posts: 3
Joined: 25-February 06
Member No.: 9,233



I have successfully installed titchy. After starting xdm with login windows displayed, I cannot login with "incorrect login" error message displayed. I use "root" as login name and the password that I changed myself but without success. I have even tried all possible combinations of login and password but still with no luck. Please help!!!
Go to the top of the page
 
+Quote Post
jpmatrix
post Jan 19 2008, 05:17 AM
Post #22





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(t1tough @ Jan 19 2008, 05:59 AM) *
I have successfully installed titchy. After starting xdm with login windows displayed, I cannot login with "incorrect login" error message displayed. I use "root" as login name and the password that I changed myself but without success. I have even tried all possible combinations of login and password but still with no luck. Please help!!!


tux said here :
"root user starts out with password kuroadmin"
Go to the top of the page
 
+Quote Post
t1tough
post Jan 19 2008, 06:31 AM
Post #23





Group: Members
Posts: 3
Joined: 25-February 06
Member No.: 9,233



QUOTE(jpmatrix @ Jan 19 2008, 09:17 PM) *
QUOTE(t1tough @ Jan 19 2008, 05:59 AM) *
I have successfully installed titchy. After starting xdm with login windows displayed, I cannot login with "incorrect login" error message displayed. I use "root" as login name and the password that I changed myself but without success. I have even tried all possible combinations of login and password but still with no luck. Please help!!!


tux said here :
"root user starts out with password kuroadmin"


I have already changed the ROOT password in the text mode. Also, I can login with the changed password as ROOT in text mode. However, when I enter the said password for ROOT in the login window (GUI), there always an error message of "incorrect login". Please help.
Go to the top of the page
 
+Quote Post
Capn_Fish
post Jan 19 2008, 09:38 AM
Post #24





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



It'd possible the GUI is set to not allow root to log in. I know some distros do that.
Go to the top of the page
 
+Quote Post
tux
post Jan 19 2008, 02:25 PM
Post #25





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



QUOTE(Capn_Fish @ Jan 19 2008, 05:38 PM) *
It'd possible the GUI is set to not allow root to log in. I know some distros do that.

cool.gif The Titchy distro isn't set up that way! smile.gif

You say that you can login from the commandline? Try adding a normal user as well and install sudo.

Have you set up the date and time and did you do hwclock -w and reboot? That cured some of my problems with logging in graphically. I seem to remember having the same problem a good while ago. I think it was related to setting up the hardware clock. I suspect that your system is trying to make you set a new password because the date settings are saying that it is time for a password change. The gui login can't cope with that. smile.gif

I'm sorry to be unclear in my explanation: but try a commandline session with the date setting and hwclock command followed by a reboot. Then, login to the commandline and start the X system. I hope it will cure your problem. unsure.gif

I'd also recommend installing ssh-server and using your desktop to login in while you experiment with your Z. It has saved my sanity on many occasions! biggrin.gif

Cheers
Go to the top of the page
 
+Quote Post
t1tough
post Jan 19 2008, 07:36 PM
Post #26





Group: Members
Posts: 3
Joined: 25-February 06
Member No.: 9,233



QUOTE(tux @ Jan 20 2008, 06:25 AM) *
You say that you can login from the commandline? Try adding a normal user as well and install sudo.

Have you set up the date and time and did you do hwclock -w and reboot? That cured some of my problems with logging in graphically. I seem to remember having the same problem a good while ago. I think it was related to setting up the hardware clock. I suspect that your system is trying to make you set a new password because the date settings are saying that it is time for a password change. The gui login can't cope with that. smile.gif

Cheers


You are right. The system always ask for setting a new password after each login.

I have set the date and time with "date -s" command and confirmed it is correct. After reboot, the time reset to 2 Jan 1970. However, when I repeat the date and time setting then "hwclock -w", there is a message "Cannot access the Hardware Clock via any known method.". Is there something wrong?

By the way, could you please advise the syntac for adding a user. Thanks a lot for your help.




Go to the top of the page
 
+Quote Post
tux
post Jan 20 2008, 01:31 AM
Post #27





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



cool.gif adduser fred or whatever name you want to have for your user. Then just answer the questions as it proceeds. biggrin.gif

If you take a look inside the zaurus-hardware-support.deb from the TitchyLinux site you will find some files that are for setting up the hardware clock. Look for something about hwclock rules. I forget exactly where the files are. sad.gif When you find them: copy them to the proper place on your Z. This is a lot easier to do if you are using ssh from a terminal on your desktop. smile.gif

I'm sorry I can't be more specific but I'm about to go out for the day. I'll do some investigating this evening and try to get back to you then. I would hope that some cleverer chap will help you out before then...

Good luck!

PS try a search in this forum for hwclock or hwclock rules, the answer might be here already.
Go to the top of the page
 
+Quote Post
tux
post Jan 20 2008, 10:27 AM
Post #28





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



cool.gif In the zaurus-hardware-support.deb, look using an archive manager, you will find hwclock.rules at /etc/udev/rules.d... If you copy this file into /etc/udev/rules.d on your Z you will probably persuade hwclock -w to work. This might then solve your X login problems.

Good lick. biggrin.gif
Go to the top of the page
 
+Quote Post
gojira
post Jan 25 2008, 10:01 PM
Post #29





Group: Members
Posts: 124
Joined: 16-January 05
Member No.: 6,248



QUOTE(tux @ Jan 21 2008, 04:27 AM) *
cool.gif In the zaurus-hardware-support.deb, look using an archive manager, you will find hwclock.rules at /etc/udev/rules.d... If you copy this file into /etc/udev/rules.d on your Z you will probably persuade hwclock -w to work.


just tried installing with zImage-2.6.20-cpufreq.bin. zaurus-hardware-support is already installed in the image, so the udev rules are there, but udev insn't installed (and I haven't got networking up yet). the rules say to make /dev/rtc a link to /dev/rtc0 (253,0). I tried that but still no joy from hwclock. does anyone have a working hwclock? which kernel are you using?

thanks!

Edit: never mind, it works after an aptitude update and aptitude install titchy-desktop. I guess udev sorted it out...
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st July 2014 - 09:37 AM