OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Abicom Vs Hostap [solved], need working config
e.stoiber
post Oct 14 2007, 12:35 PM
Post #1





Group: Members
Posts: 9
Joined: 2-October 07
Member No.: 20,775



hi,

I followed the guide for installing without a network connection.

Now i fail at my wireless setup !

Everytime i insert my ambicom card the hostap driver gets loaded even after i put them into
/etc/modprobe.d/blacklist

I tried this with kernel 2.6.17 and 2.6.22.

could someone with a working ambicom card post his configuration please ??

TIA holger

p.s. at boot i get errors about mounting local filesystems, but all is working ????
p.p.s. How do we set the hw clock the machine is complaining about this at shutdown ????
Go to the top of the page
 
+Quote Post
ZDevil
post Oct 14 2007, 12:42 PM
Post #2





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Hey, first you need to provide more information:

1) Which model are you running Debian on?

2) What kind of filesystem error did you see? Could you post/type it here?

3) What does dmesg say when you plug the Ambicom card in? And what does "pccardctl status" say about the card?

4) Have you set up the profile for the Ambicom card properly? And how about the files /etc/network/interfaces, /etc/resolv.conf?

5) There are some discussions already about issues concerning the Ambicom card in the recent threads. Have you tried those suggestions?
(Actually I got both the Ambicom and the Symbol Spectrum 24, but I can only get the latter working after upgrading to Lenny. Both cards work under Etch, though.)
Go to the top of the page
 
+Quote Post
e.stoiber
post Oct 15 2007, 08:51 AM
Post #3





Group: Members
Posts: 9
Joined: 2-October 07
Member No.: 20,775



My Ambicom is finally up and running, with hostap_cs drivers !

I had to do all configuring on the shell,......wrote a little script and now i'm upgrading.

Don't know yet why the interfaces file does not work, but it really doesn't matter to me.

The mount error on startup was from an entry in fstab.

The only thing left is the complaining about not beeing able to set the hw clock.
Go to the top of the page
 
+Quote Post
ZDevil
post Oct 15 2007, 10:28 AM
Post #4





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



That's interesting. I was thinking that the Ambicom card can only use the orinoco but not hostap driver?

Could you share the script here? Thanks.
Go to the top of the page
 
+Quote Post
dlj0
post Oct 15 2007, 05:17 PM
Post #5





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(ZDevil @ Oct 15 2007, 02:28 PM) *
That's interesting. I was thinking that the Ambicom card can only use the orinoco but not hostap driver?

Could you share the script here? Thanks.


This is true for my Ambicom card, but I think it depends upon the age of the firmware.
Go to the top of the page
 
+Quote Post
Raul
post Aug 16 2008, 03:40 PM
Post #6





Group: Members
Posts: 133
Joined: 10-February 06
Member No.: 9,110



My card (ambicom wl1100c) firmware is old and I cannot get it to work either with orinoco (it worked before upgrade) nor hostap drivers. I have to find somebody with laptop and pcmcia port (I have a macbook which doesn't come with one).
I've tried most of the solution on the forum and googled for some but it didn't work.
Go to the top of the page
 
+Quote Post
maemorandum
post Aug 19 2008, 10:54 AM
Post #7





Group: Members
Posts: 57
Joined: 12-March 08
From: North Pole
Member No.: 21,496



QUOTE(Raul @ Aug 17 2008, 01:40 AM) *
My card (ambicom wl1100c) firmware is old and I cannot get it to work either with orinoco (it worked before upgrade) nor hostap drivers. I have to find somebody with laptop and pcmcia port (I have a macbook which doesn't come with one).
I've tried most of the solution on the forum and googled for some but it didn't work.


The AmbiCom Card works perfect with the hostap drivers of the 2.6.23 kernel.
I had many problems using the hostap drivers with the 2.6.24 kernel.
Strange: they seemed to overkill the transmit-power and then broke down. So i guess, getting hostap to work might be a problem of the 2.6.24 kernel.

Nevertheless, hostap is the better solution than orinoco and now i am able to connect to wpa with tkip encrypted networks out of the box, but had to blacklist orinoco and hermes first. This card has a very low power-consumption, which was the usp for me.

If you decide a firmware-upgrade, you have to apt-get the hostap-utils and flash the firmware-files with the prism2.srec command.
Go to the top of the page
 
+Quote Post
Raul
post Aug 19 2008, 01:21 PM
Post #8





Group: Members
Posts: 133
Joined: 10-February 06
Member No.: 9,110



>>The AmbiCom Card works perfect with the hostap drivers of the 2.6.23 kernel.
Question is if the andromeda will work with 2.6.23 kernel and modules.

>>If you decide a firmware-upgrade, you have to apt-get the hostap-utils and flash the firmware-files with the prism2.srec command.
I've tried but without succes - the problem is with renamed card name - it's wifi0_rename.
Go to the top of the page
 
+Quote Post
band-aid
post Aug 24 2008, 12:12 PM
Post #9





Group: Members
Posts: 37
Joined: 30-July 07
Member No.: 18,631



I too have tried to flash my card but it appears the hostap driver that are installed by default do not have firmware download support enabled. My attempts to get new drivers compiled have failed miserably. Any suggestions?
Go to the top of the page
 
+Quote Post
Raul
post Sep 20 2008, 02:43 PM
Post #10





Group: Members
Posts: 133
Joined: 10-February 06
Member No.: 9,110



I've done the firmware upgrade on Windows (I could make card to work with prism2_srec, the same firmware flashed on Windows instatly).
Now I will try to make it work with hostap.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th September 2014 - 03:28 AM