OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Gpsp Gba Emulator For Cacko/sharp Roms
post Oct 21 2007, 09:49 AM
Post #1

Group: Members
Posts: 297
Joined: 27-October 04
Member No.: 5,233

Who wants a near full speed and very playable GBA emulator for the Sharp Roms. Suhami(is that his name?) compiled the original gpsp for pdaxrom and I ported it to the sharp rom (http://www.suhami.net/ez/?page_id=7).
It needed a compiler upgrade, the 2.95 gcc is not up to the task of compiling anything anymore.
Gpsp since it is made for the psp and then ported to gp2x has very good arm assembly optimisation for near full speed play. I have tried many games and most of them are very playable.
I am including the executable in this post as well as the script needed to play it in zemu frontend. I have modified Suhami's code to change the key bindings to
If you dont like these keys suhami aslo mentions in his website and i checked his code that you can use the environment variable GPSPKEYS as shown below to use your favorite keys.

GPSPKEYS= L,R,Down,Up,Left,Right,Start,Select,B,A
$ export GPSPKEYS=303,120,274,273,276,275,13,32,306,308

I am sorry not to ipk it but maybe someone can do it for me... and oh yes you need libsdl for it.

Go to the top of the page
+Quote Post
Start new topic
post Nov 3 2007, 02:07 PM
Post #2

Group: Members
Posts: 1,853
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821

I chmod +x /opt/QtPalmtop/bin/zemufeex_gba.sh and gpsp

I tried these 3 libsdl IPKs, none of them have libsdl.so.0.7.2

So I tried loading it with
All the above IPKs have these same files.

zemu didn't launch the game, it just tried and went back to the file browser.
When I tried launching gpsp in a console, after CD-ing to /opt/QtPalmtop/bin, my Z would just freeze up.
I tried launching it in a console with each of the above SDL libs installed seperately.
The GUI installer won't let you install a different version without un-installing the previous one.

The only method that has worked for me so far, is to open a console that has "run in magnified screen" checked.
This is the only way I can launch gpsp without it freezing up my Zaurus.
This launches gpsp front end where you can change settings, or load a game through a text type file browser.
However, the controls are backwards.
I have a 2nd copy of qkonsole binary renamed to qkonsole2, just for turbografx CD games.
It behaves separately from the original QKonsole and has it's own .desktop file.
I don't remember how the turbografx CD games are handled in this console,
I'll have to look up my instructions for launching TG-CD games, since I have removed them from my hard drive on this Zaurus.
The controls for those games were correct.
Go to the top of the page
+Quote Post

Posts in this topic
tovarish   Gpsp Gba Emulator For Cacko/sharp Roms   Oct 21 2007, 09:49 AM
bolbit   hi, i'm very interested by this emulator, from...   Oct 31 2007, 08:50 AM
tovarish   strange someone deleted the attachment i had there...   Oct 31 2007, 09:55 AM
bolbit   thanks !!   Nov 1 2007, 05:24 AM
bolbit   hi, bad news, on a C1000 with cacko 1.23, and afte...   Nov 1 2007, 10:12 AM
sidmoraes   QUOTE(bolbit @ Nov 1 2007, 10:12 AM) hi, ...   Nov 1 2007, 11:39 AM
bolbit   thanks, that was that!.   Nov 2 2007, 06:05 AM
Jon_J   gpsp-qt_0.9-SDL-3_arm.ipk places "gpsp" ...   Nov 2 2007, 08:04 AM
Jon_J   I figured that gba_bios.bin needed to be placed in...   Nov 2 2007, 01:26 PM
sidmoraes   QUOTE(Jon_J @ Nov 2 2007, 01:26 PM) I fig...   Nov 2 2007, 07:02 PM
bolbit   Jon_J, you need to place the gba_bios.bin in the s...   Nov 3 2007, 03:04 AM
Jon_J   Here's what I have tried so far: 1. I tried th...   Nov 3 2007, 06:54 AM
sidmoraes   QUOTE(Jon_J @ Nov 3 2007, 06:54 AM) Here...   Nov 3 2007, 10:40 AM
Jon_J   I chmod +x /opt/QtPalmtop/bin/zemufeex_gba.sh and ...   Nov 3 2007, 02:07 PM
sidmoraes   We need to investigate this case with anther aproa...   Nov 3 2007, 06:07 PM
Jon_J   QUOTE(sidmoraes @ Nov 3 2007, 08:07 PM) W...   Nov 4 2007, 07:26 AM
tovarish   what happens when you do this in a terminal window...   Nov 4 2007, 09:11 AM
Jon_J   QUOTE(tovarish @ Nov 4 2007, 11:11 AM) wh...   Nov 4 2007, 09:29 AM
sidmoraes   "./" is your current directory! only...   Nov 4 2007, 11:20 AM
tovarish   QUOTE(sidmoraes @ Nov 4 2007, 08:20 PM) g...   Nov 4 2007, 10:30 PM
bolbit   hi, i had the same issue, the way to run gpsp from...   Nov 9 2007, 07:06 AM
bolbit   To summarize zemuf & gpsp & cresho setup :...   Dec 25 2007, 08:22 AM
AltairTK   QUOTE(bolbit @ Dec 25 2007, 08:22 AM) To ...   Jan 31 2011, 08:32 AM
Jon_J   QUOTEExcuse me if i resumed an old thread, but the...   Feb 1 2011, 12:09 PM
AltairTK   QUOTE(Jon_J @ Feb 1 2011, 12:09 PM) QUOTE...   Feb 2 2011, 07:11 AM
Darth_Sith   I can't get it working. Run in shell (640x480)...   Feb 9 2008, 08:07 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd May 2018 - 06:09 AM