OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Sl-c3000 Cacko Beta 1 Wireless Problems, Socket Spectrum24 LA4137
Daedelus
post Oct 21 2007, 11:17 AM
Post #1





Group: Members
Posts: 8
Joined: 11-October 05
From: BC, Canada
Member No.: 8,294



I've spent the last Day and a half trying to get this card working in Cacko, I've searche around on the fourms and have found other people get it working properly, but when I try and follow the steps it dosn't work. I just flashed back from pdaxii13 where the card worked perfectly. Currently I can't get this card to work properly on my Cacko beta 1 install. I insert the card and it recognizes with the normal task bar alert. I've setup a profile specific to my network, and the connect button remains grayed out. Clicking current reveals that I have:
CODE
Avaible service.
Wireless Lan Service : Off Line
MAC Address :     MY:MA:CA:DD:RE:SS
AP Address:         (Blank)


heres what my spectrum.conf looks like
CODE
device "spectrum_cs"
#  class "network" module "hermes", "orinoco", "spectrum_cs"
  class "spectrum" module "hermes", "orinoco", "spectrum_cs"
#  class "hostap" module "hermes", "orinoco", "spectrum_cs"

card "Spectrum24 LA4100 Series WLAN PC Card"
  manfid 0x026c, 0x0001
  bind "spectrum_cs"

card "Socket Communications CF+ LP WLAN Card"
  manfid 0x0104, 0x0001
  bind "spectrum_cs"

Line 3 was added for testing purposes, I'll get to that a little further down.
I adjusted the card line to accurately reflect the line from cardctl ident.

Here's some command output.

Dmesg:
CODE
eth0: Station identity 0021:0002:0002:0001
eth0: Looks like a Symbol firmware version [F3.10-06] (parsing to 31006)
eth0: Ad-hoc demo mode supported
eth0: IEEE standard IBSS ad-hoc mode supported
eth0: WEP supported, 104-bit key
eth0: MAC address MY:MA:CA:DD:RE:SS
eth0: Station name "Prism  I"
eth0: ready
eth0: index 0x01: Vcc 3.3, irq 135, io 0xf6000000-0xf6000047
pxa_pcmcia_suspend(0)
hermes @ IO 0xf6000000: Card removed while issuing command.
hermes @ IO 0xf6000000: Card removed while issuing command.
...
spectrum_cs: AccessConfigurationRegister: Configuration locked
eth0: Error – 16 shutting down Hermes chipset
pxa_pcmcia_suspend(0)
I'm not removing the card. That goes on for about 20 lines before the card hits suspend and the hermes module is unloaded

iwconfig:
CODE
eth0      IEEE 802.11-DS  ESSID:""  Nickname:"zaurus"
          Mode:Managed  Frequency:42.9497GHz  Bit Rate:11Mb/s   Tx-Power=15 dBm  
          RTS thr:off

cardctl status
CODE
Socket 0:
  3.3V 16-bit PC Card [suspended]

cardctl ident
CODE
Socket 0:
  product info: "Symbol", "Spectrum24 LA4100 Series WLAN PC Card", "1.00"
  manfid: 0x026c, 0x0001
  function: 6 (network)

cardctl resume
CODE
ioctl(): device or resource busy

sudo ifconfig eth0 up
CODE
SIOCSIFFLAGS: Device or resource busy


I get the folowing results if I swap the lines in spectrum.conf as follows.

CODE
#  class "network" module "hermes", "orinoco", "spectrum_cs"
#  class "spectrum" module "hermes", "orinoco", "spectrum_cs"
  class "hostap" module "hermes", "orinoco", "spectrum_cs"


Normal Insertion popup.
Current tab lists No available services in the current tab, and the connect button remains greyed out.

Dmesg:
CODE
eth0: Station identity 0021:0002:0002:0001
eth0: Looks like a Symbol firmware version [F3.10-06] (parsing to 31006)
eth0: Ad-hoc demo mode supported
eth0: IEEE standard IBSS ad-hoc mode supported
eth0: WEP supported, 104-bit key
eth0: MAC address MY:MA:CA:DD:RE:SS
eth0: Station name "Prism  I"
eth0: ready
eth0: index 0x01: Vcc 3.3, irq 135, io 0xf6000000-0xf6000047


Iwconfig:
CODE
eth0      IEEE 802.11-DS  ESSID:""  Nickname:"Prism  I"
          Mode:Managed  Frequency:2.412GHz  Access Point: 00:00:00:00:00:00  
          Bit Rate:11Mb/s   Tx-Power=15 dBm  
          Retry limit:16   RTS thr:off   Fragment thr=0 B  
          Power Management:off
          Link Quality:0/92  Signal level:134/153  Noise level:134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


cardctl status:
CODE
Socket 0:
  3.3V 16-bit PC Card
  function 0: [busy]


I am able to manually enter my ESSID, and WEP key to iwconfig in this state, and bring eth0 up with ifconfig. I am then able to ping off of google.ca, but when I attempt to access netfront, it tells me that I'm offline, and I don't have a properly setup profile.

Any help getting this matter resolved would be greatly appriciated. Thanks in advance =D

-- Daedelus
Go to the top of the page
 
+Quote Post
Daedelus
post Oct 21 2007, 01:10 PM
Post #2





Group: Members
Posts: 8
Joined: 11-October 05
From: BC, Canada
Member No.: 8,294



Well, I managed to dummy it up a bit and get connected. I changed the Spectrum.conf to the following
CODE
  class "network" module "hermes", "orinoco", "spectrum_cs"
#  class "spectrum" module "hermes", "orinoco", "spectrum_cs"
#  class "hostap" module "hermes", "orinoco", "spectrum_cs"

this seems to make the Z think that it's a wired connection, and I need to have a dummy wired connection in the network settings to make the connection work. I still have to enter ESSID and WEP key through iwconfig, so it's only really a partial work around. If anyone can let me know how to get this card working as a network card, it would be much appricated.

Thanks

--Daedelus.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th July 2014 - 03:02 PM