OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Dev_img-1.6 Setup Trouble, SL-C860 Sharp ROM 1.31 JP
Meyer
post Nov 16 2007, 10:33 PM
Post #1





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



dev_img-1.5 worked fine until several months ago when gcc started segment faulting. Decided to try upgrading to 1.6 to solve the problem, but I can't get the set-up script to run successfully. Does something need to be installed first to use squashfs instead of the previous image's cramfs? Have tried running more than once removing all the 1.5 configuration I could find.

CODE
# sh image_setup.sh /usr/mnt.rom/card/dev_img-1.6 /mnt/dev
Setting mount point /mnt/dev...
Mounting image /usr/mnt.rom/card/dev_img-1.6...
mount: Mounting /usr/mnt.rom/card/dev_img-1.6 on /mnt/dev failed: No such device
Failed to mount image /usr/mnt.rom/card/dev_img-1.6 on /mnt/dev


Is there a better forum for this topic?
Go to the top of the page
 
+Quote Post
speculatrix
post Nov 17 2007, 02:15 PM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



check that the file on your SD card is actually there, and has non-zero size.

/usr/mnt.rom/card/dev_img-1.6

I think, from memory, that /mnt/card is a link to /usr/mnt.rom/card so check both locations, maybe the soft link is broken, the card isn't being mounted correctly (using fat16, fat32 or ext2/3??), or the file is corrupted??
Go to the top of the page
 
+Quote Post
Meyer
post Apr 6 2008, 09:53 PM
Post #3





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



Having made no progress on this problem, I've been making-do with zgcc for on-board compiling for the last few months, until today when I wanted to compile something that uses the curses library. Finding no IPKG for libcurses, I decided to give dev_img-1.6 another try.

Still no success, but I may have found the cause for image file failing to mount. My kernel is version 2.4.18-rmk7-pxa3-embedix (Sharp ROM 1.31 JP), but my squashfs module is compiled for kernel 2.4.20. This give me three possible ways forward:
  1. Find a squashfs IPKG for kernel 2.4.18...
  2. Find a copy of dev_img-1.5, which uses known-to-work cramfs instead of squashfs.
  3. Compile squashfs myself, which will require a kernel patch.

Anyone know where I can find the targets of 1. or 2., or a painless way to do 3.?

Zaurus is SL-C860.
Go to the top of the page
 
+Quote Post
sdjf
post Apr 16 2008, 07:15 PM
Post #4





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



I don't have the patience to wade through the results but you might also try google's code search:

http://google.com/codesearch?hl=en&lr=...amp;btnG=Search

Anything useful there? Nothing came up for the dev img you wanted. Might also try meta engine like dogpile.com

When we needed a copy of my 2.4.6 kernel, I used google to help me locate people who had been involved in development of applications for it, and one of them still had a copy and pointed us to the right ftp sites.

Hopefully someone here will see your query and respond.
sdjf
Go to the top of the page
 
+Quote Post
speculatrix
post Apr 17 2008, 04:30 AM
Post #5





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



when I made a squashfs archive of the oesf forums, I had to use an old version of squashfs - version 2.

new kernels with squashfs v3 filesys will mount old v2 files, but not vice versa.

some notes/comments here: http://www.zaurus.org.uk/squashfs.html
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th September 2014 - 11:56 AM