OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Images, Not currently working
koan
post Nov 22 2007, 07:07 PM
Post #1





Group: Members
Posts: 328
Joined: 25-February 04
From: UK
Member No.: 2,025



@Meyer/tux:

Easier said than done, but: we need images working.

Is it possible to make a plan to investigate required fixes and get them working ?

thanks
Go to the top of the page
 
+Quote Post
tux
post Nov 23 2007, 02:34 AM
Post #2





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



QUOTE(koan @ Nov 23 2007, 03:07 AM) *
@Meyer/tux:

Easier said than done, but: we need images working.

Is it possible to make a plan to investigate required fixes and get them working ?

thanks


cool.gif Some pages have images that display. Other pages have links to images that don't display. The images are present. If you look in Special Pages and look at Images unsure.gif , my memory for the exact page name fails me, you can access them. However the problem of displaying them on their pages seems to be related to the error message about not being able to create thumbnails. This appears to be something to do with permissions on creating directories.

There seem to be some limitations on size for some working directories and on permissions for functions to work on some directories. I suppose this is a legacy of the move from one provider to the other?

Ping dz! Ping dz! Ping dz!

I suppose this could be related to the apparent disappearance of the download files/facility from the ZUG page/portal? I'm sure that the problem about uploading images/files etc are also related to this.

I will look, but my time seems a bit limited at the moment... smile.gif

I think a post or two containing the error messages when we try to access images might be helpful?

Cheers cool.gif
Go to the top of the page
 
+Quote Post
koan
post Nov 23 2007, 04:28 AM
Post #3





Group: Members
Posts: 328
Joined: 25-February 04
From: UK
Member No.: 2,025



QUOTE(tux @ Nov 23 2007, 02:34 AM) *
I will look, but my time seems a bit limited at the moment... smile.gif

I think a post or two containing the error messages when we try to access images might be helpful?


First problem: Uploads are disabled so we can't add any new images.

Second problem: Viewing an image in the filelist broken seems to be a permissions problem, exemplified here: Page with image link but broken and here: Permissions and thumbnails problem at Uncategorized Images

The error is
CODE
Warning: mkdir() [function.mkdir]: Permission denied in /public/vhost/o/oesf/html/includes/GlobalFunctions.php on line 1671


This should be enough to get started...
Go to the top of the page
 
+Quote Post
Meyer
post Dec 5 2007, 10:45 AM
Post #4





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



I will look into the problem over the weekend. Definitely a high priority to fix.
Go to the top of the page
 
+Quote Post
Meyer
post Dec 9 2007, 11:07 AM
Post #5





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



I have enable image uploading, but have been unable to test it completely because now the Bad Behavior anti-spam extension is blocking me. I will now have to teach Bad Behavior a lesson on good manners before proceeding with upload testing and the image gallery bug.
Go to the top of the page
 
+Quote Post
Meyer
post Dec 9 2007, 11:46 AM
Post #6





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



Enabling Image Support Work Log

(This post is technical notes on the process of enabling image uploading and correcting the image gallery bug on OESF Wiki. I am recording it hear since a bug in our anti-spam software has me temporarily locked out of changing the wiki. I will transfer this information to the wiki once I am able to. I will update this post or its successor wiki page as I progress.)

1. Enabling File Upload

Relevant articles on MediaWiki and SiteGround.

Our LocalSettings.php sets only the pre-1.5 version parameter, $wgDisableUploads (to false, which would supposedly work if our wiki was still pre-1.5), so I comment-out that line and add a setting for the 1.5+ parameter:

CODE
$wgEnableUploads                = true;


Now I can open the the wiki upload page.

2. Ain't Misbehavin'

Filling-in and submitting the upload form returns the following HTTP error page, which I believe is generated by the Bad Behavior anti-spam extension and not by MediaWiki itself (this is not the same as the error previously reported by gaarder):

QUOTE
Error 403

We're sorry, but we could not fulfill your request for /index.php?title=Special:Upload on this server.

Your Internet Protocol address is listed on a blacklist of addresses involved in malicious or illegal activity. See the listing below for more details on specific blacklists and removal procedures.

Your technical support key is: cbd4-2c28-1366-73cd

You can use this key to fix this problem yourself.

If you are unable to fix the problem yourself, please contact michael.hubbard at gmail.com and be sure to provide the technical support key shown above.


The technical support key links to http://www.ioerror.us/bb2-support-key?key=...-2c28-1366-73cd:

QUOTE
Technical Support

Your request was intercepted by Bad Behavior, security software which protects the Web site you visited from malicious activity, such as hackers, spam and viruses. We apologize for the inconvenience, but your request matched a profile of suspicious activity. This problem is usually quite easy to fix.

Your request was blocked because of malicious automated requests received from your computer's IP address.

Your computer's IP address was determined to have recently sent spam or engaged in malicious activity as reported by a third-party monitoring service. This means your computer is most likely infected with viruses or other malicious software. See below for more information and removal instructions.

This problem may be caused by viruses or spyware on your computer, or by malicious software that pretends to be anti-virus or anti-spyware software. Ensure that you have REAL anti-virus and anti-spyware software on your computer, that they are kept up-to-date, and that you have run a full system scan using each tool. Once your system is cleaned of viruses and spyware, please try your request again.

The free Google Pack provides trustworthy anti-virus and anti-spyware software.

This may also occur with old versions of Bad Behavior. If you do not see any blacklist providers listed below, and you are the site administrator, try updating to the latest version of Bad Behavior.

Blacklist Reason(s):

If the above suggestions fail to resolve the problem, click Back and contact the e-mail address you were given for further assistance.
Go to the top of the page
 
+Quote Post
tux
post Dec 9 2007, 01:15 PM
Post #7





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



cool.gif
Well Meyer, I can't log in at the wiki.. I get the same response as you and a key which takes me to the same message. sad.gif

I think it might be wise to revert your changes relating to uploads and see what happens. unsure.gif I'll try and review the files and look again at what I was looking at with regard to the problem. I'm rather pushed for time at the moment.... sad.gif

Meyer, my cursory research said to do 3, perhaps 4, things.

1. make the image directory writeable.
2. $wgEnableUploads = true; as you mention
3. and alter the DefaultSettings.php $wgFileExtensions to permit various image file extensions.
4. ?? setting StrictFileExtensions = false;

I presume you did number 1? You did number 2. I suppose the details are irrelevent if BadBehaviour is bugging us now?

I wonder if there are some security measures taken in the past that are conflicting with what you are attempting?

dz, if you get the chance please review what the changes were when you or Offroadgeek stopped file uploads. It might be relevent! blink.gif

I'll pm dz and ask him to take a look and perhaps point us in the right direction.

Cheers biggrin.gif

Go to the top of the page
 
+Quote Post
dz
post Dec 9 2007, 05:02 PM
Post #8


~


Group: Admin
Posts: 596
Joined: 2-February 04
From: Cape Canaveral, FL
Member No.: 1,667



I don't remember anyone of us stopping file uploads on the wiki. That must've happened when we upgraded or something.

Any idea where this Bad Behavior extension installs bad IP addresses? Why not just pull your ips out of there and see if it still acts up?
Go to the top of the page
 
+Quote Post
Meyer
post Dec 9 2007, 09:50 PM
Post #9





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



Directory images/ was user-writable, but not group- or others-writable when I did the work described above. I have now set it user-, group-, and others-writable, but if anything Bad Behavior is behaving worse: I'm at work now and now get the same error others have reported at login.

I have restored the pre-1.5 configuration parameter, but no apparent change in Bad Behavior behavior.

I, too, find the error message suspicious. I didn't know Bad Behavior had a black IP list and have certainly not added any addresses to it since I installed the extension, so I have know idea why it would suddenly start complaining about black IP addresses it allowed before.

I will give Bad Behavior a closer look at home tonight.
Go to the top of the page
 
+Quote Post
tux
post Dec 10 2007, 02:37 AM
Post #10





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



cool.gif Hi meyer.

I tried logging in using Dillo and also deleting all cookies in Firefox, thinking it might be a browser issue. I got the same response to trying to log on.

I'm beginning to think that BadBehaviour is a bit buggy??! unsure.gif

I might try setting up a proxy and seeing if the problem persists. blink.gif

From dz's response it doesn't look like any options set previously are likely to be causing the problem. I suppose I should stop complaining about being busy and look at the setup, directory permissions and such on the site? Don't panic I won't alter anything! biggrin.gif If I spot anything I'll email you smile.gif

Cheers
cool.gif

This post has been edited by tux: Dec 10 2007, 02:59 AM
Go to the top of the page
 
+Quote Post
koan
post Dec 10 2007, 04:42 AM
Post #11





Group: Members
Posts: 328
Joined: 25-February 04
From: UK
Member No.: 2,025



I tried to login at work this morning (behind a proxy) but BadBehaviour denied me.

I logged in from home, but http://www.oesf.org/index.php?title=Special:Upload still says uploads are disabled.
Go to the top of the page
 
+Quote Post
gaarder
post Dec 10 2007, 08:21 AM
Post #12





Group: Members
Posts: 19
Joined: 4-June 07
Member No.: 16,894



I have some suggestions on Bad Behavior in here.

Regarding upload: the reason why Special:upload says uploads are disabled is probably because Meyer set $wgEnableUploads back to false at the time you access the page. However I cannot debug the situation further unless an administrator post the current LocalSettings.php (in MediaWiki) up here.
Go to the top of the page
 
+Quote Post
dz
post Dec 10 2007, 12:48 PM
Post #13


~


Group: Admin
Posts: 596
Joined: 2-February 04
From: Cape Canaveral, FL
Member No.: 1,667



Heh, I'm no good with Wiki stuff but if I can be of any assistance let me know.
Go to the top of the page
 
+Quote Post
gaarder
post Dec 11 2007, 02:20 AM
Post #14





Group: Members
Posts: 19
Joined: 4-June 07
Member No.: 16,894



The reason why people are blocked from logging into the wiki:
QUOTE
Bad Behavior 2.0.11
December 6th, 2007 by Michael Hampton

All users should update to Bad Behavior 2.0.11 immediately to prevent being blocked from your own site.

Within the past two days users have found themselves blocked from their own sites while using recent versions of Bad Behavior. A third party blacklist which Bad Behavior queries recently began sending false positives for any IP address queried, causing everyone using Bad Behavior to be blocked. This issue is fixed in Bad Behavior 2.0.11.

Download Bad Behavior now!

P.S. Yes, Bad Behavior is still in development. More news coming soon.

Update: Some people have asked for more details on what exactly happened. In brief, yesterday I moved all of my sites to a new dedicated server. In the process, I decommissioned an old blacklist I was running which I thought wasn’t being used, not realizing that Bad Behavior was still set to use it. Shortly afterward, I found myself locked out of my own blog, just as you all did. So therefore, this release.
Go to the top of the page
 
+Quote Post
Meyer
post Dec 11 2007, 11:49 PM
Post #15





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



Thanks, again, gaarder. That indeed was the cause of the login trouble.

Back to images on the wiki. I redid the configuration parameter change documented above ($wgEnableUploads), and set not only the images/ directory but every directory in its subtree group- and other-writable.

Now I can upload image files, and all the problematic pages koan linked seem to display correctly now, other than thumbnails of PNG images showing blank (our problem? MediaWiki problem? MS IE problem?).

Let me know if you have any further problems. I'll put a summary of the image support configuration on the wiki later.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2014 - 07:44 PM