OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Wireshark On Pdaxiiv2
climber
post Nov 29 2007, 01:51 AM
Post #1





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



Meanie,

I upgraded my SL-C3100 v5.4.9 to your newest version of pdaXii13v2. I installed wireshark_0.99.6_armv5tel.ipk from
your pdaXii13v2 feed.

When I start it from command line I get the following error:

wireshark; error while loading shared libraries: /usr/lib/libportaudio.so.:
cannot open shared object file: No such file or directory

Searching for this file I found it on: /opt/native/arm/3.4.6-xscale-softvfp/arm5tel-cakco-linux/lib/lipportaudio.so
Then I created a symlink (ln -s) from this path to the /usr/lib/

Starting wireshark again: ......
..... Error 40


Do you have a idea why this do not work? dry.gif

Thanks
climber

Go to the top of the page
 
+Quote Post
Jon_J
post Jul 17 2008, 08:05 AM
Post #2





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I did a search for "lipportaudio" and only found this thread, and your more recent one.
I'm pretty sure the path below is created when you have zgcc-3.4.5-4.squashfs mounted, (or 3.4.6 version).
I would just copy
/opt/native/arm/3.4.6-xscale-softvfp/arm5tel-cakco-linux/lib/libportaudio.so
to
/usr/lib/lipportaudio.so

I don't have a compiling setup at the moment. I tried it last Winter, but some of the stuff went over my head. sad.gif

Another question, Do you have the full "spitz" version of pdaxii13 installed?
This library may be contained in another library in the "full" version.
I searched inside "hdimage-full.tgz" of "build-5.4.9-beta" and didn't find "libportaudio.so" in any of the usual places.

I just have the "Akita" version of pdaXii13v2 installed on my C3200 and didn't find this lib on my Zaurus.

On an unrelated subject:
I noticed that "Wifi-Radar" requires "flite" for some audio stuff, but it works for me without "flite".
Go to the top of the page
 
+Quote Post
Capn_Fish
post Jul 17 2008, 08:30 AM
Post #3





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Flite is just text-to-speech, so you just don't get fancy voice effects without it.
Go to the top of the page
 
+Quote Post
climber
post Jul 18 2008, 12:13 AM
Post #4





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



Yes, I found the file /opt/native/arm/3.4.6-xscale-softvfp/arm5tel-cakco-linux/lib/lipportaudio.so too but if you view it with ls -la you'll
see it in red colour. So it's not available anymore and obviously a dead link.

Maybe I've to try older or newer version of zgccc. Hopefully I found the file.

If anybody else have time to search for so please do it :-)

Thanks
climber
Go to the top of the page
 
+Quote Post
Jon_J
post Jul 18 2008, 05:46 AM
Post #5





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I found an openzaurus version of libportaudio here, but I get "you don't have permission to access this" message when using a browser in Windows to download it.
http://www.openzaurus.org/feed-browser/?ac...m=libportaudio0

If you can download it, you may be able to extract its contents using "ar"
Go to the top of the page
 
+Quote Post
climber
post Jul 21 2008, 11:39 PM
Post #6





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



In the meantime I found the needed lib.

Remove the ending of the file (.ipk) because it's library and not a ipk file.
Copy the file on the zaurus and create a symbolic link to /usr/lib

ln -s /path/to/source/libportaudio.so.0 /usr/lib

ldconfig

That's all and for me it works now :-)


climber
Attached File(s)
Attached File  libportaudio.so.0.ipk ( 50.41K ) Number of downloads: 20
 
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th July 2014 - 10:42 PM