OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Key Repeat Speed, How can this be set
dlj0
post Dec 4 2007, 07:24 PM
Post #1





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom. It is too fast for my taste in debian; I'd like to slow it down. Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat. How do you do that?
Go to the top of the page
 
+Quote Post
2or0
post Dec 5 2007, 02:00 AM
Post #2





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



QUOTE(dlj0 @ Dec 4 2007, 07:24 PM) *
I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom. It is too fast for my taste in debian; I'd like to slow it down. Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat. How do you do that?


The 'xset' command is useful to change the speed of rate of key.
xset r rate 1000
or change the number if it is too fast or too slow.
Go to the top of the page
 
+Quote Post
dlj0
post Dec 5 2007, 06:22 AM
Post #3





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(2or0 @ Dec 5 2007, 05:00 AM) *
QUOTE(dlj0 @ Dec 4 2007, 07:24 PM) *
I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom. It is too fast for my taste in debian; I'd like to slow it down. Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat. How do you do that?


The 'xset' command is useful to change the speed of rate of key.
xset r rate 1000
or change the number if it is too fast or too slow.


No joy:

xset r rate 1000
server does not have extension for "r rate" option

This is with debian/eabi (cortez' kernel) and xserver-kdrive-fbdev 1:1.3.0.0-r19 I'd be happy to try another server if someone could suggest one.
Go to the top of the page
 
+Quote Post
jpmatrix
post Dec 5 2007, 07:30 AM
Post #4





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(dlj0 @ Dec 5 2007, 03:22 PM) *
No joy:

xset r rate 1000
server does not have extension for "r rate" option

This is with debian/eabi (cortez' kernel) and xserver-kdrive-fbdev 1:1.3.0.0-r19 I'd be happy to try another server if someone could suggest one.


same result for me with angstrom kernel 2.6.23 & zdevil rootfs...

this command should work under X, but is there a non X command too ?
Go to the top of the page
 
+Quote Post
2or0
post Dec 5 2007, 08:48 AM
Post #5





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



kdrive doesn't seem to support change of the repeat rate of key. Only I could find the command to turn off key repeat.
In console: setterm -repeat off
in X: xset -r
Go to the top of the page
 
+Quote Post
gojira
post Jan 18 2009, 02:53 AM
Post #6





Group: Members
Posts: 124
Joined: 16-January 05
Member No.: 6,248



some other options would be: using the xorg server (http://www.oesf.org/forum/index.php?showtopic=26362 http://www.oesf.org/forum/index.php?showtopic=25433) adding xkb to kdrive (http://www.oesf.org/forum/index.php?showtopic=26345) or setting it in the kernel (?)

turning autorepeat off completely is better than nothing but it's annoying to lose autorepeat for space delete return and the cursor keys

attached is my script to turn off autorepeat for normal characters but have it on for editing characters
Attached File(s)
Attached File  zaurus_kdrive_autorepeat_fix.txt ( 375bytes ) Number of downloads: 23
 
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th April 2014 - 11:00 AM