OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Opie Player 2 Troubles
raji
post Dec 9 2007, 07:16 PM
Post #1





Group: Members
Posts: 2
Joined: 5-December 07
Member No.: 21,033



Dear members,

I am new to this forum.. and I joined it because I need help regarding the mediaplayer of OPIE. I am totally new to the software field and hence facing several problems ..=)

I am basically working on a mobile reference platform board, which uses the opie 1.2.0 environment. The mediaplayer 1 that comes together with opie 1.2.0, when i tested it on my reference platform, had the following performance. It refused to play video (any format) and only .mp3 and .wav audio files played.

After learning that there was an opieplayer 2, I decided to import the codecs into the current filesystem that I would port to the board. I saved the codecs to the plugins folder. I got them from the ipkgfind.com website. This time the performance was as follows. It still refused to play video, but played .ogg audio files in addition to .mp3 and .wav audio files.

In terms of streaming, the performance did not change whether i used the new opie player 2 codecs or not. It played precisely just one .ogg streaming file that i obtained ( http://auggie.wclv.com/lo.ogg). All other .ogg and .m3u streaming files i tried (http://lists.w3.org/Archives/Public/public-html/2007Oct/0097.html ) gave me a segment error, SIGFPE and terminated the application completely.

My aim is to get the player working, i.e to be able to play video files and most importantly be able to stream. According to what I have read in forum posts and the opie home page, player2 should be able to do all of the above. Am I including the player2 codecs in the wrong folder?

If any of you could help me I would be more than grateful! Thank you..

Sincerely,
Raji
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
adf
post Dec 9 2007, 07:25 PM
Post #2





Group: Members
Posts: 2,821
Joined: 13-September 04
From: Wasilla Ak.
Member No.: 4,572



QUOTE(raji @ Dec 9 2007, 06:16 PM) *
Dear members,

I am new to this forum.. and I joined it because I need help regarding the mediaplayer of OPIE. I am totally new to the software field and hence facing several problems ..=)

I am basically working on a mobile reference platform board, which uses the opie 1.2.0 environment. The mediaplayer 1 that comes together with opie 1.2.0, when i tested it on my reference platform, had the following performance. It refused to play video (any format) and only .mp3 and .wav audio files played.

After learning that there was an opieplayer 2, I decided to import the codecs into the current filesystem that I would port to the board. I saved the codecs to the plugins folder. I got them from the ipkgfind.com website. This time the performance was as follows. It still refused to play video, but played .ogg audio files in addition to .mp3 and .wav audio files.

In terms of streaming, the performance did not change whether i used the new opie player 2 codecs or not. It played precisely just one .ogg streaming file that i obtained ( http://auggie.wclv.com/lo.ogg). All other .ogg and .m3u streaming files i tried (http://lists.w3.org/Archives/Public/public-html/2007Oct/0097.html ) gave me a segment error, SIGFPE and terminated the application completely.

My aim is to get the player working, i.e to be able to play video files and most importantly be able to stream. According to what I have read in forum posts and the opie home page, player2 should be able to do all of the above. Am I including the player2 codecs in the wrong folder?

If any of you could help me I would be more than grateful! Thank you..

Sincerely,
Raji

I think opie media player is buggy and has not been fixed.
Quasar mkght work in that environment, though--if this is any help at all.
Go to the top of the page
 
+Quote Post
ofels
post Dec 10 2007, 12:00 AM
Post #3





Group: Members
Posts: 142
Joined: 4-December 06
From: Lake Constance, Germany
Member No.: 13,087



QUOTE(adf @ Dec 10 2007, 04:25 AM) *
Quasar mkght work in that environment, though--if this is any help at all.


Quasar is currently not available for Opie as the recipes in OpenEmbedded are based on qt-x11.
Somebody will have to add the appropriate OE recipes for the qtopia version (should not be a big deal though as building quasar us rather straight forward).

Oliver
Go to the top of the page
 
+Quote Post

Posts in this topic
raji   Opie Player 2 Troubles   Dec 9 2007, 07:16 PM
adf   QUOTE(raji @ Dec 9 2007, 06:16 PM) Dear m...   Dec 9 2007, 07:25 PM
ofels   QUOTE(adf @ Dec 10 2007, 04:25 AM) Quasar...   Dec 10 2007, 12:00 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 03:36 PM