OESF | ELSI (coming soon) | Community Links (coming soon) | LinuxPDA | Ibiblio


Welcome Guest ( Log In | Register )

> Zaurus C1000 Will Not Charge, I can't get my Z to charge a battery or boot.
post Dec 23 2007, 04:44 AM
Post #1

Group: Members
Posts: 22
Joined: 3-December 06
From: Raliegh, NC
Member No.: 13,079

I've seen similar posts, but have not been able to find clear answers to this one. Please forgive me if I simply didn't look hard enough.

I have been using an SL-C1000 for about a year and have been very pleased with it up until now. I noticed I wasn't getting very long battery life (a day, maybe 1.5 days) so when I plugged it in to charge and the light blinked I figured it needed a new battery. I ordered the new battery, put it in, and the Z still won't work. I've tried reflashing it from the diagnostic menu and that does not work. I've tried several of the battery sections in the service menu. I tried charging both batteries from the charge submenu and that does not work. The battery light will come on and stay on for hours, but the battery does not charge at all. I've checked the battery voltage with a separate volt meter and no change even after several hours.

The Z does seem to respond to batteries of different charge levels. The new battery only reads 3.7V on my volt meter (not the Z's Low Battery menu). The old battery shows 4.0V. If I plug in the old battery (after turning off the Z in the service menu) the battery light will stay on for about 10 minutes and then start blinking. If I try this with the old battery the battery light just starts blinking right away. The Low Battery Menu will only show 1.1V no matter which battery is in or if I even have a battery in the unit.

The only thing that works at all is reloading the original Japanese NAND and booting from the emergency console (the one you get to by holding down 'D + B'). I booted it up by typing Qt at the prompt. It took a while, but eventually I had a Japanese ROM working. However, when I pulled the power cable, it went dead. I tried charging the unit with the Japanese console and that didn't work either. If I try turning the Z off when using the Japanese NAND it will not turn on again even though I have the power cord plugged in. It seems a little inconvenient to keep it plugged in and on AND try to learn Japanese.

I also cannot get the emergency menu to come up (the one where you pull the battery, unplug the power, hold OK, plug in the power cord, put in the battery, lock the battery and then push the ON button).

I've seen a few posts that suggest replacing a fuse or some caps on the power board, but I haven't seen any clear instructions about how to do it (getting the unit apart, pulling out the ribbon cables without damaging them, where the power board is, or a good schematic, etc.). I also would rather not tear into it if there is a simple solution OUTSIDE the unit.

Go to the top of the page
+Quote Post
Start new topic
post Apr 16 2008, 12:37 PM
Post #2

Group: Admin
Posts: 3,337
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149

if you think the internal charge circuitry is b0rked, maybe an external charger would be the way forward? Or, to find a nearby owner and see if a fully charged battery will work?
Go to the top of the page
+Quote Post
post Apr 16 2008, 12:54 PM
Post #3

Group: Members
Posts: 22
Joined: 3-December 06
From: Raliegh, NC
Member No.: 13,079

QUOTE(speculatrix @ Apr 16 2008, 03:37 PM) *
if you think the internal charge circuitry is b0rked, maybe an external charger would be the way forward?

I'd be glad to go with an external charger, but it doesn't appear that the Zaurus will even work with a charged battery. I mentioned in an earlier post that I took the battery to a battery shop. They charged it for me and said it should at least have enough power to turn the Z on. They thought the battery was fine. Unfortunately the Z doesn't seem to think the battery is strong enough. This is all really strange.

1) A charged battery alone will not power up the unit.
2) Plugging in the charger will only get me to the Zaurus shell and the service menu. The "OK menu" (can't remember what it's called) will not work.
3) I can only get the unit to boot by typing "reboot" in the shell. As soon as power is removed or it's turned off I can't turn it on again.
4) If I boot the unit from the shell it works fine as long as I don't unplug it. I suppose I could get a long extension cord to reach around town.
5) I can't get any of my information out of it. I went back to the original Japanese NAND and I don't know how to load the old Cacko OS I was using without getting to the 'OK' menu.

Go to the top of the page
+Quote Post

Posts in this topic
garmiste   Zaurus C1000 Will Not Charge   Dec 23 2007, 04:44 AM
garmiste   I thought I'd mention that when I charge from ...   Dec 23 2007, 04:46 AM
Capn_Fish   Does your new battery need plastic carved away fro...   Dec 23 2007, 09:43 AM
garmiste   QUOTE(Capn_Fish @ Dec 23 2007, 12:43 PM) ...   Dec 23 2007, 09:52 AM
garmiste   Ok, I tried carving some of the plastic away from ...   Dec 23 2007, 01:03 PM
pelrun   Did you by chance select the "Battery Voltage...   Dec 23 2007, 04:36 PM
Capn_Fish   QUOTE(pelrun @ Dec 23 2007, 06:36 PM) Did...   Dec 23 2007, 05:54 PM
garmiste   I did spend some time in the battery menus so I we...   Dec 23 2007, 08:45 PM
Capn_Fish   Did you do the NAND erase/restore before doing tha...   Dec 24 2007, 08:49 AM
garmiste   Sorry for not being clear on my last post. I did ...   Dec 24 2007, 10:20 PM
speculatrix   QUOTE(garmiste @ Dec 25 2007, 06:20 AM) T...   Dec 26 2007, 01:48 PM
pelrun   The battery circuitry in the cxxxx series isn...   Dec 26 2007, 02:51 PM
garmiste   QUOTE(pelrun @ Dec 26 2007, 05:51 PM) The...   Apr 15 2008, 08:51 AM
utx   QUOTE(garmiste @ Apr 15 2008, 06:51 PM) Y...   Apr 16 2008, 10:51 AM
garmiste   QUOTEI have seen several reports here in the forum...   Apr 16 2008, 12:32 PM
speculatrix   if you think the internal charge circuitry is b0rk...   Apr 16 2008, 12:37 PM
garmiste   QUOTE(speculatrix @ Apr 16 2008, 03:37 PM...   Apr 16 2008, 12:54 PM
speculatrix   when you say you restored the original NAND, do yo...   Apr 16 2008, 02:09 PM
garmiste   QUOTE(speculatrix @ Apr 16 2008, 05:09 PM...   Apr 16 2008, 06:20 PM
sdjf   I vaguely recall someone saying that there is anot...   Apr 16 2008, 07:04 PM
speculatrix   QUOTE(sdjf @ Apr 17 2008, 04:04 AM) I vag...   Apr 17 2008, 04:22 AM
sdjf   I am surprised no one has asked if you have ever d...   Jun 23 2008, 05:46 PM
HRH_H_Crab   Don't really have much to add to the thread ex...   Jul 9 2008, 11:32 PM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 28th April 2017 - 07:41 PM