OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Angstrom 2007.12 Pcmcia Issue, Can't get my PCMCIA Wlan Card up and running
x75
post Jan 1 2008, 11:01 AM
Post #1





Group: Members
Posts: 2
Joined: 1-January 08
Member No.: 21,145



Hi there,

i just installed the new Angstrom x11 Image on my SimPad SLC. Works nice.
But i can't find a way to get my Wlan Card up and running. The card works, I used it under familiar before.

If I click on "PC/CF Cards" under Settings, I get an error message "PCMCIA initialisation failed No PCMCIA driver in '/proc/devices'"
If i open the "Root shell" and type in "pccardctl ident" it finds the card at Socket 0 and knows it's a function 6 (network) card.

What am I missing here? Can someone point me to a manual somewhere, that explains how to get the pcmcia card running under angstrom?

Thanks
Johannes
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Martin
post Jan 6 2008, 04:21 AM
Post #2





Group: Members
Posts: 138
Joined: 5-October 04
From: konstanz, germany
Member No.: 4,874



Hi :-)

I try to test it too with my Simpad SL4 ... GREAT WORK

... first issue are the basic functions ...

- flashing with serial console vie USB / serial adapter work fine (little slow with serial) ...
- on first startup to set clock and timezone no virtual keyboard available ...
- missing berlin/german timezone / german localization (maybe I am able to help!)
- missing usbnet support on Simpad ...

... second with some enhanced features ...

- my SIEMENS I-GATE 11M WLAN card is not recognized ... no WPA :-( for wlan / networl setting applet
- how to get my serial little keyboard work (DATACOMP Model DPK62AV V3.1) ... at the moment I need the port for serial terminal connection (login)
- sound missing
- some software missing ... (maybe via ipkg repos later)

- add sd/mmc slot
- add bluetooth dongle (but problem to get one with simple usb for "serial" connection only (maybe someone knows where to buy one in germany?)

I attach a logfile later today ...

Martin
Go to the top of the page
 
+Quote Post
mr_nice
post Jan 10 2008, 11:14 AM
Post #3





Group: Members
Posts: 156
Joined: 21-September 05
Member No.: 8,161



hi,
thanks for testing the images smile.gif.
please report those bugs to the bugtracker [1].

-sound is not working atm. because there is no driver for it in 2.6 [2]

-serial keyboard should work with kbdd [3]. but I am not shure if there isn't a kernel side driver for your keyboard so that you even don't need kbdd.
But please report this also to the bugtracker because kbdd is not in angstrom feeds [4].

- some wireless drivers are missing in the feeds. i need to check that. but please also send it to the bugtracker smile.gif.

best regards
mr nice

1 http://bugs.openembedded.org/
2 http://bugs.openembedded.org/show_bug.cgi?id=2319
3 http://www.handhelds.org/moin/moin.cgi/kbdd
4 http://www.angstrom-distribution.org/repo/...p;action=search
Go to the top of the page
 
+Quote Post
fredyd
post Jan 17 2008, 01:37 AM
Post #4





Group: Members
Posts: 38
Joined: 4-April 05
Member No.: 6,787



Thanks Berhardt and others, this is very (mr_)nice work!

The main problem right now is with PCMCIA, which prevents any kind of networking:
- a CF card adapter is recognized properly and mounted
- my old ethernet card (Linksys EC2T) which is supported by pcnet_cs and works in Familiar is not recognized when inserted. I only get the message "pccard: PCMCIA card inserted into slot 0" in the console. Loading the module pcnet_cs before or after inserting the card doesn't fix that (the module is included in the jffs2 images)
- my WLAN card (prism2-based), which works with hostap on Familiar, isn't recognized either. Incidentally, I noticed that kernel-module-hostap_cs is neither present in the images, nor in the simpad feed, although the hostap utilities are installed...
- "pccardctl ident" only works with the CF card adapter
- shouldn't there be a /proc/bus/pccard directory? (maybe not, but it's here on my linux 2.6.22 workstation)

has anybody got an ethernet or wifi card to work?

bugs.openembedded.org is down at the moment, so I cannot file any bug for these, sorry.

I can't wait for the day when I'll have a working Angstrom tablet with minimo running on it ;-)

Fred
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2014 - 07:12 AM