OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Irda-device On Eabi
LinuxGadget
post Jan 4 2008, 02:11 PM
Post #1





Group: Members
Posts: 44
Joined: 21-October 07
From: Aschersleben, Germany
Member No.: 20,849



Hi all,

my C1k is running EABi on 2.6.22.9-yonggun. Tried to setup the irda-stuff. So installed irda and irda-utils.
Now, when am doing
CODE
irattach /dev/ttySx (x=0,...,2)

it gives in /var/log/messages:
CODE
Jan  4 22:53:43 Zaurus irattach: Stopping device /dev/ttyS2
Jan  4 22:53:43 Zaurus irattach: ioctl(SIOCGIFFLAGS): No such device
Jan  4 22:53:43 Zaurus irattach: exiting ...

But in /var/log/dmesg are theses devices:
CODE
pxa2xx-uart.0: ttyS0 at MMIO 0x40100000 (irq = 22) is a FFUART
pxa2xx-uart.1: ttyS1 at MMIO 0x40200000 (irq = 21) is a BTUART
pxa2xx-uart.2: ttyS2 at MMIO 0x40700000 (irq = 20) is a STUART

and ls -l /dev/ttyS*
CODE
crw-rw-rw- 1 root dialout 4, 64 Jan  4 20:44 /dev/ttyS0
crw-rw-rw- 1 root dialout 4, 65 Jan  4 20:44 /dev/ttyS1
crw-rw-rw- 1 root dialout 4, 66 Jan  4 20:44 /dev/ttyS2


So, where am i missing the point unsure.gif ?
Go to the top of the page
 
+Quote Post
Vitel
post Jan 5 2008, 05:29 PM
Post #2





Group: Members
Posts: 47
Joined: 25-April 06
Member No.: 9,703



Try this, it works for me on the same kernel:
CODE
modprobe pxaficp_ir
modprobe ircomm
modprobe ircomm_tty
irattach irda0 -s

After this /dev/ircomm0 is ready to use.
Go to the top of the page
 
+Quote Post
LinuxGadget
post Jan 6 2008, 01:44 AM
Post #3





Group: Members
Posts: 44
Joined: 21-October 07
From: Aschersleben, Germany
Member No.: 20,849



rolleyes.gif Thanks, Vitel! Irda is working perfectly.
Now let's see if my Polar Hrm is syncing with my Z. rolleyes.gif
Go to the top of the page
 
+Quote Post
jpmatrix
post Jan 6 2008, 04:11 AM
Post #4





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



(smile) this article will soon be wikified! (smile)

so far for me:

1) i had to apt-get install irda-utils

2) i had to create the /dev/ircomm0 device node :

mknod /dev/ircomm0 c 161 0

3) then :

modprobe pxaficp_ir
modprobe ircomm
modprobe ircomm_tty
irattach irda0 -s

4) i modprobe irda too

5) now wammu can see my nokia 6021 !
and it seems to retrive the infos!!!

thanks everybody !
Go to the top of the page
 
+Quote Post
LinuxGadget
post Jan 6 2008, 07:52 AM
Post #5





Group: Members
Posts: 44
Joined: 21-October 07
From: Aschersleben, Germany
Member No.: 20,849



QUOTE(jpmatrix @ Jan 6 2008, 01:11 PM) *
(smile) this article will soon be wikified! (smile)


Excellent idea! rolleyes.gif

Maybe you could also add your steps setting up bluetooth? http://www.oesf.org/forum/index.php?showto...mp;hl=bluetooth, did the job for me. Had some troubles with pairing, but now my S-E K320i syncs with some quirks on my Z (opensync+evolution+contacts). Really nice wink.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 04:50 PM