OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Qtopia 2.2 Compilation And Pngscale Error (solved!), Qtopia 2.2 compilation failed because pngscale error
zensei
post Jan 28 2008, 03:16 PM
Post #1





Group: Members
Posts: 13
Joined: 28-January 08
From: Germany, Karlsruhe
Member No.: 21,288



Hello all,
I am trying to compile qtopia 2.2 with gcc 2.95 (sharp arm). On the internet I can found the same error, but no answer. The same error come, when I try to compile it with gcc 4 (angstrom). Can anyone help? The error for GCC 2.95 (Sharp arm toolchain):

P.S: Qtopia tools compiled, qt - compiled.

***********************************
********* Build Qtopia ************
***********************************
QPE_CFG=" '-edition' 'pda' '-displaysize' '640x480' -no-qtopiadesktop -prefix '$HOME/arm/qtopia' -release -platform 'linux-g++' -xplatform 'linux-sharp-g++'"

The following configuration values have been guessed or autodetected:
-arch sharp
-fontfamilies helvetica fixed micro smallsmooth smoothtimes
-fontsizes all
-fontstyles 50 50i 75 75i
-languages en_US

Symlinking header files to include directory
Creating qmake...make[1]: Entering directory `$HOME/src/qtopia-free-2.2.0/qtopia/qmake'
.make[1]: Leaving directory `$HOME/src/qtopia-free-2.2.0/qtopia/qmake'

Creating pngscale...make[1]: Entering directory `$HOME/src/qtopia-free-2.2.0/qtopia/util/pngscale'
..make[1]: *** [../../bin/pngscale] Error 1
make[1]: Leaving directory `$HOME/src/qtopia-free-2.2.0/qtopia/util/pngscale'
Failed to make pngscale

Thank you.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
speculatrix
post Jan 28 2008, 03:49 PM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149




I recall trying to build qtopia 2.2 and having problems, lpotter of trolltech was even surprised I got as far as I did using gcc2.9x as it's not AFAICT a supported combination.

Not sure whether there's any benefit in trying to get qtopia2 running with old kernel and sharp-based distros, excepting you trying to make a hybrid system replacing some components with qtopia2 but trying to keep old libs and apps for compatibility?

If you just want qtopia2 you'd be better off looking at angstrom as your baseline distro... but then you might as well leap ahead to qtopia4 - I think qtopia4 has been built/tested for it, but you'd have to check for yourself!
Go to the top of the page
 
+Quote Post
zensei
post Feb 4 2008, 12:33 AM
Post #3





Group: Members
Posts: 13
Joined: 28-January 08
From: Germany, Karlsruhe
Member No.: 21,288



QUOTE(speculatrix @ Jan 29 2008, 12:49 AM) *
If you just want qtopia2 you'd be better off looking at angstrom as your baseline distro... but then you might as well leap ahead to qtopia4 - I think qtopia4 has been built/tested for it, but you'd have to check for yourself!


Qtopia 4 is good, but wat with performance? I had heard, that the qtopi4 is very slow on zaurus machines.
Go to the top of the page
 
+Quote Post
speculatrix
post Feb 5 2008, 01:39 PM
Post #4





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(zensei @ Feb 4 2008, 08:33 AM) *
Qtopia 4 is good, but wat with performance? I had heard, that the qtopi4 is very slow on zaurus machines.


qt-embedded-3 was apparently a real hog, but qt-embedded- (oops, qt-core-)4 is said to be better as it's more modular? I would guess that, inevitably, because it's more advanced it will need more resources, but whether that makes it unusable also depends on how well the applications can make use of shared libraries etc to maximise efficient use of code space.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2014 - 05:34 PM