OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> Icehamster (was: Customising Minimo)
jpmatrix
post Feb 12 2008, 12:48 PM
Post #16





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



i'm discovering this thread and icehamster 0.5 !
it seems to handle well my facebook profile so that's a good point! wink.gif
thanks datathief !
Go to the top of the page
 
+Quote Post
dlj0
post Mar 17 2008, 03:57 PM
Post #17





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(datathief @ Feb 6 2008, 09:58 AM) *
Icehamster 0.5 released.
  • Fixed "Open File...".
  • Added basic downloading support.
To download a file, select "File => Save Link As..." and click the link to download.


I am still having trouble downloading files. Most such ware links from a page. I can't just save the whole page, can I? Yet, when I click on the file to be downloaded, I still get the same error. What is the workaround?
Go to the top of the page
 
+Quote Post
datathief
post Mar 19 2008, 07:59 AM
Post #18





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(dlj0 @ Mar 17 2008, 11:57 PM) *
I am still having trouble downloading files. Most such ware links from a page. I can't just save the whole page, can I? Yet, when I click on the file to be downloaded, I still get the same error. What is the workaround?


Can you give an example? I haven't managed to figure out Minimo's built-in download manager, but mine (select "File => Save Link As..." and then click a link to download) works for me.
Go to the top of the page
 
+Quote Post
dlj0
post Mar 19 2008, 09:54 AM
Post #19





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(datathief @ Mar 19 2008, 10:59 AM) *
QUOTE(dlj0 @ Mar 17 2008, 11:57 PM) *
I am still having trouble downloading files. Most such ware links from a page. I can't just save the whole page, can I? Yet, when I click on the file to be downloaded, I still get the same error. What is the workaround?


Can you give an example? I haven't managed to figure out Minimo's built-in download manager, but mine (select "File => Save Link As..." and then click a link to download) works for me.


Well, I just tried to download either icehamster itself, or minimo, following what you just suggested (before I had clicked the link -- seemed like the thing to do -- and got the weird error message as before. I didn't get your instructions before).

But all I got was some empty files with random filenames in /tmp. Where are they supposed to appear, and with what names?
Go to the top of the page
 
+Quote Post
ZDevil
post Mar 23 2008, 03:50 AM
Post #20





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Just tried Icehamster. It's nice!
"Save Link As..." then tap works for me.
What is missing in the file downloading dialog is the filename, which is left blank and i have to fill that in.
Go to the top of the page
 
+Quote Post
datathief
post Apr 2 2008, 05:28 AM
Post #21





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(dlj0 @ Mar 19 2008, 05:54 PM) *
Well, I just tried to download either icehamster itself, or minimo, following what you just suggested (before I had clicked the link -- seemed like the thing to do -- and got the weird error message as before. I didn't get your instructions before).

But all I got was some empty files with random filenames in /tmp. Where are they supposed to appear, and with what names?


Do you get a "Save As..." dialog window when you click the link?
Go to the top of the page
 
+Quote Post
datathief
post Apr 2 2008, 05:29 AM
Post #22





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(ZDevil @ Mar 23 2008, 11:50 AM) *
Just tried Icehamster. It's nice!
"Save Link As..." then tap works for me.
What is missing in the file downloading dialog is the filename, which is left blank and i have to fill that in.


Agreed. Once I work out how to do that (reliably), I'll be happy.
Go to the top of the page
 
+Quote Post
bunkford
post May 5 2008, 05:56 PM
Post #23





Group: Members
Posts: 13
Joined: 28-August 06
Member No.: 11,024



this looks awsome.. does it exist as an Angstrom package?
Go to the top of the page
 
+Quote Post
ArchiMark
post May 6 2008, 10:02 AM
Post #24





Group: Members
Posts: 1,027
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Have just done a fresh install of Debian EABI and overall is working good....

Now, would like to install icehamster but having problem installing icehamster and minimo....per Titchy's IceHamster webpage....

Hope someone can please advise...

Per instructions downloaded files and did:

CODE
#dpkg --install minimo_0.02+cvs20070626-r0_armel.deb  icehamster_0.5.deb
selecting previously deselected package minimo.
(Reading database.... 37982 files and directories currently installed....)
Unpacking minimo (from minimo_0.02+cvs20070626-r0_armel.deb)...
Selecting previously deselected package icehamster_0.5.deb.
Unpacking icehamster (from icehamster_0.5.deb)....
dpkg: dependency problems prevent configuration of minimo:
  minimo depends on libgtk2.0-0 (>= 2.1.0.14); however:
    package libgtk2.0-0 is not configured yet.
  minimo depends on libatk1.0-0 (>= 1.20.0); however:
    package libatk1.0-0 is not configured yet.
  minimo depends on libpango1.0-0 (>= 1.18.1); however:
    package libpango1.0-0 is not configured yet.
  minimo depends on libcairo2 (>= 1.4.10); however:
    package libcairo2 is not configured yet.
  minimo depends on libglib2.0-0 (>= 2.14.1); however:
    package libglib2.0-0 is not configured yet.
dpkg: error processing minimo (--install):
  dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of icehamster:
  icehamster depends on minimo; however:
    package minimo is not configured yet.
dpkg: error processing icehamster (--install):
  dependency problems - leaving unconfigured
Errors were encountered while processing:
  minimo
  icehamster



Any suggestions???

Just want to try and avoid messing up my nice new fresh EABI install.....

Thanks!


Go to the top of the page
 
+Quote Post
datathief
post May 7 2008, 04:37 AM
Post #25





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(ArchiMark @ May 6 2008, 06:02 PM) *
dpkg: error processing icehamster (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
minimo
icehamster[/code]


If you get dependency problems when installing a package using dpkg, try:
CODE
apt-get -f install
Go to the top of the page
 
+Quote Post
ArchiMark
post May 9 2008, 09:28 AM
Post #26





Group: Members
Posts: 1,027
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(ArchiMark @ May 6 2008, 06:02 PM) *
dpkg: error processing icehamster (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
minimo
icehamster[/code]


QUOTE(datathief @ May 7 2008, 05:37 AM) *
If you get dependency problems when installing a package using dpkg, try:
CODE
apt-get -f install


Thanks for the suggestion, datathief....my main concern was whether or not forcing the install and upgrading the dependent packages might break my current setup, that is working nicely right now....

Meanwhile....just tried
CODE
#apt-get -f install


and now get more error messages.....

CODE
#apt-get -f install
Reading package lists.... Done
Building dependency tree.... Done
Reading state information.... Done
Correcting dependencies.... Done
The following packages were automatically installed and are no longer required:
  python-gtk2-doc   libneon25  python2.4-minimal   python2.4   libhunspell-1.1-0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
   libts-0.0-0
The following NEW packages will be installed:
   libts-0.0-0
0 Upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
320 not fully installed or removed.
Need to get 0B/29.1kB of archives.
After this operation, 143kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database... 38092 files and directories currently installed.)
Unpacking libts-0.0-0 (from .../libts-0.0-0_1.0-4_armel.deb) ...
dpkg: error processing /var/cache/apt/archives/libts-0.0-0_1.04_armel.deb (--unpack):
trying to overwrite `/usr/lib/ts.collie.so', which is also in package 'libts-0.0-0
Errors were encountered while processing:
  /var/cache/apt/archives/libts-0.0-0_1.04_armel.deb
E: Sub-process /usr/bin/dpkg returned error code (1)



It clearly didn't like that!.....

rolleyes.gif

Hmmm....did some further looking on the Debian forums....

Please see thread Apt-get Issues

which in turn references another Debian thread Mod Libdirectfb & Libts Packages, ... will fix apt-get dist-upgrade issues

that relates to the libts issue.....in fact I had posted on it and noted problems related to this....which ended up later leading up to my re-installing Debian EABI again....

Any suggestions please?????

blink.gif

Thanks!

This post has been edited by ArchiMark: May 9 2008, 10:10 AM
Go to the top of the page
 
+Quote Post
mikeones
post May 9 2008, 12:04 PM
Post #27





Group: Members
Posts: 20
Joined: 20-July 06
Member No.: 10,468



QUOTE(ArchiMark @ May 9 2008, 12:28 PM) *
QUOTE(ArchiMark @ May 6 2008, 06:02 PM) *
dpkg: error processing icehamster (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
minimo
icehamster[/code]


QUOTE(datathief @ May 7 2008, 05:37 AM) *
If you get dependency problems when installing a package using dpkg, try:
CODE
apt-get -f install


Thanks for the suggestion, datathief....my main concern was whether or not forcing the install and upgrading the dependent packages might break my current setup, that is working nicely right now....

Meanwhile....just tried
CODE
#apt-get -f install


and now get more error messages.....

CODE
#apt-get -f install
Reading package lists.... Done
Building dependency tree.... Done
Reading state information.... Done
Correcting dependencies.... Done
The following packages were automatically installed and are no longer required:
  python-gtk2-doc   libneon25  python2.4-minimal   python2.4   libhunspell-1.1-0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
   libts-0.0-0
The following NEW packages will be installed:
   libts-0.0-0
0 Upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
320 not fully installed or removed.
Need to get 0B/29.1kB of archives.
After this operation, 143kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database... 38092 files and directories currently installed.)
Unpacking libts-0.0-0 (from .../libts-0.0-0_1.0-4_armel.deb) ...
dpkg: error processing /var/cache/apt/archives/libts-0.0-0_1.04_armel.deb (--unpack):
trying to overwrite `/usr/lib/ts.collie.so', which is also in package 'libts-0.0-0
Errors were encountered while processing:
  /var/cache/apt/archives/libts-0.0-0_1.04_armel.deb
E: Sub-process /usr/bin/dpkg returned error code (1)



It clearly didn't like that!.....

rolleyes.gif

Hmmm....did some further looking on the Debian forums....

Please see thread Apt-get Issues

which in turn references another Debian thread Mod Libdirectfb & Libts Packages, ... will fix apt-get dist-upgrade issues

that relates to the libts issue.....in fact I had posted on it and noted problems related to this....which ended up later leading up to my re-installing Debian EABI again....

Any suggestions please?????

blink.gif

Thanks!

I had to

CODE
dpkg --force-overwrite -i  /var/cache/apt/archives/libts-0.0-0_1.04_armel.deb && apt-get install -f
Go to the top of the page
 
+Quote Post
ArchiMark
post May 9 2008, 01:00 PM
Post #28





Group: Members
Posts: 1,027
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(mikeones @ May 9 2008, 01:04 PM) *
I had to

CODE
dpkg --force-overwrite -i  /var/cache/apt/archives/libts-0.0-0_1.04_armel.deb && apt-get install -f


Yep, that works, mikeones!

tongue.gif

Hmmm...now, it's asking if I want to change '/etc/ts.conf' or not.....

Did you accept the new version of this file or leave the old one?

I went ahead and accepted the new version....then after that a lot of other files got updated/configured....

UPDATE: I now have a touchscreen calibration problem....cursor in IceWM is way off....

I try quitting IceWm and then running 'ts_calibrate' but it opens and then quickly closes.....console shows quite a few lines of calibration related text saying that it took readings from different points.....

Just checked '.profile' and it says the following related to touchscreen:

CODE
export TSLIB_TSDEVICE="/dev/input/ts0"
export TSLIB_CONFFILE="/etc/ts.conf"



Just checked '/etc/ts.conf' and it has everything commented out EXCEPT for the following lines:
CODE
module_raw input

module pthres pmin=1
module variance delta=30
module dejitter delta=100
module linear


Any suggestions as to how to get touchscreen calibrated again???

Thanks!!

This post has been edited by ArchiMark: May 9 2008, 02:50 PM
Go to the top of the page
 
+Quote Post
mikeones
post May 9 2008, 07:07 PM
Post #29





Group: Members
Posts: 20
Joined: 20-July 06
Member No.: 10,468



QUOTE(ArchiMark @ May 9 2008, 04:00 PM) *
QUOTE(mikeones @ May 9 2008, 01:04 PM) *
I had to

CODE
dpkg --force-overwrite -i  /var/cache/apt/archives/libts-0.0-0_1.04_armel.deb && apt-get install -f


Yep, that works, mikeones!

tongue.gif

Hmmm...now, it's asking if I want to change '/etc/ts.conf' or not.....

Did you accept the new version of this file or leave the old one?

I went ahead and accepted the new version....then after that a lot of other files got updated/configured....

UPDATE: I now have a touchscreen calibration problem....cursor in IceWM is way off....

I try quitting IceWm and then running 'ts_calibrate' but it opens and then quickly closes.....console shows quite a few lines of calibration related text saying that it took readings from different points.....

Just checked '.profile' and it says the following related to touchscreen:

CODE
export TSLIB_TSDEVICE="/dev/input/ts0"
export TSLIB_CONFFILE="/etc/ts.conf"



Just checked '/etc/ts.conf' and it has everything commented out EXCEPT for the following lines:
CODE
module_raw input

module pthres pmin=1
module variance delta=30
module dejitter delta=100
module linear


Any suggestions as to how to get touchscreen calibrated again???

Thanks!!

Always (99% of the time) choose not to update the config file. I chose to keep my current config. You can however type "D" to see for your self what changes will be made.

I always run ts_calibrate from within icewm. Just pull up a console and run ts_calibrate. You may have to su to root 1st if you are running as a non-privileged user.

Here is my /etc/ts.conf
CODE
module_raw input grab_events=0
module_raw corgi
module pthres pmin=1
module variance delta=30
module dejitter delta=100
module linear
Go to the top of the page
 
+Quote Post
ArchiMark
post May 12 2008, 07:23 AM
Post #30





Group: Members
Posts: 1,027
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(mikeones @ May 9 2008, 08:07 PM) *
Always (99% of the time) choose not to update the config file. I chose to keep my current config. You can however type "D" to see for your self what changes will be made.

I always run ts_calibrate from within icewm. Just pull up a console and run ts_calibrate. You may have to su to root 1st if you are running as a non-privileged user.

Here is my /etc/ts.conf
CODE
module_raw input grab_events=0
module_raw corgi
module pthres pmin=1
module variance delta=30
module dejitter delta=100
module linear



Yup, that did it, mikeones!!!

Just edited 'ts.conf' to match your first 2 lines and voila! 'ts_calibrate' runs OK again.....got screen calibrated and working now again!!

THANKS!

laugh.gif
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 09:16 AM