OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Google Android M5-rc14 Installable Image Available!, Full distro for SL-C3x00
post Mar 3 2008, 01:39 PM
Post #1

Group: Members
Posts: 374
Joined: 18-March 04
From: The Netherlands
Member No.: 2,380

Sorry for the delay, but I had some trouble uploading the files to my site.
The image files and installation instructions can be obtained from my website
Have fun!
Go to the top of the page
+Quote Post
Start new topic
post Mar 6 2008, 01:59 PM
Post #2

Group: Admin
Posts: 3,574
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149

the first time it ran, my c3100 took a very long time to start up and I thought I'd be looking at the "nightrider eye" (or is a cylon) forever!

eventually it did start, so I was pretty wowed.

I've managed to get WEP wifi up at home, didn't seem to want to connect to work's WPA access point. I had to hack /etc/resolv.conf and /etc/network/interfaces though, set a manual IP + mask + route as it reports bad protocol when udhcpc runs, it's still very finicky. Locked up Z, hard reset (nice there's a button in the battery compartment)

Not actually managed to use the android web browser yet, but hopefully very very soon!

--edit-- rebooted, this time the manual settings in /etc/network/interfaces worked and I could ping www.google.com straight off.

fired up android and the browser, it reports "Page Load Suspended
No network coverage. Load will resume when network connection recovers"

--edit2-- my wireless access point is a linux box with intel 2915abg minipci card, so I can sniff the lan and do interesting stuff; when android browser fires up, I see no traffic, so it's not even trying to talk to the network. bummer. Went back to console, Z got upset, reboot time.

--edit3-- do I need to do the net.eth0.dns trick? hmm, I can use FN-left to switch back to the console, but weirdly android is still getting every key press too! Tried killing android process off, Z locks up, reset

--edit4-- aha, when the Z brings up wlan0 (ifup wlan0=home), I have to ping it from the gateway and then wlan0 works, otherwise Z can't ping the linux server. ok, I left a ping running, so know the Z is definitely online, but android cannot see the network. still no traffic on gateway. maps work, but when I scroll off the edge, I get a blank space and it pops up the no network alert.

no sound, no touchscreen either.
Go to the top of the page
+Quote Post

Posts in this topic
cortez   Google Android M5-rc14 Installable Image Available!   Mar 3 2008, 01:39 PM
matthis   Thank you!! Testing now! **EDIT: I...   Mar 3 2008, 04:54 PM
cortez   Press Fn+Left cursor to see if there are any error...   Mar 3 2008, 10:39 PM
zogs   just red line but don't start window error: s...   Mar 4 2008, 05:32 AM
cortez   QUOTE(zogs @ Mar 4 2008, 02:32 PM) just r...   Mar 4 2008, 06:43 AM
zogs   ok it's normal but don't start , I'm w...   Mar 4 2008, 07:55 AM
dproldan   QUOTE(zogs @ Mar 4 2008, 04:55 PM) ok it...   Mar 4 2008, 08:35 AM
BarryW   Yea, it scrolls errors faster than I can read. I...   Mar 4 2008, 09:58 AM
cortez   I'll re-check the complete installation to see...   Mar 4 2008, 10:43 AM
cortez   I see that Google released a new version of the SD...   Mar 4 2008, 11:23 AM
cortez   I have an updated image ready, but I'm current...   Mar 5 2008, 12:09 AM
zogs   Thanks cortez, I'm waiting   Mar 5 2008, 12:59 AM
cortez   New image is uploaded here (android-root.tar.gz). ...   Mar 5 2008, 09:42 AM
speculatrix   woohoo, thanks cortez, I'll try it on my c3100...   Mar 5 2008, 01:41 PM
jpmatrix   just installed on my c3000 ! it works !...   Mar 5 2008, 02:20 PM
matthis   Got it to work as well!! Very very nice...   Mar 6 2008, 04:52 AM
speculatrix   the first time it ran, my c3100 took a very long t...   Mar 6 2008, 01:59 PM
Android Zaurus   QUOTE(speculatrix @ Mar 7 2008, 06:59 AM)...   Mar 6 2008, 02:27 PM
speculatrix   QUOTE(Android Zaurus @ Mar 6 2008, 10:27 ...   Mar 6 2008, 03:10 PM
speculatrix   I demonstrated android at work, one of the guys wo...   Mar 7 2008, 04:53 AM
Android Zaurus   I totally forgot about updating my RotateView to m...   Mar 10 2008, 01:26 AM
speculatrix   QUOTE(Android Zaurus @ Mar 10 2008, 09:26...   Mar 10 2008, 04:59 AM
whtslmndr   QUOTE(cortez @ Mar 3 2008, 01:39 PM) Sorr...   Mar 18 2008, 09:53 AM
Android Zaurus   A hacker in Japan successfully runs m5-rc14 on C70...   Apr 12 2008, 07:24 PM
Android Zaurus   Finally, touchscreen driver has been fixed. Now to...   May 13 2008, 12:56 AM
matthis   If anyone feels in a generous mood, could we have ...   May 13 2008, 03:16 PM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 23rd June 2018 - 03:52 PM