OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Hdd-free Patch For Cacko Rom!, updated to scriptpack v0.2 (080416)
post Mar 5 2008, 01:29 AM
Post #1

Group: Members
Posts: 1,998
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882

SOLVED: for details see post #15 below.


I am stilling thinking of setting up dualbooting Cacko and Debian/EABI using the sharp bootloader and kexec as described here: https://www.oesf.org/forum/index.php?showtopic=25555

Even though dualbooting Debian and PdaXii works fine, I feel like having the NAND run Cacko so that there are more varieties.

The question is: the internal disk is already partitioned with one big giant partition filled by the Debian rootfs.
The fact is Cacko/Sharp rom require the internal disk to be partitioned in exactly three parts with exact sizes/sectors.
I cannot do this with GParted in Debian because the program can only resize in terms of MBs, not sectors.
fdisk doesn't work here because repartitioning with fdisk will wipe the disk content clean.

Of course there is a straightforward way: just tar up/create a back up image of the Debian rootfs, then use fdisk to repartition the disk, then put the Debian rootfs back in HDD1, and finally install Cacko and set up dualbooting using the method in that thread. Actually this is also what I may do.

But many Debian Z users have already got the whole system working. This method, however simple, is clumsy and not without risks.

So would it be feasible to do it the other way round: tweak Cacko/Sharp rom in such a way that it simply ignores the HDDs part. In principle it seems workable to me, because the files living in the three hdax do not seem to be critical for the system to operate. Everything important is all in the NAND flash.
I have tried to play with /root/etc/rc.d/rc.rofilesys in Cacko by taking away all the instructions to mount the HDDs. But Cacko fails to boot because of something missing in the process (let me skip the details here).

Has someone ever tried to do a similar thing? I would great appreciate if you could share your insights here. Thanks! wink.gif

This post has been edited by ZDevil: Apr 16 2008, 01:35 AM
Go to the top of the page
+Quote Post
Start new topic
post Mar 5 2008, 02:02 AM
Post #2

Group: Members
Posts: 2,808
Joined: 13-September 04
From: Wasilla Ak.
Member No.: 4,572

It has been done as a part of on old pocketworkstaion intallation--the guy doing it wanted to make PW look native on (I think) a 3000. the project got superceded by XQT, but in part of his instrucions he boots cacko by doing a key combo (ctrl -c?) when cacko complains about the missing partitions--it then loads just fine. This surely could be massaged into something workable.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th May 2018 - 12:10 PM