OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Exult Running On Pdaxii13-5.5, SDL lib conflict [solved]
Jon_J
post Apr 13 2008, 07:35 AM
Post #1





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



This may be old news to most here, but I have Ultima 7 running through Exult on my pdaxii13-5.5 C3200
I wanted to post this earlier, but I wanted ninnd000000's topic on "Dga Support?" to have at least a day on top of the list.
I found "exult_1.2_armv5tel.ipk" somewhere and will attach it here for anyone interested. I installed it to my hard drive.
Exult requires the original files from the original game. The CD-ROM version is easiest to use, I don't have the floppy disk version.
I also copied these files to my hard drive. (I'm very low on space on my NAND partition).
Here is the website dedicated to Exult. There are also forums and several pages on configuring Exult.
This website is chock full of documentation.
This is a really nice site. I just love when an application or game comes with full documentation. smile.gif
The second link is to the instructions for configuring the Sharp ROM version on Sharp/Cacko.
I used all the documentation to get it working on my pdaxii13 Zaurus.
http://exult.sourceforge.net/index.php
http://exult.sourceforge.net/docs.php#zaurus_install

I had the game working almost perfect, but was having some interface problems with the touchscreen and the stylus.
My problem was that I installed an older SDL lib, to get psx4zaurus to work.
psx4zaurus (in pdaXrom) requires sdl_1.2.9_armv5tel.ipk
pdaxii13-5.5 comes with sdl_1.2.12_armv5tel.ipk
After I uninstalled sdl_1.2.9 and installed sdl_1.2.12, my touchscreen problems in Exult vanished! smile.gif smile.gif
I guess if I want both Exult and psx4zaurus to work, I'll need to switch these SDL libs back and forth.
Right now I'm sticking with Exult and sdl_1.2.12
Here's the pdaXrom version of Exult. The Sharp ROM version can be found at the Exult website I linked above.

Jon
Attached File(s)
Attached File  exult_1.2_armv5tel.ipk ( 1.12MB ) Number of downloads: 12
Attached File  Ultima_7___The_Black_Gate_7.png ( 19.6K ) Number of downloads: 45
 
Go to the top of the page
 
+Quote Post
relapse808
post Apr 23 2008, 04:14 PM
Post #2





Group: Members
Posts: 70
Joined: 20-August 06
From: Phoenix, Arizona
Member No.: 10,881



I would love to get this working but I am getting errors when trying to install the package you have provided in this thread. I am not sure of the specifics but could check it out. Is there something I could be doing wrong?
Go to the top of the page
 
+Quote Post
Jon_J
post Apr 24 2008, 05:01 AM
Post #3





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



QUOTE(relapse808 @ Apr 23 2008, 07:14 PM) *
I would love to get this working but I am getting errors when trying to install the package you have provided in this thread. I am not sure of the specifics but could check it out. Is there something I could be doing wrong?
I just downloaded this package using Firefox in Windows. It isn't corrupt or anything, I checked it.
Make sure your browser isn't trying to unpack it while downloading it. If that is working, read on..
This package installs to /usr/local/bin and /usr/local/share
That may be part of your problem getting it to work.
You need to study the file: "exult.cfg" and go to this page to understand how to set up the paths to the game data files.
http://exult.sourceforge.net/docs.php
http://exult.sourceforge.net/docs.php#exult_config
Read the section thoroughly about exult.cfg
On pdaxii13, exult.cfg is a hidden file and is actually named .exult cfg
It is located in /home/root/.exult.cfg
I have attached my copy of .exult.cfg (It is in a zip file because the forum won't accept *.cfg)
I have the program and game data files on my hard drive, and have also downloaded the sound files and sound effects files, which are also referenced in the .exult.cfg file.
I have the below two directories symlinked from my hard drive, I'm not sure if it is absolutely necessary, but it works for me.
/home/root/.exult/blackgate
/home/root/.exult/serpentisle

Whenever you try to get the game running, launch it in a console, the path errors are shown in the console, if exult cannot find its files.
BTW, you do need the data files from the original game for this to work.

hope this helps,
Jon
Attached File(s)
Attached File  exult.cfg.zip ( 837bytes ) Number of downloads: 0
 
Go to the top of the page
 
+Quote Post
relapse808
post Apr 28 2008, 03:02 PM
Post #4





Group: Members
Posts: 70
Joined: 20-August 06
From: Phoenix, Arizona
Member No.: 10,881



Ill have to write down the error I am getting. I am getting a error on the IPKG install using the package manager. I got exult working in cacko once and I still have my 3.5 inch floppies of when I first bought the game. I have installed the game via dosbox as well so I am good with the files. I will update with my error.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2014 - 06:19 PM