OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Mounting A Usb Drive, Mounting USB memory stick
MrStaypuft
post Jun 5 2008, 09:42 PM
Post #1





Group: Members
Posts: 63
Joined: 17-July 06
Member No.: 10,437



Hi Everyone,

I know threads like this are everywhere but trust me I have searched and tried MANY commands and I can't get this memory stick to work.

I am running Sharprom with an updated Kernel and meanies automounter-c3000_0.5.0_arm.ipk

I have mounted USB hard drives many times in the past but after trying a few different drives (formatted as FAT16 and FAT32) i keep getting a similar error.

If I look in system info under device-USB-* USB MASS STORAGE

I get vendor, product, class and ID information however under Driver I get
"Driver: (none)".

Obviously the drive is not showing up anywhere - i can't do fdisks on sda, sda1, sdb, sdb1, etc as they aren't there.

I know I have probably missed something which makes me look stupid but what is it?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Jon_J
post Jun 20 2008, 06:17 PM
Post #2





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



QUOTE(MrStaypuft @ Jun 20 2008, 12:54 AM) *
OK I think i worked out what my problem is - see this thread (http://www.oesf.org/forum/index.php?showtopic=23984&st=75&gopid=178010&#entry178010)

It says in there that the kernel developed for Quasar media player causes issues with USB HDD however someone else also says that these changes have been rolled into Tetsu's kernel (which presumably would work fine with external USB HDD's)

Also I just double checked and it said sharprom/cacko so I guess I'm still running sharprom with this kernel so any references to cacko are my mistake - i am not running cacko - just sharprom with this special kernel.

Sooooo......

I guess the answer is to install Tetsu's kernel - of course as I can't read his website (I don't speak japanese)

so I downloaded what I think is the right kernel (18j C3200) and also kernel-modules_v18j_arm.ipk and updater.sh. However in some of the english translated stuff I could see that 18j was talking about dual booting into PDAXROM which I don't want to do but I can't see the earlier Kernel on his website to download. Oh well I guess it supports it but hopefully doesn't require it?

So I think what I need to do is
- Install the new kernel
- Install the IPK with the modules

Test again - can someone else make sense of this and see if my approach makes sense?

Thanks!

I have copies of Tetsu kernels for both the SL-C3100 and SL-C3200
I have these two versions: (v-18h) and (v-18i)
I'll attach them in 2 zip files. I'll also attach a zip file with instructions (English) in "html" and a short text instruction.
Also attached is a screenshot of the file contents of both zip files with Tetsu's kernels.

Jon
Attached File(s)
Attached File  tetsu_contents.png ( 31.54K ) Number of downloads: 11
Attached File  tetsu_v18h__C3100___C3200_.zip ( 3.12MB ) Number of downloads: 2
Attached File  tetsu_v18i__C3100___C3200_.zip ( 3.04MB ) Number of downloads: 2
Attached File  tetsu_docs.zip ( 3.08K ) Number of downloads: 3
 
Go to the top of the page
 
+Quote Post

Posts in this topic
MrStaypuft   Mounting A Usb Drive   Jun 5 2008, 09:42 PM
Capn_Fish   What does dmesg say?   Jun 6 2008, 06:28 AM
MrStaypuft   dmesg says this: NETDEV WATCHDOG: usbd0: transmit...   Jun 8 2008, 09:15 PM
the_oak   You have probably already tried this, but in case ...   Jun 10 2008, 01:16 PM
case   Hi, I had a similiar problem with an SD card moun...   Jun 18 2008, 01:59 PM
case   Hi, My post is still there....here is link you ca...   Jun 18 2008, 02:05 PM
MrStaypuft   Thanks for the info, unfortunately none of these t...   Jun 18 2008, 03:00 PM
Jon_J   I would first try an external USB hard drive. (One...   Jun 18 2008, 03:18 PM
case   Hi, I just wanted to point out that I had similia...   Jun 18 2008, 04:05 PM
MrStaypuft   Hi everyone - firstly thanks for all your help. C...   Jun 19 2008, 02:47 PM
Capn_Fish   Did you do a "modprobe ohci-hcd" (may ha...   Jun 19 2008, 04:31 PM
case   Ok... I understand. Can you mount cf and s...   Jun 19 2008, 05:11 PM
MrStaypuft   QUOTE(case @ Jun 20 2008, 11:11 AM) Ok......   Jun 19 2008, 05:18 PM
MrStaypuft   just tried the "sudo modprobe ohci-hcd" ...   Jun 19 2008, 05:17 PM
Capn_Fish   QUOTE(MrStaypuft @ Jun 19 2008, 08:17 PM)...   Jun 19 2008, 07:25 PM
MrStaypuft   QUOTE(Capn_Fish @ Jun 20 2008, 01:25 PM) ...   Jun 19 2008, 07:49 PM
MrStaypuft   OK I think i worked out what my problem is - see t...   Jun 19 2008, 09:54 PM
Capn_Fish   Why not just use Cacko? Does it not run on the C30...   Jun 20 2008, 07:21 AM
Jon_J   QUOTE(MrStaypuft @ Jun 20 2008, 12:54 AM)...   Jun 20 2008, 06:17 PM
MrStaypuft   In answer to an earlier question - I have a C3200 ...   Jun 22 2008, 06:08 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th December 2014 - 11:18 PM