OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Angstrom Upgrade Questions
agosine
post Jul 4 2008, 10:20 AM
Post #1





Group: Members
Posts: 123
Joined: 4-March 04
From: Toronto, Canada
Member No.: 2,156



I installed the latest Anstrom (zImage-2.6.24-akita-20080607124504.bin & Angstrom-x11-image-glibc-ipk-2007.12-r17-akita.rootfs.tar.gz) images on my C1000 followed by 'ipkg update' and 'ipkg upgrade'. There were no upgrades and almost no additional packages available. Through a little digging I found a link to the 2008 package build feed. I updated the file paths in /etc/ipkg and was able to see the packages without issue.

This is where my problems start. Running 'ipkg upgrade' works 97% without errors. There were 2 symbolic link errors with libhal1 and libdsub which I fixed manually. When I reboot though OE fails to start.

Any suggestions? Should I wait for a Angstrom-x11-image-glibc-ipk-2008 build?
Go to the top of the page
 
+Quote Post
olipage
post Nov 3 2008, 12:56 AM
Post #2





Group: Members
Posts: 10
Joined: 31-October 08
Member No.: 23,292



QUOTE(agosine @ Jul 4 2008, 07:20 PM) *
I installed the latest Anstrom (zImage-2.6.24-akita-20080607124504.bin & Angstrom-x11-image-glibc-ipk-2007.12-r17-akita.rootfs.tar.gz) images on my C1000 followed by 'ipkg update' and 'ipkg upgrade'. There were no upgrades and almost no additional packages available. Through a little digging I found a link to the 2008 package build feed. I updated the file paths in /etc/ipkg and was able to see the packages without issue.

This is where my problems start. Running 'ipkg upgrade' works 97% without errors. There were 2 symbolic link errors with libhal1 and libdsub which I fixed manually. When I reboot though OE fails to start.

Any suggestions? Should I wait for a Angstrom-x11-image-glibc-ipk-2008 build?


I installed similar but angstrom-gpe-image 2007.12. installation and upgrade ran fine, but had to rerun ipkg upgrade, because not everything was updated properly on first run.

but angstrom ran fine afterwards...

cheers, Oliver
Go to the top of the page
 
+Quote Post
ofels
post Nov 7 2008, 03:10 AM
Post #3





Group: Members
Posts: 142
Joined: 4-December 06
From: Lake Constance, Germany
Member No.: 13,087



Never do an ipkg upgrade from the 2008 feed over a 2007 image.
This will lead almost certainly to an unusable system and if you think you have suceeded to 97% you are rather lucky or have not yet encountered all consequences.

Upgrading from 2007 to 2008 requires reflashing with a new 2008 image, otherwise no support can be given and questions arising from such procedures are good candidates to be ignored.

Reflashing is the (only) official way as communicated by the Angstrom project.

Oliver
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th September 2014 - 07:42 PM