OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Socket Bluetooth Cf Card Not Working (surprise!), 2or0's rootfs & 2.6.24.4 kernel
Khepri
post Aug 1 2008, 12:06 AM
Post #1





Group: Members
Posts: 19
Joined: 29-December 07
Member No.: 21,129



Installed bluez etc. Drivers won't load.


dmesg:

Bluetooth: Core ver 2.11
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.9
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8



and when I take the card out and reinsert it:

pccard: card ejected from slot 1
pccard: PCMCIA card inserted into slot 1
pcmcia: registering new device pcmcia1.0



Tried playing around with hciattach and setserial, with no success.

Is this an issue with the kernel? I read about a bug (here and elsewhere) in 2.6 kernels that prevents some Socket BT cards from working, but I'm not really up to configuring a kernel for my Z from scratch, not knowing every relevant switch I should temper with in the config.

Any ideas?


Here's some output:

Zaurus:~# hciattach /dev/ttyS4 socket
Can't get port settings: Input/output error
Can't initialize device: Illegal seek

Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Khepri
post Aug 3 2008, 03:49 AM
Post #2





Group: Members
Posts: 19
Joined: 29-December 07
Member No.: 21,129




I am stuck again.

I execute "rfcomm connect 0 <bdaddr>".
The phone asks if I want to bond with the Z, I say Yes.
I enter the same pin code on the phone that I have in /etc/bluetooth/hcid.conf
The phone says "Verifying PIN... Please Wait".

A couple seconds pass, the connection fails and Z says:

Can't connect RFCOMM socket: Operation now in progress

Why!?
Go to the top of the page
 
+Quote Post
Khepri
post Aug 4 2008, 11:23 AM
Post #3





Group: Members
Posts: 19
Joined: 29-December 07
Member No.: 21,129



Just reporting in that I got it to work.

It was an issue with HALd not loading correctly at boot because it hadn't loaded dbus first.
I also had to install the passkey-agent and run the process in the background while binding the devices.

Then I did:

hciattach /dev/ttyS4 socket
hciconfig hci0 up
rfcomm connect rfcomm0


I had so many different problems during setting this up that if I can gather some energy I will write a thorough tutorial on it.
Go to the top of the page
 
+Quote Post
ant
post Aug 8 2008, 01:09 AM
Post #4





Group: Members
Posts: 163
Joined: 11-March 04
From: IT
Member No.: 2,270



This should be valid for debian too:

/etc/sysconfig/bluetooth
BLUETOOTH=yes
BLUETOOTH_PORT=/dev/ttyS4
#BLUETOOTH_SCRIPT=
BLUETOOTH_SPEED=230400
BLUETOOTH_PROTOCOL=bcsp
#
#
#BLUETOOTH_SPEED=921600
#BLUETOOTH_PROTOCOL=socket

/etc/rfcomm.conf
# RFCOMM configuration file.
#

rfcomm0 {
# # Automatically bind the device at startup
bind yes;
#
# # Bluetooth address of the device
device 00:xx:xx:xx:xx:xx;

#
# # RFCOMM channel for the connection
channel 1;
#
# # Description of the connection
comment "My Nokia xxxx";
}

rfcomm1 {
bind yes;
device 00:xx:xx:xx:xx:xx;
channel 1;
comment "My BT-GPS-xx";
}


Then, but this is using Angstrom, rfcomm is not pulled automatically though bind=yes, so add the two calls in

/etc/init.d/bluetooth

start)
...
rfcomm bind all

stop )
...
rfcomm release all
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd November 2014 - 01:16 PM