OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> How To Bring Up Wlan0 Via Command-line?
misha
post Aug 9 2008, 06:26 PM
Post #1





Group: Members
Posts: 7
Joined: 9-October 07
Member No.: 20,805



Hi all,

I've got a Zaurus CL-3200, using AmbiCom WL1100C-CF PCMCIA wireless card.

I'm trying to bring up wlan0 via the command-line (yeah, there's a GUI tool to do it, but I'm curious). I can connect to the wireless AP at home (sometimes).

I see the card details in dmesg after I insert it into the slot and cardctl status lists the card at socket 0. It's in suspended mode. So far so good.

I'm assuming that to get the card up I need to unsuspend it. cardctl resume prints "ioctl(): Device or resource busy", but I'm assuming that's from the built-in microdrive, which is sitting at socket 1. cardctl resume 0 doesn't print anything and seems to succeed. cardctl status shows the card in a suspended state, however. Can anyone explain why this is so?

At this stage I still can't do anything wireless-related to the card as wlan0 still doesn't exist (it isn't reported by ifconfig). Ifconfig wlan0 up prints "SIOCSIFFLAGS: No such device".

Can someone fill me in?

Cheers,
Misha
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
sdjf
post Aug 11 2008, 05:35 AM
Post #2





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



Try "cardctl reset" and then "cardctl resume"

This is based on my experience with starting dialup connections from the command line.

You may want to read my webpage about this:

http://sdjf.esmartdesign.com/scripts/qreset.html

You do not mention your ROM?

sdjf
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th July 2014 - 12:29 PM