OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Angstrom Install - My Experience, quick outline of my experience with angstrom so far
post Aug 11 2008, 04:09 AM
Post #1

Group: Members
Posts: 12
Joined: 9-August 08
Member No.: 22,175

So - after a minor glitch with a strange serial port problem, I had no problem installing the HH.org bootloader. I then downloaded the X11 image and copied it onto a compact flash card. Following the instructions I renamed the jffs2 file, inserted it into the simpad, connected a terminal via serial and reset the simpad.

however, reading the final page of the HH.org bootloader instructions, and watching the output of the terminal, it seems the bootloader is looking for a differently named image, and would automatically install without the need for the terminal, if it was correctly named.

i then continued as instructed, i.e. "copy hda1:/rootfs.jffs2 root" and the install completed. i then booted into angstrom.

  • the touch screen seems slightly inaccurate, especially noticeable within the virtual keyboard. recalibration improved this slightly
  • virtual keyboard (ol' good keyboard - qwertyGB geometry layout) seems to misbehave - various keys sometimes behave as if the enter key had been pressed - d especially. this happens within terminal.
  • virtual keyboard size - would be nice if the keyboard width was parametric, so something like original small CE keyboard could be displayed
  • Keys and Buttons setup - no button configuration available for this device - would be good to have the hardware buttons mappable, to enable the keyboard button, right click, and change the behaviour of the 4 way switch.
  • Battery monitor - does not seem to reflect battery status when on battery - if charging (connected to mains) battery juice is accurately shown as 64% for instance, but once unplugged, battery status jumps to 100%, and never drops until device goes flat and powers down
  • WiFi - tried three wlan pcmcia cards - only one worked. three cards are
    • siemens i-gate 11m - works natively under CE but fails to init "cs: pcmcia_socket0: time out after reset."
    • Xircom CWE1100 - fails to init "cs: pcmcia_socket0: time out after reset."
    • Linksys WPC11 ver.3 - plug and play
  • Wireless monitor panel utility - does not reflect status of wifi card
All in all, not too bad. Only other issue thus far is the lack of space - really cramped, so not been able to install anything laugh.gif
Go to the top of the page
+Quote Post
Start new topic
post Aug 18 2008, 01:33 AM
Post #2

Group: Members
Posts: 12
Joined: 9-August 08
Member No.: 22,175

i-gate firmware - plugged my igate card into my pundit to find out the firmware version - dmesg reports:

Intersil firmware earlier than v0.8.x - several features not supported
Firmware determined as Intersil 0.7.6

So I'm a bit out of date apparently wink.gif
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th May 2018 - 05:59 AM