OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> I Will Pay Anyone $150 Us Just Compile Aspj Rt73 Module For Zaurus, will u compile 4 me RT73 for C1000 & kernel 2.4.20 ?
Allelectrix
post Aug 23 2008, 05:59 PM
Post #1





Group: Members
Posts: 85
Joined: 7-April 08
Member No.: 21,602



Its incredible.. cant get kernel modules to download, dont know how to modify vanilla kernel code for Zaurus C1000 because no one
else knows it seems ? I hope I am wrong ?

And all I want is:

rt73.o

yes, that single kernel module compiled for kernel 2.4.20 and to be used on a Zaurus SL-C1000 and pdaxii13 OS.
just make sure the source code is from the ASPj rt73-k2wrlz source code and you use GCC 3.4.5 which is the default GCC for
pdaxii13.

Its got to be the all time easiest $150 US your ever going to make.

someone, somewhere out there knows exactly what I'm talking about and want, if thats you, come get your money ! its ready !

create for me rt73.o and its all yours !

contact me on +44 775 7627096 on my Cellular phone daylight GMT . if no reply, please leave a message I will get back to you
quickly.

please also contact me at: allelectrix2@yahoo.co.uk

your efforts to help me will be well rewarded. thanks so much !
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
xamindar
post Oct 18 2008, 01:06 AM
Post #2





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



This post got me really excited as I have a usb card that this driver runs. I just tried both your new one and eviljazz'. Both load fine but neither work for my card, unless I am missing something. Here is what I get when the card is plugged into my powered hub with the module already loaded:
CODE
hub.c: USB new device connect on bus1, assigned device number 9
usb.c: kmalloc IF c3d348c0, numif 1
usb.c: new device strings: Mfr=1, Product=2, SerialNumber=0
usb.c: USB device number 9 default language ID 0x409
Manufacturer: Ralink
Product: 802.11 bg WLAN
Device Descriptor not matching
usb.c: unhandled interfaces on device
usb.c: USB device 9 (vend/prod 0x7d1/0x3c04) is not claimed by any active driver.
  Length              = 18
  DescriptorType      = 01
  USB version         = 2.00
  Vendor:Product      = 07d1:3c04
  MaxPacketSize0      = 64
  NumConfigurations   = 1
  Device version      = 0.01
  Device Class:SubClass:Protocol = 00:00:00
    Per-interface classes
Configuration:
  bLength             =    9
  bDescriptorType     =   02
  wTotalLength        = 0020
  bNumInterfaces      =   01
  bConfigurationValue =   01
  iConfiguration      =   00
  bmAttributes        =   80
  MaxPower            =  300mA

  Interface: 0
  Alternate Setting:  0
    bLength             =    9
    bDescriptorType     =   04
    bInterfaceNumber    =   00
    bAlternateSetting   =   00
    bNumEndpoints       =   02
    bInterface Class:SubClass:Protocol =   ff:ff:ff
    iInterface          =   00
    Endpoint:
      bLength             =    7
      bDescriptorType     =   05
      bEndpointAddress    =   81 (in)
      bmAttributes        =   02 (Bulk)
      wMaxPacketSize      = 0040
      bInterval           =   00
    Endpoint:
      bLength             =    7
      bDescriptorType     =   05
      bEndpointAddress    =   01 (out)
      bmAttributes        =   02 (Bulk)
      wMaxPacketSize      = 0040
      bInterval           =   00
usb.c: kusbd: /sbin/hotplug add 9


The rt73 driver works for this card on my linux box and on debian on this zaurus. Maybe this older version of the driver doesn't support my card? It's a d-link WUA-1340 card.
Go to the top of the page
 
+Quote Post
Allelectrix
post Oct 18 2008, 04:02 AM
Post #3





Group: Members
Posts: 85
Joined: 7-April 08
Member No.: 21,602



xamindar wrote about his ralink rt2571 chipset card...

Hi there xamindar, thanks for your input into this very exciting thread.

eviLjazz and Capn_Fish still have my head reeling from all the big buzz they caused ! biggrin.gif

OK, first things first, this card is an rt2571 chipset card. It just so turns out that I also have an rt2571 Card too !

When I try to load this card with the rt73.o module installed, it will not load at all.

When I try to load this card with the rt2570.o module, everything works.

When I try to load my rt73 chipset card with the rt2570.o module, it starts up, but when I issue wireless-tools commands, it freezes
the system up or makes it run very slowly.

The solution therefore is a simple one:

I need the rt73.o module listed as I have an rt73 based card

You need the rt2570.o module as you have an rt2571 based card !

And here is the said module, which, in fact, I compiled yesterday from rt2570-k2wrlz-1.6.0 sources:

Attached File  rt2570.zip ( 276.54K ) Number of downloads: 17


same as before, change .zip to .o then load to:

/lib/modules/2.4.20/kernel/drivers/net/wireless


delete the rt73.o module now, or move it out of the ..../wireless directory to say /mnt/card

then do:

depmod -a
modprobe rt2570

insert the card, the card fires up immediately.

execute:

iwconfig

you should see the card listed under the RT2500 driver and NOT the rt73 driver.

BTW All the modules in this thread feature packet injection in Monitor mode, and this one is no exception wink.gif

let us know how you get on with this Module, all the best from all of us ! wink.gif
Go to the top of the page
 
+Quote Post
xamindar
post May 14 2010, 02:29 AM
Post #4





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



QUOTE(Allelectrix @ Oct 18 2008, 05:02 AM) *
You need the rt2570.o module as you have an rt2571 based card !

Just thought I would add a reply to this as I never did before. I just gave up. But to save anyone any trouble if they come across this. Allelectrix is incorrect. rt2570 is not the same as rt2571. This module is NOT for my card. As I stated in my previous post my card (d-link WUA-1340) requires the rt73 module. Weird it never worked correctly for me on my Zaurus. Might be because I am on the Sharp rom and not pdaXrom.

I just boot the Zaurus into debian anyway where it works correctly and it's fine that way.
Go to the top of the page
 
+Quote Post

Posts in this topic
Allelectrix   I Will Pay Anyone $150 Us Just Compile Aspj Rt73 Module For Zaurus   Aug 23 2008, 05:59 PM
Allelectrix   as of Monday September 29th 2008, this still appli...   Sep 29 2008, 05:28 AM
Frederic Bergeron   Looking on Google for "rt73.o zaurus" or...   Sep 29 2008, 07:25 AM
Allelectrix   QUOTE(Frederic Bergeron @ Sep 29 2008, 04...   Oct 1 2008, 05:42 PM
sdjf   Two thoughts. I know how frustrating what you are...   Oct 5 2008, 08:14 PM
Allelectrix   QUOTE(sdjf @ Oct 6 2008, 05:14 AM) Two th...   Oct 11 2008, 04:24 AM
Allelectrix   thanks for your help guys, keep this stuff coming ...   Oct 11 2008, 04:35 AM
Frederic Bergeron   Just out of curiosity, why don't you just buy ...   Oct 11 2008, 06:20 AM
Allelectrix   I've only got Hostap for 802.11b CF Cards and ...   Oct 11 2008, 11:50 AM
sdjf   Out of curiousity, what does "works for a few...   Oct 13 2008, 03:43 AM
Allelectrix   QUOTE(sdjf @ Oct 13 2008, 12:43 PM) Out o...   Oct 13 2008, 06:07 AM
Capn_Fish   OK, I'm getting Cacko dev stuff downloaded. We...   Oct 13 2008, 12:50 PM
Capn_Fish   Try this (It's likely broken in some way or an...   Oct 13 2008, 03:18 PM
Allelectrix   QUOTE(Capn_Fish @ Oct 14 2008, 12:18 AM) ...   Oct 14 2008, 03:05 PM
Capn_Fish   I tried 5 versions of the code (the one you had, a...   Oct 14 2008, 06:08 PM
laan   QUOTE(Capn_Fish @ Oct 15 2008, 04:08 AM) ...   Oct 14 2008, 09:26 PM
Allelectrix   QUOTE(laan @ Oct 15 2008, 06:26 AM) QUOTE...   Oct 15 2008, 03:15 AM
Capn_Fish   QUOTE(laan @ Oct 15 2008, 12:26 AM) QUOTE...   Oct 15 2008, 06:46 AM
louigi600   I had similar problems building zd1211 for 2.6.16....   Oct 15 2008, 10:27 AM
Allelectrix   Come on everybody ! Please help Capn_Fish solv...   Oct 15 2008, 10:49 AM
eviLjazz   I compiled the module against my kernel branch (se...   Oct 15 2008, 01:09 PM
Allelectrix   QUOTE(eviLjazz @ Oct 15 2008, 10:09 PM) I...   Oct 15 2008, 03:18 PM
eviLjazz   Glad the module is working. QUOTE(Allelectrix ...   Oct 15 2008, 09:46 PM
Allelectrix   The Beautiful Sight   Oct 15 2008, 04:01 PM
Frederic Bergeron   Beautiful indeed! You could almost hang the p...   Oct 15 2008, 04:46 PM
zmiq2   QUOTEI really don't think I have ever been so ...   Oct 15 2008, 11:57 PM
Allelectrix   Thanks evilJazz for that information, I'll hav...   Oct 16 2008, 03:44 AM
Capn_Fish   I've had an internet connection from a USB-Eth...   Oct 16 2008, 04:36 AM
Allelectrix   QUOTE(Capn_Fish @ Oct 16 2008, 01:36 PM) ...   Oct 16 2008, 07:49 AM
eviLjazz   Attached is the latest version 3.0.1 of the rt73 d...   Oct 16 2008, 09:54 AM
Allelectrix   QUOTE(eviLjazz @ Oct 16 2008, 06:54 PM) A...   Oct 16 2008, 02:47 PM
Allelectrix   QUOTE(eviLjazz @ Oct 16 2008, 06:54 PM) A...   Oct 16 2008, 03:19 PM
Allelectrix   also, someone made a sensitivity patch for 2.0.x. ...   Oct 17 2008, 04:13 AM
Allelectrix   OK, with all of your fine help, I just compiled it...   Oct 17 2008, 12:05 PM
xamindar   This post got me really excited as I have a usb ca...   Oct 18 2008, 01:06 AM
Allelectrix   xamindar wrote about his ralink rt2571 chipset car...   Oct 18 2008, 04:02 AM
Allelectrix   Yes, after applying the Sensitivity patch to the M...   Nov 1 2008, 11:29 AM
xamindar   QUOTE(Allelectrix @ Oct 18 2008, 05:02 AM...   May 14 2010, 02:29 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th September 2014 - 10:06 AM