OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> X-forwarding Unbearably Slow, firefox on SIMpad unusable
Master One
post Sep 10 2008, 12:55 AM
Post #1





Group: Members
Posts: 28
Joined: 13-January 07
Member No.: 13,912



I finally came around to test X-Forwarding on the SIMpad, as described here.

It kind of works, but it is unbearably slow. Connecting to an Ubuntu Hardy box with Firefox 3.0.1, this is what I get in the terminal:
CODE
$ssh user@ubuntubox -X firefox

(firefox:7819): Gdk-WARNING **: Connection to display localhost:10.0 appears to be untrusted. Pointer and keyboard grabs and inter-client communication may not work as expected.

(firefox:7819): Gdk-WARNING **: Coercing GDK_INPUT_ONLY toplevel window to GDK_INPUT_OUTPUT to work around bug in Xorg server

(firefox:7819): Gdk-WARNING **: Coercing GDK_INPUT_ONLY toplevel window to GDK_INPUT_OUTPUT to work around bug in Xorg server

(firefox:7819): Gdk-WARNING **: Coercing GDK_INPUT_ONLY toplevel window to GDK_INPUT_OUTPUT to work around bug in Xorg server

Firefox then starts, but it takes ages till the window display is completed, and then trying to use firefox on the SIMpad is that unbearably slow, that it can not be used seriously.

What can be the reason for that behaviour?
Does anybody have it working properly?
What about the shown two error messages?
Is it possible, that the SIMpad is not powerful enough, to handle such X-Forwarding over SSH on a WPA secured wireless connection?
Or is it possible, that this is some kind of networking problem (like OpenSSH trying to resolve the hostname or FQDN / DNS problem)?
Go to the top of the page
 
+Quote Post
koen
post Sep 10 2008, 01:01 AM
Post #2





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



X tunneling over ssh adds a lot of overhead and latencie, as does you wireless connection. Try doing remote X without tunneling (e.g. just by setting DISPLAY=simpadipaddress:0)
Go to the top of the page
 
+Quote Post
Master One
post Sep 10 2008, 01:05 AM
Post #3





Group: Members
Posts: 28
Joined: 13-January 07
Member No.: 13,912



You mean, I should log into the Ubuntu-box from the SIMpad over SSH, but without the "-X" option, and then do "DISPLAY=simpadip:0 firefox"?
Go to the top of the page
 
+Quote Post
koen
post Sep 10 2008, 07:13 AM
Post #4





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



Yeah, that's the idea
Go to the top of the page
 
+Quote Post
Master One
post Sep 11 2008, 08:14 AM
Post #5





Group: Members
Posts: 28
Joined: 13-January 07
Member No.: 13,912



CODE
$ DISPLAY=simpadip:0 firefox
No protocol specified
Error: cannot open display: simpadip:0

That's all I get, when trying SSHed into the Ubuntu-box. I do not really have any experience, when it comes down to X-Forwarding, so what could be the issue with this approach?

P.S. If the solution with X-Forwarding over SSH really is too demanding, why is it not mentioned in the HowTo on opensimpad.org under "Possible problems"? Since others seem to have it working properly, I am not convinced, that the problem I'm experiencing are a general issue.
Go to the top of the page
 
+Quote Post
koen
post Sep 11 2008, 01:52 PM
Post #6





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



replace 'simpadip' with the ip address of your simpad
Go to the top of the page
 
+Quote Post
Master One
post Sep 11 2008, 10:07 PM
Post #7





Group: Members
Posts: 28
Joined: 13-January 07
Member No.: 13,912



Sorry, for not being clear enough, but of course I did replace "simpadip" with the actual IP address, and nevertheless it is resulting in exactly that error messages as shown.
Go to the top of the page
 
+Quote Post
mr_nice
post Sep 12 2008, 03:06 AM
Post #8





Group: Members
Posts: 156
Joined: 21-September 05
Member No.: 8,161



Hi,
I use ssh with X forwarding on my simpad to surf with firefox 2.x on my slackware 12.1 box. The definition of slow and fast is allways user dependent. For me the speed is quite good. I was also able to watch a lowres youtube video. But I only own some older computers so it is possible that someone else find the response time realy slow. Feel free to add something to the wiki that it might be verry slow wink.gif .

You can try to do some speed tests with scp to see how fast your connection to your ubuntu box is.

For koens way you will need to set xhost + (for allowing every ip on your simpad). Please keep in mind that with this way all your traffic is not secure. Passwords etc (gksu e.g) are all send unencrypted over the network!

If unencrypted network traffic is no problem for you, you may also try tightvnc or rdesktop. tightvnc is currently not officialy available for angstrom but I can upload some ipkg if you are interested.
For rdesktop you can use the ipkg file that is available here [1] (don't use the 1.5 version from the feeds it is buggy and has some securety holes!).

... well we should think about an external simpad feed.

have fun with your pad
mr nice

1 http://www.oesf.org/forum/index.php?showtopic=25870
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 06:22 AM