OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Mail Problems, problem with mail and php
BJIce
post Sep 15 2008, 06:09 AM
Post #1





Group: Members
Posts: 1
Joined: 15-September 08
Member No.: 22,357



Hi,
I have this strange problem:
when I try to send mail via [ksh] shell on my OpenBSD 4.0 server there is no problem and mail is delivered, but when I try to send email via php with function mail() it return false and the mail is not sended.

I have readed everthing I can find about this problem but nothing seems to work.

I'm set my php.ini to use exacty the same sendmail I'm using when I send email via shell.

So if anyone had same problem and solved it, please tell me how to manage this.

Thanks in advance.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies (1 - 1)
desertrat
post Sep 16 2008, 01:17 AM
Post #2





Group: Members
Posts: 742
Joined: 15-October 05
From: Gulag, Siberia
Member No.: 8,322



QUOTE(BJIce @ Sep 15 2008, 02:09 PM) *
when I try to send mail via [ksh] shell on my OpenBSD 4.0 server there is no problem and mail is delivered, but when I try to send email via php with function mail() it return false and the mail is not sended.
When sending using php does the mail ever make it into the mail queue? Look at your mail logs to see whether mail is injected or not.

QUOTE
I'm set my php.ini to use exacty the same sendmail I'm using when I send email via shell.
How did you compile php? If at the time of compilation php doesn't find an appropriate sendmail it will compiled without mail support - however I'm not sure whether the mail() function is still available (but fails silently) or not.

Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2014 - 01:35 PM