OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Usb Network - Connection Problem
0laf
post Nov 1 2008, 11:25 AM
Post #1





Group: Members
Posts: 4
Joined: 16-September 07
Member No.: 20,407



Hello all,

at the moment I m trying to get USB networking configured for the Zaurus CL1000.
The Zaurus is running Angstrom x11-image 2007.12-r18.

Basically I tried to get it working by performing the steps which are described in the USB networking howto on the Angstrom wiki (http://linuxtogo.org/gowiki/AngstromManual)...
Nevertheless its not working for me blink.gif

I did following on the zaurus:
  • modprobe g_ether
  • ifconfig usb0 192.168.1.201 netmask 255.255.255.255 up
  • route add -host 192.168.1.101 usb0
  • then i had a look at the available network devices with ifconfig, interface "usb0" seemed to be fine

Next I continued with the configuration of the desktop computer (running debain etch 4.0 stable):
  • loaded the modules cdc_ether and usbnet
  • dmesg output:
    usb0: register 'cdc_ether' at usb-0000:00:08.1-2, CDC Ethernet Device, de:3a:e8:4a:93:2c
  • lsusb output:
    Bus 002 Device 010: ID 0525:a4a2 Netchip Technology, Inc. Linux-USB Ethernet/RNDIS Gadget
  • ifconfig usb0 192.168.1.101 netmask 255.255.255.255 up
  • route add -host 192.168.1.201 usb0
  • ifconfig output:

    usb0 Link encap:Ethernet HWaddr DE:3A:E8:4A:93:2C
    inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.255
    inet6 addr: fe80::dc3a:e8ff:fe4a:932c/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:108772 dropped:0 overruns:0 frame:0
    TX packets:6 errors:288 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b ) TX bytes:468 (468.0 b )


Well next I tried to test the connection with ping:
on the desktop: ping 192.168.1.101 -> ok, ping 192.168.1.201 -> not working
zaurus: ping 192.168.1.201 -> ok, ping 192.168.1.101 -> not working

Hm, obviously there is something wrong with my configuration sad.gif

I m somewhat stuck, any help would be greatly appreciated

Thanks in advance
olaf

Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
utx
post Nov 1 2008, 01:09 PM
Post #2





Group: Members
Posts: 135
Joined: 27-June 05
From: Prague, Czech Republic, Europe
Member No.: 7,468



You have bad configuration. You are configuring ifconfig with a different network address than route (101 x 201).

Here are my files:

Manual setup

ifcfg-usb0 for automatic setup in openSUSE
Go to the top of the page
 
+Quote Post
0laf
post Nov 2 2008, 05:02 AM
Post #3





Group: Members
Posts: 4
Joined: 16-September 07
Member No.: 20,407



QUOTE(utx @ Nov 1 2008, 10:09 PM) *
You have bad configuration. You are configuring ifconfig with a different network address than route (101 x 201).

Here are my files:

Manual setup

ifcfg-usb0 for automatic setup in openSUSE

Thanks for your reply, I tried your script, but usb networking is still not possible for me sad.gif
Now my config looks like that:
desktop:
ifconfig:
CODE
eth5 Link encap:Ethernet HWaddr 00:90:27:54:0E:D5
inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::290:27ff:fe54:ed5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:30073 errors:0 dropped:0 overruns:0 frame:0
TX packets:26165 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:30927764 (29.4 MiB) TX bytes:2415453 (2.3 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:589 errors:0 dropped:0 overruns:0 frame:0
TX packets:589 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:61128 (59.6 KiB) TX bytes:61128 (59.6 KiB)

usb0 Link encap:Ethernet HWaddr DE:3A:E8:4A:93:2C
inet addr:192.168.129.1 Bcast:192.168.129.255 Mask:255.255.255.255
inet6 addr: fe80::dc3a:e8ff:fe4a:932c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:96176 dropped:0 overruns:0 frame:0
TX packets:6 errors:501 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 cool.gif TX bytes:468 (468.0 cool.gif

route - n:
CODE
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.129.201 0.0.0.0 255.255.255.255 UH 0 0 0 usb0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth5
0.0.0.0 192.168.1.252 0.0.0.0 UG 0 0 0 eth5


zaurus:
ifconfig:
CODE
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1739 errors:0 dropped:0 overruns:0 frame:0
TX packets:1739 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:191760 (187.2 KiB) TX bytes: 191760 (187.2 KiB)

usb0 Link encap:Ethernet HWaddr 6A:67:78:C5:07:1B
inet addr:192.168.129.201 Bcast:192.168.129.255 Mask:255.255.255.255
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:30 errors:0 dropped:0 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1906 (1.8 KiB) TX bytes:756 (756.0 cool.gif

route - n:
CODE
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.129.1 0.0.0.0 255.255.255.255 UH 0 0 0 usb0
0.0.0.0 192.168.129.1 255.255.255.255 UG 0 0 0 usb0


i hope you can help me, that would be great

Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th September 2014 - 07:35 AM