OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Usb Network - Connection Problem
post Nov 1 2008, 11:25 AM
Post #1

Group: Members
Posts: 4
Joined: 16-September 07
Member No.: 20,407

Hello all,

at the moment I m trying to get USB networking configured for the Zaurus CL1000.
The Zaurus is running Angstrom x11-image 2007.12-r18.

Basically I tried to get it working by performing the steps which are described in the USB networking howto on the Angstrom wiki (http://linuxtogo.org/gowiki/AngstromManual)...
Nevertheless its not working for me blink.gif

I did following on the zaurus:
  • modprobe g_ether
  • ifconfig usb0 netmask up
  • route add -host usb0
  • then i had a look at the available network devices with ifconfig, interface "usb0" seemed to be fine

Next I continued with the configuration of the desktop computer (running debain etch 4.0 stable):
  • loaded the modules cdc_ether and usbnet
  • dmesg output:
    usb0: register 'cdc_ether' at usb-0000:00:08.1-2, CDC Ethernet Device, de:3a:e8:4a:93:2c
  • lsusb output:
    Bus 002 Device 010: ID 0525:a4a2 Netchip Technology, Inc. Linux-USB Ethernet/RNDIS Gadget
  • ifconfig usb0 netmask up
  • route add -host usb0
  • ifconfig output:

    usb0 Link encap:Ethernet HWaddr DE:3A:E8:4A:93:2C
    inet addr: Bcast: Mask:
    inet6 addr: fe80::dc3a:e8ff:fe4a:932c/64 Scope:Link
    RX packets:0 errors:108772 dropped:0 overruns:0 frame:0
    TX packets:6 errors:288 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b ) TX bytes:468 (468.0 b )
Well next I tried to test the connection with ping:
on the desktop: ping -> ok, ping -> not working
zaurus: ping -> ok, ping -> not working

Hm, obviously there is something wrong with my configuration sad.gif

I m somewhat stuck, any help would be greatly appreciated

Thanks in advance
Go to the top of the page
+Quote Post
Start new topic
post Nov 3 2008, 01:31 AM
Post #2

Group: Members
Posts: 10
Joined: 31-October 08
Member No.: 23,292

i wonder, whether you have a running usb-net connection between winxp and angstrom?

i finally found statements that due to an kernel bug this would not work. using pdaxrom it worked, but this used another windows driver, not rndis, but 3ndis - now with most recent angstrom i have a driver that cannot get initialized on windows side.

anyone running this constellation?

cheers, Oliver
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th June 2018 - 10:57 AM