OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Akita Install Report, Mostly awesome with just a touch of suck!
nontrivial
post Dec 31 2008, 07:27 PM
Post #1





Group: Members
Posts: 62
Joined: 28-October 03
From: OKC
Member No.: 791



I just installed zubuntu on my akita (Zaurus SLC1000) using an SD card for root and I just wanted to post how it is going so far. For the most part it runs fine. It takes a while to boot and start X, but once it is up and running it's actually faster than I thought it would be for most things. Just for giggles I tried suspend and was pleasantly shocked to see it works flawlessly.

Tweaks:
* I dedicated a swap partition on the SD card, but it wasn't usable until I ran mkswap on it.
* Added "/dev/mmcblk0p3 none swap sw 0 0" to fstab mount the swap automatically on boot.
* Added "/dev/mmcblk0p2 /media/card auto defaults 0 0" to fstab to mount an extra partition on the SD card.
* Added "/dev/mtdblock3 /media/nand jffs2 defaults 0 0" to fstab to mount NAND flash partion.
* Added "/dev/hda1 /media/cf auto defaults,sync,noauto 0 0" to fstab be able to easily mount the CF card.

Non Problem Problems :
* tskeys was running wild so I killed it (killall tskeys).
* Got funky warnings about understanding it's not a touch screen but X seems to work OK.
* Added pxa2xx_cs to modules and "modprobe pxa2xx_cs" to be able to mount the CF card.

Problems:
* Sound isn't working. spitz modules inserted, no errors with aplay, just no sound.
GUI volume control automutes eventually, cat /dev/urandom > /dev/dsp is black hole.
* Can't seem to rotate the display.

TODO:
* Get networking working and really start hacking.
* Get sound working.
* Get rotating working.
* Get Angstrom working dual boot style to compare.
* See about speeding things up some more.

Questions:
* How does one do home, end, and PageUp, PageDown, and function keys?
* Is it possible to switch over to a virtual console (hence the need for fn keys)?
* How does one map the calendar, address, mail, home, and menu keys?

TIA,
James
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
apink
post Jan 9 2009, 09:49 AM
Post #2





Group: Members
Posts: 105
Joined: 2-August 05
Member No.: 7,764



I have been using pdaxii13 nicely for several years on a daily basis regularly. Last year I migrated to debian briefly. I just tried zubuntu yesterday. For the most part it looks nice. I now have it completely on the sd card, so boot and startx times will hopefully drop when it is on the internal flash. But . . .

QUOTE
Just for giggles I tried suspend and was pleasantly shocked to see it works flawlessly.


. . . I am often just getting a blank screen with a flashing underscore cursor at the top of the screen when I come out of suspend. I am doing this with the power switch as was with pdax and every once in a while it does come back completely. I searched the forum for this and there is no mention. Am I missing something?

edit: After a day with it I have learned to stop my old pdaxrom learned habit of holding the power switch in for a couple of seconds to turn on and off. Suspend has been working just fine if I just hit the button quickly. smile.gif
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th August 2014 - 08:28 PM