OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Dhclient Fixed For Spitz, quotes from omegamoon blog
Jon_J
post Jan 6 2009, 02:07 PM
Post #1





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I didn't see this "fix" anywhere on OESF, so I decided to post it here.
This has worked for me on my SL-C3100. I'm not sure if this works on all covered models.
------------------------------------------------
credit goes to Stefani at omegamoon blog:
dhclient will fail with message "can't create addrlist socket" due the bad or missing support of the kernel capabilities.

Setting the user and group id of dhcp both to 0 (root) will solve the problem.

------------------------------------------------
credit goes to crash at omegamoon blog:
You have to modify the "dhcp" entry in the /etc/passwd file. That was a tip by Stefani earlier before:
"...Setting the user and group id of dhcp both to 0 (root) will solve the problem..."
Go to the top of the page
 
+Quote Post
speculatrix
post Jan 10 2009, 03:46 PM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



ah, that explains it! of course, if dhcpcd/dhclient wasn't running as root, it'd b0rk!

thanks for alerting us. that really does help!
Go to the top of the page
 
+Quote Post
teh.sean
post Feb 27 2009, 01:59 PM
Post #3





Group: Members
Posts: 77
Joined: 23-April 08
From: Cleveland, OH USA
Member No.: 21,673



QUOTE(Jon_J @ Jan 6 2009, 05:07 PM) *
You have to modify the "dhcp" entry in the /etc/passwd file. That was a tip by Stefani earlier before:
"...Setting the user and group id of dhcp both to 0 (root) will solve the problem..."


To those here who are linux newbies (like me!), would that be:
CODE
chmod u+s,g+s dhcp

Assuming I was already in /etc/passwd ?
Go to the top of the page
 
+Quote Post
teh.sean
post Feb 27 2009, 02:51 PM
Post #4





Group: Members
Posts: 77
Joined: 23-April 08
From: Cleveland, OH USA
Member No.: 21,673



Wait, further research makes me think this is a modification to the actual /etc/passwd file?

And in fact it is. For newbies: modify the dhcp line in /etc/passwd. The numbers 101 and 103 should be 0's.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2014 - 04:18 AM