OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Zubuntu 1.0 Rc1 Upgraded To Ubuntu Jaunty 9.04 Armel, Zubuntu Jaunty 9.04 Desktop Rootfs
same
post Feb 15 2009, 09:23 AM
Post #1





Group: Members
Posts: 51
Joined: 29-October 07
From: barcelona
Member No.: 20,873



Hello,

Just another rootfs to play while waiting for the next cortez release smile.gif

Upgraded "Zubuntu 1.0 Rc1" (Handhelds' Mojo Ubuntu Hardy 8.04 [Hasty]) to "Ubuntu Jaunty 9.04 ARMEL".
Repository: http://ports.ubuntu.com/dists/jaunty/


Screenshot

One can install the linked rootfs or upgrade from the original cortez-rootfs.

Post UPDATES:
- all questions in Zubuntu Rc1 thread apply to this rootfs.
- for 760-860 zaurii read following posts to fix touchscreen and keymap bugs.
- removed "lost+found" folder from rootfs, my fault. sorry. new rootfs linked.
- installed, disabled and put "on hold" the package apt-xapian-index (eat too much resources).
- added recomendation about checking bad block before install.

________________________________________________________

BACKUP your existing system.
For an SD card, "halt" zaurus and from your linux pc with the sd card mounted, type:
CODE
cd /media/sdcard
tar --exclude="lost+found" -cpf ~/zubuntu-backup.tar .

________________________________________________________

INSTALL instructions available in Omegamoon and use this "zubuntu-desktop root filesystem"

zubuntu-desktop-jaunty-rootfs_feb.2009-rev-armel.tar.bz2
MD5: 274d5f798e05e2fa1da85c941203bae3
Uploaded: 02/16/09
File Size: 98.06 MB (Extracted: ~375 MB)

- After formating and before extracting the rootfs, you should check and mark bad block in sd card:
CODE
fsck -fcp /dev/sdb1
where /dev/sdb1 is the partition of your SD card
- How to extract the .tar.bz2 file:
CODE
tar xpjf zubuntu-desktop-jaunty-rootfs_feb.2009-rev-armel.tar.bz2 -C /media/sdcard

- Remember to add the kernel and modules from Omegamoon and edit /etc/fstab.
- Boot and
CODE
apt-get update
apt-get install fennec abiword gnumeric geany xtightvncviewer x11vnc xournal cellwriter pidgin ...

- Has a "fake" boot splash. To disable it add "psplash=false" in /boot/kernel-cmdline.
- "Home" key is Terminal launcher, "Mail" key is WiFi toggle, "Alt+`" is F11 [fullscreen].
________________________________________________________

UPGRADE your existing "Zubuntu 1.0 Rc1":
1. in files /var/lib/dpkg/status and /var/lib/dpkg/available
replace all "Architecture: arm" with "Architecture: armel"

2. in file /etc/apt/apt.conf add:
QUOTE
APT::Architecture "armel";
Dpkg::Options:: "--force-architecture";

3. in file /etc/apt/sources.list remove everything and add:
QUOTE
#9.04 Jaunty Jackalope
deb http://ports.ubuntu.com/ jaunty main restricted universe multiverse
deb http://ports.ubuntu.com/ jaunty-updates main restricted universe multiverse
deb http://ports.ubuntu.com/ jaunty-proposed main restricted universe multiverse
deb http://ports.ubuntu.com/ jaunty-security main restricted universe multiverse

4. then
CODE
apt-get update
apt-get upgrade


All Ubuntu Jaunty official repository packages for your zaurus biggrin.gif
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
same
post Feb 17 2009, 02:40 AM
Post #2





Group: Members
Posts: 51
Joined: 29-October 07
From: barcelona
Member No.: 20,873



BerndS: i don't have acces to a 760,
but from command line, does the ts_calibrate program work?
if not:
1) do a grep -i handlers /proc/bus/input/devices
and check the second line starting with a "H: Handlers="
2) then grep TS ~/.profile
this line should have the same event* as the previous command
if it's not the same, nano ~/.profile and change the TSLIB_TSDEVICE line and specify the proper device
3) then logout, login, and run ts_calibrate again
4) if it doesn't work, try editing /etc/ts.conf and uncomment (remove the #) at the line module_raw corgi and run ts_calibrate again

bobey: you need to extract two files, with a z 3000
1) the kernel an modules: http://www.zaurus.org.uk/cortez/ubuntu/dow...addition.tar.gz
2) and the desired rootfs
Go to the top of the page
 
+Quote Post
BerndS
post Feb 17 2009, 07:38 AM
Post #3





Group: Members
Posts: 66
Joined: 26-September 04
Member No.: 4,770



Hi,

>>BerndS: i don't have acces to a 760,
>>but from command line, does the ts_calibrate program work?

No, it fails with

ts_open: No such file or directory

>>if not:
>>1) do a grep -i handlers /proc/bus/input/devices

H: Handlers=kbd event0 apm-power
H: Handlers=event1

>>and check the second line starting with a "H: Handlers="

export TSLIB_TSDEVICE=/dev/input/event2

>>2) then grep TS ~/.profile
>>this line should have the same event* as the previous command
>>if it's not the same, nano ~/.profile and change the TSLIB_TSDEVICE line and specify the proper device

changed to

export TSLIB_TSDEVICE=/dev/input/event1


>>3) then logout, login, and run ts_calibrate again

works

Restarted X and now the Stylus works in X!

But the keyboard still does not work while X is running (excpet CTRL-ALT-BACKSPACE) ...

>>4) if it doesn't work, try editing /etc/ts.conf and uncomment (remove the #) at the line module_raw corgi and run ts_calibrate again

Tested this also:

ts_calibrate
xres = 640, yres = 400
ts_read: Invalid argument


One other (very) minor issue:

After the installation the GUI started in Portrait mode. Therefor I removed the line

xrandr -o right

from the .xinitrc file . Now the GUI starts correctly in Landscape mode (hopefully I did not mix the Portrait/Landscape here ..)

The boot messages are also correct but the initial graphical Ubunutu logo is still in the wrong mode -- can this be corrected?

Thanks

Bernd



QUOTE(same @ Feb 17 2009, 11:40 AM) *
BerndS: i don't have acces to a 760,
1) do a grep -i handlers /proc/bus/input/devices
and check the second line starting with a "H: Handlers="
2) then grep TS ~/.profile
this line should have the same event* as the previous command
if it's not the same, nano ~/.profile and change the TSLIB_TSDEVICE line and specify the proper device
3) then logout, login, and run ts_calibrate again
4) if it doesn't work, try editing /etc/ts.conf and uncomment (remove the #) at the line module_raw corgi and run ts_calibrate again

bobey: you need to extract two files, with a z 3000
1) the kernel an modules: http://www.zaurus.org.uk/cortez/ubuntu/dow...addition.tar.gz
2) and the desired rootfs

Go to the top of the page
 
+Quote Post
same
post Feb 17 2009, 01:31 PM
Post #4





Group: Members
Posts: 51
Joined: 29-October 07
From: barcelona
Member No.: 20,873



BerndS: edit /etc/ts.conf and comment (add the #) at the line module_raw corgi, this step was just in case the previous steps haven't worked.

if C+Alt+S works, the keyb is up under X? seems wrong keymap loaded in (.xinitrc)
the line test -f uses the reply of the grep Hardware /proc/cpuinfo, try hardcoding it (replace $HARDWARE with one given by ls /etc/X11/kb/) try different options or comment this line.

About boot splash, edit /etc/defaults/psplash and remove -a 270 but it will look weird

Capn_Fish hope everything goes as expected unsure.gif

EzerchE maybe you where extracting the tar.bz2 without root account, anyway, you got it smile.gif
1. mouse is moving like screen rotated, mouse moving for vertical view, but i am using it horizontially.
i don't use mouse, i don't have an adapter.
2. i have linksys wcf 12 and how can i connect to wireless network
that's ubuntu basics, but start checking /etc/network/interfaces
Go to the top of the page
 
+Quote Post
BerndS
post Feb 18 2009, 09:09 AM
Post #5





Group: Members
Posts: 66
Joined: 26-September 04
Member No.: 4,770



Hi,

QUOTE
BerndS: edit /etc/ts.conf and comment (add the #) at the line module_raw corgi, this step was just in case the previous steps haven't worked.


I already did that direct after the failed test

QUOTE
if C+Alt+S works, the keyb is up under X? seems wrong keymap loaded in (.xinitrc)
the line test -f uses the reply of the grep Hardware /proc/cpuinfo, try hardcoding it (replace $HARDWARE with one given by ls /etc/X11/kb/) try different options or comment this line.


With Akita the keyboard works; /proc/cpuinfo returns "Husky".

QUOTE
About boot splash, edit /etc/defaults/psplash and remove -a 270 but it will look weird

Done (I don't think it looks better with the -a 270)

Thanks again

Bernd

Go to the top of the page
 
+Quote Post

Posts in this topic
same   Zubuntu 1.0 Rc1 Upgraded To Ubuntu Jaunty 9.04 Armel   Feb 15 2009, 09:23 AM
tanjian2   Any performance difference between Hardy and Jaunt...   Feb 15 2009, 04:23 PM
same   QUOTEAny performance difference between Hardy and ...   Feb 16 2009, 03:33 AM
BerndS   Hi, I installed it in on my CL-760 (a partition o...   Feb 16 2009, 10:20 AM
apink   QUOTE(BerndS @ Feb 16 2009, 10:20 AM) Hi,...   Feb 16 2009, 11:08 AM
bobey   Hello, I am trying to install Zubuntu on...   Feb 16 2009, 04:59 PM
same   BerndS: i don't have acces to a 760, but from...   Feb 17 2009, 02:40 AM
BerndS   Hi, >>BerndS: i don't have acces to a 7...   Feb 17 2009, 07:38 AM
EzerchE   I have uploaded the root files to my usb flash dis...   Feb 17 2009, 10:44 AM
EzerchE   QUOTE(EzerchE @ Feb 17 2009, 10:44 AM) I ...   Feb 17 2009, 11:06 AM
same   BerndS: edit /etc/ts.conf and comment (add the #) ...   Feb 17 2009, 01:31 PM
BerndS   Hi, QUOTEBerndS: edit /etc/ts.conf and comment (a...   Feb 18 2009, 09:09 AM
bobey   QUOTE(same @ Feb 17 2009, 02:40 PM) bobey...   Feb 17 2009, 02:51 PM
Capn_Fish   I think "apt-get dist-upgrade" would be ...   Feb 17 2009, 04:47 AM
Capn_Fish   I'm doing my upgrade now (not a fresh install)...   Feb 17 2009, 10:05 AM
EzerchE   Now i installed it, its working very fast but i h...   Feb 17 2009, 12:12 PM
Capn_Fish   Everything went well, and it seems to be working f...   Feb 18 2009, 09:58 AM
arnpsyke   great job ! i have installed zubuntu and it wo...   Feb 19 2009, 09:44 AM
Capn_Fish   Try MPlayer (the Angstrom version or the pdaXrom i...   Feb 19 2009, 11:17 AM
arnpsyke   QUOTE(Capn_Fish @ Feb 19 2009, 11:17 AM) ...   Feb 19 2009, 11:56 AM
tanjian2   QUOTE(Capn_Fish @ Feb 19 2009, 07:17 PM) ...   Feb 19 2009, 03:38 PM
Capn_Fish   QUOTE(tanjian2 @ Feb 19 2009, 05:38 PM) Q...   Feb 20 2009, 11:00 AM
ofels   QUOTE(Capn_Fish @ Feb 20 2009, 08:00 PM) ...   Feb 21 2009, 08:42 AM
arnpsyke   hello I installed successfuly mplayer on zubuntu :...   Feb 19 2009, 04:49 PM
crash1104   QUOTE(arnpsyke @ Feb 20 2009, 01:49 AM) h...   Mar 5 2009, 12:39 AM
same   QUOTEConnection Managerconnman The core Connection...   Feb 20 2009, 02:55 AM
HRH_H_Crab   QUOTE(same @ Feb 20 2009, 11:55 AM) anyon...   Apr 3 2009, 11:43 PM
same   QUOTE(HRH_H_Crab @ Apr 3 2009, 11:43 PM) ...   Apr 12 2009, 12:29 PM
duo   QUOTE"Can't get session bus: failed execu...   Jul 1 2009, 12:52 PM
diesel1   Hi all, I upgraded my RC1 to Jaunty as described ...   Jul 8 2009, 01:31 PM
same   QUOTE(diesel1 @ Jul 8 2009, 01:31 PM) Hi ...   Jul 11 2009, 01:17 PM
diesel1   QUOTE(same @ Jul 11 2009, 10:17 PM) QUOTE...   Jul 12 2009, 04:38 PM
same   QUOTE(diesel1 @ Jul 12 2009, 04:38 PM) QU...   Jul 13 2009, 01:26 AM
diesel1   QUOTE(same @ Jul 13 2009, 10:26 AM) QUOTE...   Jul 13 2009, 02:26 PM
arnpsyke   Many thanks for connman same ! I'll try it...   Feb 21 2009, 02:59 AM
Capn_Fish   (Sorry if you already know this) MPlayer normally...   Feb 21 2009, 08:50 AM
ofels   QUOTE(Capn_Fish @ Feb 21 2009, 05:50 PM) ...   Feb 22 2009, 09:06 AM
dsteuer   Hi! First of all big thanks! Call me impr...   Mar 5 2009, 05:58 AM
Chero   QUOTE(dsteuer @ Mar 5 2009, 02:58 PM) Hi...   Mar 14 2009, 08:36 AM
canguy247   QUOTE(Chero @ Mar 14 2009, 12:36 PM) Now ...   Mar 14 2009, 11:38 AM
Chero   QUOTE(canguy247 @ Mar 14 2009, 08:38 PM) ...   Mar 15 2009, 12:05 AM
dsteuer   How can I persuade Jaunty to display german umlaut...   Mar 11 2009, 01:14 AM
RX Shorty   Tried a fresh installation, but got a init not fou...   Jul 1 2009, 06:08 AM
adf   All this seemed to do is to remove most of my syst...   Sep 8 2009, 09:46 PM
diesel1   QUOTE(adf @ Sep 9 2009, 06:46 AM) All thi...   Nov 20 2009, 05:54 PM
ppyo   I installed Zubuntu v1 but it is slow with LXDE, s...   Sep 10 2009, 04:58 PM
ptoki   I am confirming that. LXDE is not much slow but it...   Sep 10 2009, 11:37 PM
danboid   I've read numerous threads in the oesf (z)ubun...   Mar 16 2010, 09:10 AM
danboid   I've read numerous threads in the oesf (z)ubun...   Mar 16 2010, 11:31 AM
danboid   I have tried to install this jaunty zubuntu tarbal...   Mar 16 2010, 03:04 PM
danboid   Whoah! I now now have Jaunty booting on my...   Mar 17 2010, 08:26 AM
ArchiMark   Hi all.... I know it has been about 4 years since...   Sep 4 2014, 05:27 AM
YoG   QUOTE(ArchiMark @ Sep 4 2014, 04:27 PM) H...   Sep 6 2014, 10:21 AM
ArchiMark   Hi, To clarify.... Omegamoon has different vers...   Sep 6 2014, 11:05 AM
YoG   QUOTE(ArchiMark @ Sep 6 2014, 10:05 PM) H...   Sep 6 2014, 12:11 PM
ArchiMark   Hopefully, somebody still has the file and can sha...   Sep 6 2014, 03:33 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th September 2014 - 01:30 PM