OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Zubuntu 1.0 Rc1 Upgraded To Ubuntu Jaunty 9.04 Armel, Zubuntu Jaunty 9.04 Desktop Rootfs
same
post Feb 15 2009, 09:23 AM
Post #1





Group: Members
Posts: 51
Joined: 29-October 07
From: barcelona
Member No.: 20,873



Hello,

Just another rootfs to play while waiting for the next cortez release smile.gif

Upgraded "Zubuntu 1.0 Rc1" (Handhelds' Mojo Ubuntu Hardy 8.04 [Hasty]) to "Ubuntu Jaunty 9.04 ARMEL".
Repository: http://ports.ubuntu.com/dists/jaunty/


Screenshot

One can install the linked rootfs or upgrade from the original cortez-rootfs.

Post UPDATES:
- all questions in Zubuntu Rc1 thread apply to this rootfs.
- for 760-860 zaurii read following posts to fix touchscreen and keymap bugs.
- removed "lost+found" folder from rootfs, my fault. sorry. new rootfs linked.
- installed, disabled and put "on hold" the package apt-xapian-index (eat too much resources).
- added recomendation about checking bad block before install.

________________________________________________________

BACKUP your existing system.
For an SD card, "halt" zaurus and from your linux pc with the sd card mounted, type:
CODE
cd /media/sdcard
tar --exclude="lost+found" -cpf ~/zubuntu-backup.tar .

________________________________________________________

INSTALL instructions available in Omegamoon and use this "zubuntu-desktop root filesystem"

zubuntu-desktop-jaunty-rootfs_feb.2009-rev-armel.tar.bz2
MD5: 274d5f798e05e2fa1da85c941203bae3
Uploaded: 02/16/09
File Size: 98.06 MB (Extracted: ~375 MB)

- After formating and before extracting the rootfs, you should check and mark bad block in sd card:
CODE
fsck -fcp /dev/sdb1
where /dev/sdb1 is the partition of your SD card
- How to extract the .tar.bz2 file:
CODE
tar xpjf zubuntu-desktop-jaunty-rootfs_feb.2009-rev-armel.tar.bz2 -C /media/sdcard

- Remember to add the kernel and modules from Omegamoon and edit /etc/fstab.
- Boot and
CODE
apt-get update
apt-get install fennec abiword gnumeric geany xtightvncviewer x11vnc xournal cellwriter pidgin ...

- Has a "fake" boot splash. To disable it add "psplash=false" in /boot/kernel-cmdline.
- "Home" key is Terminal launcher, "Mail" key is WiFi toggle, "Alt+`" is F11 [fullscreen].
________________________________________________________

UPGRADE your existing "Zubuntu 1.0 Rc1":
1. in files /var/lib/dpkg/status and /var/lib/dpkg/available
replace all "Architecture: arm" with "Architecture: armel"

2. in file /etc/apt/apt.conf add:
QUOTE
APT::Architecture "armel";
Dpkg::Options:: "--force-architecture";

3. in file /etc/apt/sources.list remove everything and add:
QUOTE
#9.04 Jaunty Jackalope
deb http://ports.ubuntu.com/ jaunty main restricted universe multiverse
deb http://ports.ubuntu.com/ jaunty-updates main restricted universe multiverse
deb http://ports.ubuntu.com/ jaunty-proposed main restricted universe multiverse
deb http://ports.ubuntu.com/ jaunty-security main restricted universe multiverse

4. then
CODE
apt-get update
apt-get upgrade


All Ubuntu Jaunty official repository packages for your zaurus biggrin.gif
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
danboid
post Mar 16 2010, 03:04 PM
Post #2





Group: Members
Posts: 682
Joined: 26-December 05
From: Rochdale, Lancashire
Member No.: 8,789



I have tried to install this jaunty zubuntu tarball a few times now with both spitz-root-addition.tar.gz and spitz-root-addition-v2.0.tar.gz only to get the same 'unable to open initial console' error. I've just updated my previous post as my tar command was incorrect as I have been extracting both my tar.gz files with 'tar xpzvf', I just don't normally bother to include the 'p', but that is specified in the OP's instructions so thats what I've be trying.

Its also important to mention that 'fsck -fcp /dev/hda1' returns no errors, I have checked the md5sum of zubuntu-desktop-jaunty-rootfs_feb.2009-rev-armel.tar.bz2 is OK and that when I extracted zubuntu-desktop-jaunty-rootfs_feb.2009-rev-armel.tar.bz2 on my PC I did so as root using a command beginning 'tar xpvjf' and when I re-tarred the contents (again on my PC) I did so as root with 'tar cpvf' - they should do it right?

I'd like to hear from anyone who has successfully installed zubuntu-desktop-jaunty-rootfs_feb.2009-rev-armel.tar.bz2 on a c3000 without either having to have an existing OS installed on the MD or having to physically remove the MD and copy stuff over that way. Did you have to alter /etc/fstab and if so how? I am starting to wonder if I'm having probs due to a bug within Lineo uLinux's kernel or its busybox/tar/mk2efs or some other software of my NAND I'm using here? I think the install tools used for pdaXii13 etc. are a bit newer (if still old) than the versions integrated in the c3000 NAND/ D+B menu (Lineo). I have also tried to install zubuntu by booting the pdaXii13 5.4.9 installer off an SD card the choosing the command option but unlike Lineo it doesn't register cards inserted into the CF slot nor USB memory sticks.

I have yet to try installing using the original zubuntu 1.0RC rootfs so thats my next thing to try..

EDIT

I have now tried following my install procedure detailed in my last post with zubuntu-desktop-rc1.tar.gz and spitz-root-addition.tar.gz yet I'm still just getting the same ol' 'unable to open initial console' warning so now I presume my install method is not an option ie you have to have a full c3000 Zaurus OS installed somewhere and available to boot into to install zubuntu onto your MD or you have to remove you MD and stick it directly into your PC's CF slot OR do I just need a certain fstab entry/adjustment to get zubuntu to boot?
Go to the top of the page
 
+Quote Post

Posts in this topic
same   Zubuntu 1.0 Rc1 Upgraded To Ubuntu Jaunty 9.04 Armel   Feb 15 2009, 09:23 AM
tanjian2   Any performance difference between Hardy and Jaunt...   Feb 15 2009, 04:23 PM
same   QUOTEAny performance difference between Hardy and ...   Feb 16 2009, 03:33 AM
BerndS   Hi, I installed it in on my CL-760 (a partition o...   Feb 16 2009, 10:20 AM
apink   QUOTE(BerndS @ Feb 16 2009, 10:20 AM) Hi,...   Feb 16 2009, 11:08 AM
bobey   Hello, I am trying to install Zubuntu on...   Feb 16 2009, 04:59 PM
same   BerndS: i don't have acces to a 760, but from...   Feb 17 2009, 02:40 AM
BerndS   Hi, >>BerndS: i don't have acces to a 7...   Feb 17 2009, 07:38 AM
EzerchE   I have uploaded the root files to my usb flash dis...   Feb 17 2009, 10:44 AM
EzerchE   QUOTE(EzerchE @ Feb 17 2009, 10:44 AM) I ...   Feb 17 2009, 11:06 AM
same   BerndS: edit /etc/ts.conf and comment (add the #) ...   Feb 17 2009, 01:31 PM
BerndS   Hi, QUOTEBerndS: edit /etc/ts.conf and comment (a...   Feb 18 2009, 09:09 AM
bobey   QUOTE(same @ Feb 17 2009, 02:40 PM) bobey...   Feb 17 2009, 02:51 PM
Capn_Fish   I think "apt-get dist-upgrade" would be ...   Feb 17 2009, 04:47 AM
Capn_Fish   I'm doing my upgrade now (not a fresh install)...   Feb 17 2009, 10:05 AM
EzerchE   Now i installed it, its working very fast but i h...   Feb 17 2009, 12:12 PM
Capn_Fish   Everything went well, and it seems to be working f...   Feb 18 2009, 09:58 AM
arnpsyke   great job ! i have installed zubuntu and it wo...   Feb 19 2009, 09:44 AM
Capn_Fish   Try MPlayer (the Angstrom version or the pdaXrom i...   Feb 19 2009, 11:17 AM
arnpsyke   QUOTE(Capn_Fish @ Feb 19 2009, 11:17 AM) ...   Feb 19 2009, 11:56 AM
tanjian2   QUOTE(Capn_Fish @ Feb 19 2009, 07:17 PM) ...   Feb 19 2009, 03:38 PM
Capn_Fish   QUOTE(tanjian2 @ Feb 19 2009, 05:38 PM) Q...   Feb 20 2009, 11:00 AM
ofels   QUOTE(Capn_Fish @ Feb 20 2009, 08:00 PM) ...   Feb 21 2009, 08:42 AM
arnpsyke   hello I installed successfuly mplayer on zubuntu :...   Feb 19 2009, 04:49 PM
crash1104   QUOTE(arnpsyke @ Feb 20 2009, 01:49 AM) h...   Mar 5 2009, 12:39 AM
same   QUOTEConnection Managerconnman The core Connection...   Feb 20 2009, 02:55 AM
HRH_H_Crab   QUOTE(same @ Feb 20 2009, 11:55 AM) anyon...   Apr 3 2009, 11:43 PM
same   QUOTE(HRH_H_Crab @ Apr 3 2009, 11:43 PM) ...   Apr 12 2009, 12:29 PM
duo   QUOTE"Can't get session bus: failed execu...   Jul 1 2009, 12:52 PM
diesel1   Hi all, I upgraded my RC1 to Jaunty as described ...   Jul 8 2009, 01:31 PM
same   QUOTE(diesel1 @ Jul 8 2009, 01:31 PM) Hi ...   Jul 11 2009, 01:17 PM
diesel1   QUOTE(same @ Jul 11 2009, 10:17 PM) QUOTE...   Jul 12 2009, 04:38 PM
same   QUOTE(diesel1 @ Jul 12 2009, 04:38 PM) QU...   Jul 13 2009, 01:26 AM
diesel1   QUOTE(same @ Jul 13 2009, 10:26 AM) QUOTE...   Jul 13 2009, 02:26 PM
arnpsyke   Many thanks for connman same ! I'll try it...   Feb 21 2009, 02:59 AM
Capn_Fish   (Sorry if you already know this) MPlayer normally...   Feb 21 2009, 08:50 AM
ofels   QUOTE(Capn_Fish @ Feb 21 2009, 05:50 PM) ...   Feb 22 2009, 09:06 AM
dsteuer   Hi! First of all big thanks! Call me impr...   Mar 5 2009, 05:58 AM
Chero   QUOTE(dsteuer @ Mar 5 2009, 02:58 PM) Hi...   Mar 14 2009, 08:36 AM
canguy247   QUOTE(Chero @ Mar 14 2009, 12:36 PM) Now ...   Mar 14 2009, 11:38 AM
Chero   QUOTE(canguy247 @ Mar 14 2009, 08:38 PM) ...   Mar 15 2009, 12:05 AM
dsteuer   How can I persuade Jaunty to display german umlaut...   Mar 11 2009, 01:14 AM
RX Shorty   Tried a fresh installation, but got a init not fou...   Jul 1 2009, 06:08 AM
adf   All this seemed to do is to remove most of my syst...   Sep 8 2009, 09:46 PM
diesel1   QUOTE(adf @ Sep 9 2009, 06:46 AM) All thi...   Nov 20 2009, 05:54 PM
ppyo   I installed Zubuntu v1 but it is slow with LXDE, s...   Sep 10 2009, 04:58 PM
ptoki   I am confirming that. LXDE is not much slow but it...   Sep 10 2009, 11:37 PM
danboid   I've read numerous threads in the oesf (z)ubun...   Mar 16 2010, 09:10 AM
danboid   I've read numerous threads in the oesf (z)ubun...   Mar 16 2010, 11:31 AM
danboid   I have tried to install this jaunty zubuntu tarbal...   Mar 16 2010, 03:04 PM
danboid   Whoah! I now now have Jaunty booting on my...   Mar 17 2010, 08:26 AM
ArchiMark   Hi all.... I know it has been about 4 years since...   Sep 4 2014, 05:27 AM
YoG   QUOTE(ArchiMark @ Sep 4 2014, 04:27 PM) H...   Sep 6 2014, 10:21 AM
ArchiMark   Hi, To clarify.... Omegamoon has different vers...   Sep 6 2014, 11:05 AM
YoG   QUOTE(ArchiMark @ Sep 6 2014, 10:05 PM) H...   Sep 6 2014, 12:11 PM
ArchiMark   Hopefully, somebody still has the file and can sha...   Sep 6 2014, 03:33 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st November 2014 - 10:00 AM