OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Resurrecting A Collie, No charging, no SD card access
post Feb 19 2009, 03:08 PM
Post #1

Group: Members
Posts: 366
Joined: 4-November 03
From: Slovakia
Member No.: 850

Hi all,

I've been trying to bring my trusty SL-5500 back to life. I have successfully set up OpenEmbedded, built and flashed kexecboot. I'm currently stuck on a few issues:

1. SD card isn't really working. An Angstrom image unpacked onto an ext2 SD partition is recognized by kexecboot but booting ends with a flurry of error messages like this:

Buffer I/O error on device mmcblk0p1, logical block 8
mmcblk0: retrying using single block read
mmcblk0: error -22 sending status comand<3>mmcblk0: error -22 sending read/write command, response 0x4, card status 0xff04
end_request: I/O error, dev mmcblk0, sector 104

The same error messages turn up if I boot from ROM or a CF card and then insert an SD card. The most recent kernel I've tried this with is from this morning (19 February 2009) and it's a 2.6.28. I have seen this with two different cards from two different manufacturers. I have tested the cards for errors on a different machine and they seem to be OK.

2. An Opie image on a CF card boots up to the "Tap anywhere..." screen where it freezes.

3. Battery charging doesn't work. When the charger is connected the LED doesn't light up and the battery stays discharged even after several hours. I've established that this isn't a hardware problem - when I flash a Sharp ROM (from http://www.myzaurus.com/ROMupdate5.asp) everything works as it's supposed to.

Any help with any of these issues will be appreciated. A few particular questions:

- regarding issue 3: I've read about a "service menu" accessible by pressing some key or key combination while connecting the charger. Supposedly one can set various voltage thresholds in the menu but I've never been able to get to it in the first place. Anyone know any details?

- regarding issue 1: I have a vague impression that the first OE images I built a couple weeks ago didn't have the SD card problem. Is there a particular node in the git tree that's been verified to have working SD support on collie? Also, would anyone be willing to check SD access on a current OE image on their own collie?

The device is otherwise pretty functional - I can even ssh to the collie over a USB cable. I think I'll make the thing useful again eventually.


Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st June 2018 - 01:58 AM