OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Can Boot Zubuntu From Sd But Not From Cf Card
post Apr 14 2009, 11:20 AM
Post #1

Group: Members
Posts: 3
Joined: 4-April 09
From: Germany
Member No.: 35,651

I followed cortez instruction to install zubuntu on a SD card and that worked okay (with the problem solutions from this forum). Then I got myself a 16 GB CF card and copied the rootfs there. But my Zaurus C760 won't boot from there. It goes

Probing /dev/mtdblock0
Probing /dev/mtdblock1
Probing /dev/mtdblock2
found  /dev/mtdblock2 (jffs2)
mount successful
/dev/mtdblock2 no kernel found, unmounting
Probing /dev/mtdblock3
Probing /dev/mmcblk0
Probing /dev/mmcblk0p1
found  /dev/mmcblk0p1 (vfat)
mount successful
/dev/mmcblk0p1 no kernel found, unmounting
No bootable device found

I assume the mmcblk message come from the SD card from which I flashed the kexec kernel, which was still in the device. But I would have expected that it probes /dev/hda1 /dev/hda2 and so forth. I have the feeling it does not even look at the CF card. Could it be that the kernel at http://www.zaurus.org.uk/cortez/ubuntu/dow...c7x0/zImage.bin simply does not expect CF cards?

The CF card itself seems okay. If I boot zubuntu from the SD card I can mount the CF card partitions (/dev/hda1 ...) no problem.
I also checked the md5 sums on zImage.bin and flashed it another time. Same result.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th May 2018 - 09:29 PM