OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Can Boot Zubuntu From Sd But Not From Cf Card
drautzbug
post Apr 14 2009, 11:20 AM
Post #1





Group: Members
Posts: 3
Joined: 4-April 09
From: Germany
Member No.: 35,651



I followed cortez instruction to install zubuntu on a SD card and that worked okay (with the problem solutions from this forum). Then I got myself a 16 GB CF card and copied the rootfs there. But my Zaurus C760 won't boot from there. It goes

CODE
Probing /dev/mtdblock0
Probing /dev/mtdblock1
Probing /dev/mtdblock2
found  /dev/mtdblock2 (jffs2)
mount successful
/dev/mtdblock2 no kernel found, unmounting
Probing /dev/mtdblock3
Probing /dev/mmcblk0
Probing /dev/mmcblk0p1
found  /dev/mmcblk0p1 (vfat)
mount successful
/dev/mmcblk0p1 no kernel found, unmounting
No bootable device found

I assume the mmcblk message come from the SD card from which I flashed the kexec kernel, which was still in the device. But I would have expected that it probes /dev/hda1 /dev/hda2 and so forth. I have the feeling it does not even look at the CF card. Could it be that the kernel at http://www.zaurus.org.uk/cortez/ubuntu/dow...c7x0/zImage.bin simply does not expect CF cards?

The CF card itself seems okay. If I boot zubuntu from the SD card I can mount the CF card partitions (/dev/hda1 ...) no problem.
I also checked the md5 sums on zImage.bin and flashed it another time. Same result.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
drautzbug
post Apr 15 2009, 02:20 AM
Post #2





Group: Members
Posts: 3
Joined: 4-April 09
From: Germany
Member No.: 35,651



I believe the kexec kernel provided by omegamoon simply does not look at CF cards. I now flashed zImage-kexecboot-2.6.26-r12-c7x0.bin from Angström and it does find zubuntu on the CF card and starts to boot it smile.gif . But then it stops with something like "waiting for root /dev/hda1" .

I assume this is because some module is not yet loaded at this stage. I will try to locate the module and put it into /etc/modules.
Go to the top of the page
 
+Quote Post
apink
post Dec 22 2009, 12:39 AM
Post #3





Group: Members
Posts: 105
Joined: 2-August 05
Member No.: 7,764



QUOTE(drautzbug @ Apr 15 2009, 02:20 AM) *
I believe the kexec kernel provided by omegamoon simply does not look at CF cards. I now flashed zImage-kexecboot-2.6.26-r12-c7x0.bin from Angström and it does find zubuntu on the CF card and starts to boot it smile.gif . But then it stops with something like "waiting for root /dev/hda1" .

I assume this is because some module is not yet loaded at this stage. I will try to locate the module and put it into /etc/modules.


Has this issue been resolved? I would like to multiboot from a cf card. In other words:

1) Has the kexec kernel provided by omegamoon been revised to recognize CF cards?
or
2) Does the Angström image get past "waiting for root /dev/hda1" with Zubuntu?

Thanks.
Go to the top of the page
 
+Quote Post
drautzbug
post Feb 8 2010, 09:54 AM
Post #4





Group: Members
Posts: 3
Joined: 4-April 09
From: Germany
Member No.: 35,651



Picked up the trail recently. Still same problem, cannot even boot with zImage-kexecboot-2.6.26-r12-c7x0.bin at all. I wonder if I need a custom updater.sh.

Has anybody had any luck using kexecboot on a C760 with the rootfs on a CF card. Mine in 16MB, maybe that's a problem.
Go to the top of the page
 
+Quote Post
ant
post Feb 12 2010, 10:24 AM
Post #5





Group: Members
Posts: 163
Joined: 11-March 04
From: IT
Member No.: 2,270



>Has anybody had any luck using kexecboot on a C760 with the rootfs on a CF card. Mine in 16MB, maybe that's a problem.

Try this 2.6.26 kernel http://projects.linuxtogo.org/projects/zaurus/
(The 2.6.33-rc6 have still some minor issues)

Ant
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th August 2014 - 09:16 PM