OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Success! Ubuntu + Cacko!
duo
post May 10 2009, 01:05 PM
Post #1





Group: Members
Posts: 39
Joined: 20-August 08
Member No.: 22,227



step 1. Nand restore from trisoft.
step 2. Install Cacko, but don't resize the root partition.
step 3. make a folder on a sd or cf card called /boot/ contents:
zImage (kernel of your choice. I like EvilJazz's)
kernel-commandline (what should be here is all over these forums)
Image.nfo (only used if you use Cortez's kexecboot kernel, not used by Angstrom's)
Step 4. flash multiboot kernel

that's it, should work.
if you want the kernel, placed in nand, mount the root partition as rw, then move the /boot/ folder from sd to nand.

Backstory: Every time I tried to get Cacko to load, I would get a long sting of numbers (memory addresses I think) and finally a kernel panic.

Even though i resized the root partition of Cacko to 32MB, as suggested in the readme; and I had the proper config in kernel-commandline,I kept getting erros.
I noticed that even though i resized the partition, and specified a 32MB partition in the commandline, the mtd partitions were always the same.
00000000-00700000 smf
00700000-03c00000 root
03c00000-08000000 home

doing the math, i realized that the root partition above is 53MB in size. So I reflashed Cacko again for the N+1 time and this time, instead of resizing the root partition to 32MB, I set it to 53MB and then changed the kernel-commandline to reflect this. Instant success!!!

-Duo
Go to the top of the page
 
+Quote Post
mfhsieh
post May 11 2009, 05:12 PM
Post #2





Group: Members
Posts: 4
Joined: 6-February 05
Member No.: 6,418



I try it before. But the kernel of Cacko can not be boot.

I am using C760.

What is the model you are using ? Can you tell more details ?

Thanks!
Go to the top of the page
 
+Quote Post
duo
post May 12 2009, 06:36 PM
Post #3





Group: Members
Posts: 39
Joined: 20-August 08
Member No.: 22,227



Akita (C1000)

what else do you want to know?
Go to the top of the page
 
+Quote Post
speculatrix
post May 14 2009, 08:59 AM
Post #4





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(duo @ May 10 2009, 10:05 PM) *
So after trying forever to get Cacko to boot off of Nand, I finally figured out what the hangup was.


thanks for a very helpful post. I will give dual-boot cacko another go!
Go to the top of the page
 
+Quote Post
ant
post May 15 2009, 03:36 AM
Post #5





Group: Members
Posts: 163
Joined: 11-March 04
From: IT
Member No.: 2,270



Strange!
53MB is not standard root size for akita...I'd expect 58.

original 2.4 cmdline for all Zaurus models ( http://digit.que.ne.jp/visit/index.cgi?59414d41 ):

Kernel command line: console=ttyS0 root=/dev/mtdblock2 mtdparts=sharpsl-nand:7168k@0k(smf),59392k@7168k(root),-(home) jffs2_orphaned_inodes=delete EQUIPMENT=0 LOGOLANG=1 DEFYEAR=2006 LOGO=1 LAUNCH=q
Console: colour dummy device 80x30

Have you resized your partition with cacko/pdaxrom installers?

Regards

Ant
Go to the top of the page
 
+Quote Post
duo
post May 16 2009, 01:54 PM
Post #6





Group: Members
Posts: 39
Joined: 20-August 08
Member No.: 22,227



I started over with a nand restore from tri-soft.
flashed cacko
used the nand flash utils from the cacko installer
set the root partition to 32MB
booted into cacko, copied the kernel commandline and then flashed the multiboot kernel.
would not boot into cacko (strings of numbers then kernel panic)
did some math (above)
reflahed cacko, this time set the root partition to 53MB
booted into cacko, copied commandline ...etc
this time cacko booted.

i did not bother to flash the Katastrophos kernel, i just left it in the /boot dir on my sd's cacko partition.
Go to the top of the page
 
+Quote Post
Kirin
post May 19 2009, 11:16 AM
Post #7





Group: Members
Posts: 40
Joined: 20-July 05
Member No.: 7,641



did you guys lose the wallpaper and hard drive mount in cacko after starting it from the multi boot kernel?

My cacko is like that and the wallpaper and mount are gone...
Go to the top of the page
 
+Quote Post
Kirin
post May 28 2009, 12:08 PM
Post #8





Group: Members
Posts: 40
Joined: 20-July 05
Member No.: 7,641



I have successfully mounted back the micro drive from cacko. And I can find the wallpaper back from hdd3, but for some reason I can see it but can't apply it as wallpaper.

Is there some kind of access right issue? Can somebody help?
Go to the top of the page
 
+Quote Post
duo
post Jun 3 2009, 01:28 PM
Post #9





Group: Members
Posts: 39
Joined: 20-August 08
Member No.: 22,227



UPDATE: Everything is working again. problem appears to be a jffs2 issue. when installing packages, install only a couple at a time, then reboot. Should work just fine then. Also, i'm currently using the Angstrom Multiboot kernel for akita and it also is hardcoded for a 53MB root partition.



So now Cacko is acting weird on me. I can't PPP with BT or Connect to Wifi anymore. Plus I can't install anything. Something is up. Am going to try reflashing Cacko.

Also came across this on Yonggun's website where he says to use 53MB partition on Nand also for dual boot.

Makes me wonder if Cortez's (Omegamoon) kernel is based on, or shares something with Yonggun's (2or0).
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 04:18 AM