OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Debian Screws Apt, What Am I Doing Wrong?
arzgi
post Sep 7 2009, 07:59 AM
Post #1





Group: Members
Posts: 47
Joined: 27-March 06
Member No.: 9,463



I tried Zdevil's debian-rootfs (eabi) first. Installed fine to my SL-C3100,
but soon after installing a few debs from official mirror, dependency
problems made apt so broken that I could not install anything more.
First time ever I used sid, I've been running stable Debians on my
desktop pc's for years. I thought, it was just unstable sid.

So tried titchy, then oabi kernels, but they all led to the same
result. Errors that apt gives all usually something like "chown:changing
ownership of file n\465\235 [or any arbitary x\nnn\nnn]: No such file
or directory". Funny thing is, when I execute post-install script of
problematic .deb line by line, works then like it should.

Thought microdrive was dying, changed to cf-card. Did not help.
Next thought, Z's "hd-driver-chip" is corrupted, Bought another
used SL-C3100, but I'm still where I started.

I really cant get it, what causes this? Any hint appreciated.

Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
pelrun
post Sep 14 2009, 12:58 AM
Post #2





Group: Members
Posts: 369
Joined: 6-September 04
From: Brisbane, Australia
Member No.: 4,488



I suggest checking that your partitioning setup is correct - it's possible to make it so that multiple partitions partially overlap each other or extend past the actual size of the device, which can cause all sorts of intermittent and cumulative problems.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 11:44 PM