OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Promiscuous Mode
wario
post Nov 17 2009, 12:10 PM
Post #1





Group: Members
Posts: 21
Joined: 15-December 03
From: Helvetia
Member No.: 1,191



I am having difficulty putting my wireless interface into promiscuous mode. ifconfig says that it is, but I cannot gather packets not to/from the z. I compiled my own libpcap but this didn't work so I reverted to an ipk that I seem to recall working (but am now doubting my memory).

I have tried with ethereal, driftnet, tcpdump, my own code using libpcap - nothing. Kismet functions correctly but this isn't quite the same thing.

I'm not sure if the problem is my kernel, libpcap, wifi card or something else.

My setup is:
pdaXrom 1.1.0beta1 "Katherin"
Linksys WCF12 802.11b
libpcap 0.9.8-devel from capn_fish
SL-C860

Any suggestions appreciated. THanks.

----------------------------------------

Just like to say I love the z. my only real unix box at this point ...
Go to the top of the page
 
+Quote Post
climber
post Nov 20 2009, 01:26 AM
Post #2





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



I will take a closer look to your problem. By the way where can I get driftnet?

Thanks
climbers
SL-C3100 pdaXii13v2
Go to the top of the page
 
+Quote Post
wario
post Nov 22 2009, 12:17 AM
Post #3





Group: Members
Posts: 21
Joined: 15-December 03
From: Helvetia
Member No.: 1,191



driftnet
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 11:20 AM