OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Lxde
merlin1
post Jan 15 2010, 02:03 PM
Post #1





Group: Members
Posts: 82
Joined: 15-December 09
From: Germany
Member No.: 56,976



Howdy,

lxde works pretty well on the Netwalker. Installing it is easy but it doesn't pay attention to the autostart configured in the Gnome session which means that when you just install and reboot, you'll be missing quite a bit of things, most notably WiFi. Here's how I solved this problem but if there's a better way to accomplish this, please don't hesitate to tell me. smile.gif

Installing as usual...
CODE
sudo apt-get update
sudo apt-get install lxde


Now to fix the autostarted apps...
CODE
sudo mv /etc/xdg/autostart/*.desktop ~/.config/autostart
chown user:user ~/.config/autostart/*.desktop
chmod 755 ~/.config/autostart/*.desktop


Replace user with your actual user name.

Next issue - some apps are configured to only launch in Gnome. To fix this, we have to open every .desktop file in the ~/.config/autostart directory in an editor and look for the line reading "OnlyShowIn=..." LXDE has to be part of the list that follows. If it isn't present, add it like this:
CODE
OnlyShowIn=GNOME # bad
OnlyShowIn=GNOME;LXDE # good


After this is done, you can finally reboot/log off and on. It is worth mentioning that by moving every autostart file some Gnome stuff is started as well, resulting in a higher RAM consumption than what I usually see with pure lxde. However, I don't certainly know which ones can be removed without confining functionality. If someone knows, help is highly appreciated.

merlin1
Go to the top of the page
 
+Quote Post
ArchiMark
post Jan 17 2010, 11:51 AM
Post #2





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks for the great instructions, merlin1....got LXDE working on my Netwalker now....

Nice! and snappy too!!!

One question please, where you go to change appearance, etc in LXDE?

Thanks.
Go to the top of the page
 
+Quote Post
merlin1
post Jan 17 2010, 12:24 PM
Post #3





Group: Members
Posts: 82
Joined: 15-December 09
From: Germany
Member No.: 56,976



QUOTE(ArchiMark @ Jan 17 2010, 08:51 PM) *
Thanks for the great instructions, merlin1....got LXDE working on my Netwalker now....

Nice! and snappy too!!!

One question please, where you go to change appearance, etc in LXDE?

Thanks.

There are two programs, one is Openbox Configuration Manager (obconf), other is Appearance (lxappearance). Those two provide lots of options to configure appearance (fonts, icons, themes) and behaviour. Wallpaper can be set by right-clicking on desktop. The panel is not easily configurable AFAIK.
Go to the top of the page
 
+Quote Post
ArchiMark
post Jan 17 2010, 12:48 PM
Post #4





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks for the info, merlin1....

Meanwhile, one other question please....

Now, when I just tried to get online using Firefox after turning on the WiFi function (green light is on...), it didn't connect. In Gnome there was the network app in the upper task bar, where is the equivalent in LXDE???

Or do I need to use Terminal to get connected?
Go to the top of the page
 
+Quote Post
merlin1
post Jan 17 2010, 01:45 PM
Post #5





Group: Members
Posts: 82
Joined: 15-December 09
From: Germany
Member No.: 56,976



QUOTE(ArchiMark @ Jan 17 2010, 09:48 PM) *
Thanks for the info, merlin1....

Meanwhile, one other question please....

Now, when I just tried to get online using Firefox after turning on the WiFi function (green light is on...), it didn't connect. In Gnome there was the network app in the upper task bar, where is the equivalent in LXDE???

Or do I need to use Terminal to get connected?

Sounds like the NetworkManager applet is missing. Are you sure you moved all the autostarts over as outlined above?

For a quick fix, try running this in a Terminal:
CODE
nm-applet --sm-disable

If it complains due to permissions, add sudo before the command.

To check if something's wrong with your config, issue this, replacing user with your actual user name:
CODE
ls -al /home/user/.config/autostart

The output should be something like this:
CODE
...
-rw-r--r--  1 user user  361 2009-12-20 16:28 nm-applet.desktop
...

It'll show your user name of course and more .desktop files. nm-applet.desktop is the important file. It must be in there. If there's nothing in this directory then the autostarts configured in Gnome have not been successfully moved, that's why LXDE won't execute them. If you edit this file, does it contain the following?
CODE
[Desktop Entry]
Name=Network Manager
Comment=Control your network connections
Icon=nm-device-wireless
Exec=nm-applet --sm-disable
Terminal=false
Type=Application
OnlyShowIn=GNOME;XFCE;LXDE
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=NetworkManager
X-GNOME-Bugzilla-Component=general
X-GNOME-Autostart-enabled=true
X-Ubuntu-Gettext-Domain=nm-applet
Go to the top of the page
 
+Quote Post
ArchiMark
post Jan 17 2010, 02:10 PM
Post #6





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks, merlin1....

Did your quick fix and voila! NetworkManager opened and I got the icon in the task bar like before in Gnome....got connected OK after that...so that's good...

However, when I just tried to check if my config is OK using Terminal, per your instructions, I noticed that my keyboard mapping is not right anymore, so, I can't type the '~' symbol and some others anymore...doesn't type characters when I press Fn+Shift + other key like before...

So, tried to find the Keyboard Layout app like I used in Gnome, but I don't see it listed in drop-down menus either....

Any suggestion as to how to get to Keyboard Layout so that I can fix it again and then do the other steps in your instructions?

Thanks.
Go to the top of the page
 
+Quote Post
merlin1
post Jan 17 2010, 03:16 PM
Post #7





Group: Members
Posts: 82
Joined: 15-December 09
From: Germany
Member No.: 56,976



What exactly is wrong with your keyboard layout? Are some normal non-orange characters messed up as well? And does it happen in Gnome too? ~ refers to your home folder so you can also type /home/sharpie instead, assuming sharpie is your user name.

Does this help?
Go to the top of the page
 
+Quote Post
ArchiMark
post Jan 17 2010, 06:07 PM
Post #8





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(merlin1 @ Jan 17 2010, 01:45 PM) *
Sounds like the NetworkManager applet is missing. Are you sure you moved all the autostarts over as outlined above?


I thought I moved all of them...

QUOTE
For a quick fix, try running this in a Terminal:
CODE
nm-applet --sm-disable

If it complains due to permissions, add sudo before the command.


OK, did that and it worked, the app opened and shows up as before in Gnome in task bar....

QUOTE
To check if something's wrong with your config, issue this, replacing user with your actual user name:
CODE
ls -al /home/user/.config/autostart

The output should be something like this:
CODE
...
-rw-r--r--  1 user user  361 2009-12-20 16:28 nm-applet.desktop
...

It'll show your user name of course and more .desktop files. nm-applet.desktop is the important file. It must be in there. If there's nothing in this directory then the autostarts configured in Gnome have not been successfully moved, that's why LXDE won't execute them.


Yes, that file along with lots of users shows up in Terminal....but mine looks like this:

CODE
...
-rwxr-xr-x-  1 user user  357 2009-04-14 06:22 nm-applet.desktop
...



QUOTE
If you edit this file, does it contain the following?
CODE
[Desktop Entry]
Name=Network Manager
Comment=Control your network connections
Icon=nm-device-wireless
Exec=nm-applet --sm-disable
Terminal=false
Type=Application
OnlyShowIn=GNOME;XFCE;LXDE
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=NetworkManager
X-GNOME-Bugzilla-Component=general
X-GNOME-Autostart-enabled=true
X-Ubuntu-Gettext-Domain=nm-applet


Oops, I had everything like yours except LXDE in the 'OnlyShowIn...' line.....added it now...

Hmmm.....rebooted, but Network Manager and Battery App the battwalker app you posted about, do not show up in task bar.....

Also, in start menu, System Tools, I see Network Tools, not Network Manager....

I did fix keyboard per your other post, seems to be OK now....

Thanks!

This post has been edited by ArchiMark: Jan 17 2010, 07:10 PM
Reason for edit: Updated info
Go to the top of the page
 
+Quote Post
merlin1
post Jan 18 2010, 07:03 AM
Post #9





Group: Members
Posts: 82
Joined: 15-December 09
From: Germany
Member No.: 56,976



Mark,

the ownership settings seem incorrect to me. Type
CODE
chown sharpie:sharpie ~/.config/autostart/*.desktop

in Terminal but make sure that, if your user name is not sharpie, you modify the command appropriately. You have to be owner of all those files. So if your user name is mark (just an example) that would be:
CODE
chown mark:mark ~/.config/autostart/*.desktop

Go to the top of the page
 
+Quote Post
ArchiMark
post Jan 18 2010, 09:53 AM
Post #10





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(merlin1 @ Jan 18 2010, 07:03 AM) *
Mark,

the ownership settings seem incorrect to me. Type
CODE
chown sharpie:sharpie ~/.config/autostart/*.desktop

in Terminal but make sure that, if your user name is not sharpie, you modify the command appropriately. You have to be owner of all those files. So if your user name is mark (just an example) that would be:
CODE
chown mark:mark ~/.config/autostart/*.desktop



merlin1,

Thanks for your help as always....

Tried what you instructed and then rebooted, but notice no change in task bar, ie, no battery app, no network manager, etc showing up there....

Any other thoughts?

Thanks,

Mark
Go to the top of the page
 
+Quote Post
ArchiMark
post Jan 19 2010, 09:03 PM
Post #11





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



So, unless there's some other suggestions, I'm going back to Gnome for now as at least that works....
Go to the top of the page
 
+Quote Post
merlin1
post Jan 20 2010, 01:19 PM
Post #12





Group: Members
Posts: 82
Joined: 15-December 09
From: Germany
Member No.: 56,976



I'd be lying if I said this is not strange. unsure.gif I'll try to find a solution and post it here but IIRC I didn't have to do anything else and LXDE is paying attention to my autostarts.
Go to the top of the page
 
+Quote Post
ArchiMark
post Jan 20 2010, 04:38 PM
Post #13





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(merlin1 @ Jan 20 2010, 01:19 PM) *
I'd be lying if I said this is not strange. unsure.gif I'll try to find a solution and post it here but IIRC I didn't have to do anything else and LXDE is paying attention to my autostarts.


Well, it always seems that I end up having strange things happen when it involves Linux I've found....don't know why.....

rolleyes.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 06:44 PM