OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Netwalker Video Performance And Audio Problems.
ptoki
post Apr 10 2010, 05:01 PM
Post #1





Group: Members
Posts: 90
Joined: 1-April 08
From: Silesia
Member No.: 21,583



As I discovered netwalker is quite powerful device and can play full screen video smoothly.
Details are here:
http://tech.groups.yahoo.com/group/sharpne...ker/message/117

In short. After dumping pulseaudio totem player and vlc player started to play video smoothly. But there is a problem:
Video is played too fast.
I dod not have enough time to find out why and how to fix this.
Maybe it has something in common with cpu governor and constant switching between 160MHz and 800MHz?
I have written a nifty script to wisualize how cpu is switched and it shows that in normal conditions cpu can be switched 2-5 times per second between 160 and 800MHz and stays in higher clock for 5-20% of time. Maybe players got confused by this?
I will check this soon...

Any way. It is nice to be here again smile.gif
Go to the top of the page
 
+Quote Post
ptoki
post Apr 14 2010, 05:12 AM
Post #2





Group: Members
Posts: 90
Joined: 1-April 08
From: Silesia
Member No.: 21,583



Recipe to make video playback acceptable:

Put debian-multimedia.org in /etc/apt/sources.list
deb http://debian-multimedia.org stable main

Change jaunty to karmic in the same file for ports.ubuntu.org

Install mplayer and kmplayer (to have gui) from aptitude (or any other method is
acceptable)

Run kmplayer, load movie and watch smile.gif

Performance:
playing in window in native movie resolution (720x300something) is smooth even
in fast scenes. Playing in full screen is smooth but a bit chopping can be
noticed (i would say 15-20fps).
Video shutters when changing to another application and it takes a few seconds
to back to smoth play after focusing kmplayer.

During playback cpu is all time in fast mode.

I did not tried to solve sound problems with totem-player. But I will try...
Go to the top of the page
 
+Quote Post
Sleep_Walker
post Apr 15 2010, 01:41 AM
Post #3





Group: Members
Posts: 16
Joined: 14-April 10
From: Czech Republic
Member No.: 67,997



I'd suggest to remove karmic repo after this. Last time I tried to migrate to karmic I had to restore whole OS after attempt to upgrade libc version.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th October 2014 - 09:31 AM