OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Akita Multiboot "how To" Help
post Apr 17 2010, 03:21 AM
Post #1

Group: Members
Posts: 19
Joined: 29-January 06
From: Wellington, New Zealand
Member No.: 9,018

I have tried most "how to" in this forum and elsewhere and none have worked for me. I am not a developer but a user of the Zaurus. So when an "how to" assumes it is clear to everybody without actually including all the detailed steps, it does not always work for everybody, as shown in many of the posts in this forum. I have tried almost all distros by flashing them on my Akita and they all worked fine. But now the emphasis is more and more on kexecboot or multiboot methods. So I would like to write a complete multiboot "how to" for users (not developers) for the Akita hopefully with all your help.

Here is what I want to do:

1- Have multiple OS for my SL-C1000 on a SD card
- Zubuntu 2.0
- Cacko 1.23
- Angstrom
- Poky
- Igelle (http://www.igelle.com/)
2- Use the kexecboot or Omegamoon version

I have been using mainly Cacko but I now need to have a more mini computer (with Perl, Pyton, PHP and Apache) for when I am on a train or plane. I also mainly travel by bike and carrying a laptop is not an option for me, I need to travel as light as possible hence the Zaurus is perfect for that.

Here is what I tried so far:

1- I have configured a 2GB SD card with ext3 using fdisk and mkfs the same way as on Omegamoon:
2- I already had Cacko running on my Akita (capable of reading SD cards higher than 1GB)
3- I obtain the Katastrophos rootfs files and modules from this post:
4- Put the them on one of the partition of the SD card
5- Obtain the Sptiz Zubuntu 2.0 rootfs and addition files from this page:
(That actually did not work, when I tried to gunzip and tar -xvf the content on my Linux box, I got a few mknode permission denied).
6- Put them on a 1GB partition on the SD card
7- Obtain the kexecboot kernel and update file from Omegamoon:
8- Put them on a CF VFAT card (my SD card formatted as VFAT did not get recognized by my Akita)
9- Flashed update them on the Zaurus and rebooted as per the instruction on Omagamoon:
10- After rebooting my Akita, I obtain the Omagemoon kexecboot menu with 2 items in the list, one for Cacko and one for Zubuntu.
11- Selecting the Cacko did not work, got a kernel panic (init not found)
12- Selecting the Zubuntu did not work just stopped in the console and never booted the actual desktop.

I read all the posts in this forum related to this topic and there are many incomplete solutions but none of them seem to work for me.

So I want to start from the absolute beginning and want to write down every single steps that need to be taken for using kexecboot on Akita. Remember this is for the users not the developers.

Step 1: Format a SD card

- Partition and make an ext3 filesystem on a 2GB SD card with some swap space
(enter the exact and complete steps here)

Step 2: Prepare your Zaurus

- ...

Step 3: Obtain rootfs files, kernel-cmdline, kernel images for each OS

etc. ...

Shall we start?

Thank you for your help.
Go to the top of the page
+Quote Post
Start new topic
post Apr 18 2010, 02:44 AM
Post #2

Group: Members
Posts: 90
Joined: 1-April 08
From: Silesia
Member No.: 21,583

I confirm what duo describes. I did my c1000 according to this recipe and got dual boot cacko+zubuntu.
Actually i have spare 1 gig sd so i can try another distro. But not now, too much work.
Additionally I made two partitions on sd card to have cacko and zubuntu on one card.
And about instaling under cacko.
I have quite polished installation with loads of goodies and did backup (the one from settings tab).
After multibooting I did restore and all works fine (not tested all but have no problems so far).
Go to the top of the page
+Quote Post
post Apr 19 2010, 05:29 PM
Post #3

Group: Members
Posts: 19
Joined: 29-January 06
From: Wellington, New Zealand
Member No.: 9,018

I managed to have Cacko running from NAND on my Akita as per the instruction with the kernel image in the boot directory of a SD card (ext2). Once it has booted in Cacko, can I remove the SD card? I will also try putting the kernel image and kernel-commandline file in the /boot directory of the NAND and see if I can boot without the SD card as done in another duo post.

I have a lot of problems with my SD cards trying to make them work with the Zaurus. Seems like GParted actually corrupts the SD cards on Ubuntu 9.04. The card I am using does get mounted in my Zaurus (2.0GB SD, and yes I have the Testsu Kernel) but it does seem to show the correct partition and does work at booting Cacko:


$ sudo fdisk -l

Disk /dev/mmcda: 2032 MB, 2032664576 bytes
255 heads, 63 sectors/track, 247 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/mmcda1 1 123 987966 83 Linux

The next step did not work for me. I downloaded the Zubuntu 2.0 from Omegamoon, extracted the rootfs and addition files to a ext2 1.0GB SD card (this one actually gets mounted when put in my Zaurus). Put it in my Zaurus and rebooted. Zubuntu does show in the list in the Omegamoon boot menu, but after I select it, I get a Kernel Panic message after several fast moving error messages. Any idea why it would do that? I did not change anything from the downloaded files, only extracted them on the SD card as is.

Also each time I try to extract Zubuntu 2.0 or RC1 I always get mknod errors (permission denied, I guess trying to create the device block). Should I extract as root or using sudo?

Once I have Zubuntu working from a SD card I want to get Angstrom running and perhaps Poky also from the SD card. After I have everything running I will put all the detailed steps including all the commands needed.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th May 2018 - 08:57 PM