OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Power On Issue With Sl-6000
jcabrer
post Jul 11 2010, 11:47 AM
Post #1





Group: Members
Posts: 161
Joined: 23-June 05
Member No.: 7,429



Update: I have fixed the problem. The short answer is that I needed to re-flash with the contents of SL6000L-US-1.12.zip.

Googling for this will return several download sources. I thought I had done this already, but it turns out that the file I used, 20040217SL6V112.zip is not the same. Must be for a different TOSA model. At any rate, if you suffer from similar problems, just download the SL6000L-US-1.12.zip and put the contents on a compact flash card that has been formatted to FAT16 (NOT FAT32!!!), insert it into the slot with power turned off, hold D+P to enter the Maintenance/Diagnostic Menu, and select CF Update.

I'VE BEEN OUT OF THE SCENE FOR A WHILE, BUT i'M BACK BABY!!!

Original Message:
I'm a little concerned that the last post in this section was back in March. Hopefully there are enough of us Tosa owners out there that someone knows the answer to this problem.

I just bought an SL-6000L and SL-C31000. Neither one would boot when I powered them up. The C3100 solution required re-flashing the NAND, and re-partitioning the internal HDD. The SL-6000 seems to be a little more complicated.

I am suspecting that the battery had been totally discharged, and that this caused a problem where the Z thinks it is fully charged, and thus will not allow the battery to charge. I was able initially to get the maintenance menu up (D+P, and D+M), but then I think the battery lost too much charge, and I was not able to get in any more.

I took a lab power supply and charged up the battery a bit externally, and I'm now able to access the Diagnostic Menus once again, however I can still not boot the thing using the power button.

Here are the symptoms:
1. When plugged in to AC adapter directly or through the dock, amber charging light does not turn on.
2. Pressing the Power On button causes the Mail and Charge LEDs to faintly flash momentarily, but the unit does not power on, and the screen does not react in any way.
3. In order to enter Maintenance (D+M) or Diagnostic (D+P) modes, the battery must be removed, the backup battery switched toggled, battery re-inserted, and then reset while pressing the D+M or D+P keys.
4. Re-flashing NAND using the Q+T+reset seems to work (except that it does not boot afterward, of course)

Hopefully someone out there knows the answer!
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
undrwater
post Jul 12 2010, 03:26 PM
Post #2





Group: Members
Posts: 232
Joined: 26-September 03
Member No.: 500



There's some Tosa love still in the universe! There are some OE people working on the Tosa kernel...slowly but surely. If the kernel gets stabilized, we can expect to run a modern OS (Android, Linux / Enlightenment, Zubuntu, etc...) on the Tosa.

Where did you get that copy of the ROM? I'm not sure if that's the one provided by Sharp or not.
Go to the top of the page
 
+Quote Post
cycojesus
post Jul 20 2010, 01:28 AM
Post #3





Group: Members
Posts: 60
Joined: 17-February 04
From: Ha Noi, ViÍt Nam
Member No.: 1,881



QUOTE(undrwater @ Jul 13 2010, 12:26 AM) *
There's some Tosa love still in the universe! There are some OE people working on the Tosa kernel...slowly but surely. If the kernel gets stabilized, we can expect to run a modern OS (Android, Linux / Enlightenment, Zubuntu, etc...) on the Tosa.

Where did you get that copy of the ROM? I'm not sure if that's the one provided by Sharp or not.

I have a Zubuntu running.
Once I successfully booted Angstrom after following http://brooknet.no-ip.com/~lex/public/zaurus/tosa/ but I have little interest in it.
I have an old OpenZaurus (kernel 2.4) in flash that I use daily as an ebook reader.
And when I have time I (slowly) polish my armedslack installation (see http://github.com/cycojesus/ArmedZed )
Go to the top of the page
 
+Quote Post
undrwater
post Jul 22 2010, 08:33 PM
Post #4





Group: Members
Posts: 232
Joined: 26-September 03
Member No.: 500



QUOTE(cycojesus @ Jul 20 2010, 02:28 AM) *
QUOTE(undrwater @ Jul 13 2010, 12:26 AM) *
There's some Tosa love still in the universe! There are some OE people working on the Tosa kernel...slowly but surely. If the kernel gets stabilized, we can expect to run a modern OS (Android, Linux / Enlightenment, Zubuntu, etc...) on the Tosa.

Where did you get that copy of the ROM? I'm not sure if that's the one provided by Sharp or not.

I have a Zubuntu running.
Once I successfully booted Angstrom after following http://brooknet.no-ip.com/~lex/public/zaurus/tosa/ but I have little interest in it.
I have an old OpenZaurus (kernel 2.4) in flash that I use daily as an ebook reader.
And when I have time I (slowly) polish my armedslack installation (see http://github.com/cycojesus/ArmedZed )



Does your zubuntu include sound and wifi? If so, how did you go about installing and fixing the USB problem?
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 10:06 PM