OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Enabling Existing Drivers
Tom Moulton
post Jul 24 2010, 06:09 PM
Post #1





Group: Members
Posts: 20
Joined: 25-June 10
From: Tampa, FL, USA
Member No.: 77,866



Cross posted to Ubuntu Forums

I have a i.MX51 (arm) based system. Sharp PC-Z1 and I am
trying to get a USB Dongle WIFI working.
(The internal one died)

The usb stick is a RT2870 device and the system does have
/lib/firmware/rt2870.bin

It also has /usr/src/linux-headers-2.6.28-15-araneo/drivers/staging/rt2870

Makefile and Kconfig

but that is all. no rt2870sta.ko etc

Is it possible I have enough on the system to complete the generation of the needed file to enable this device?

It's Ubuntu 9.04

tom
Go to the top of the page
 
+Quote Post
Tom Moulton
post Jul 26 2010, 03:48 AM
Post #2





Group: Members
Posts: 20
Joined: 25-June 10
From: Tampa, FL, USA
Member No.: 77,866



QUOTE(Tom Moulton @ Jul 24 2010, 10:09 PM) *
Cross posted to Ubuntu Forums

Is it possible I have enough on the system to complete the generation of the needed file to enable this device?


Well I took the driver from the chipset manufacturer and compiled it.
The Netwalker not surprisingly has gcc and full linux headers installed on it.

I have gotten the device to install and after discovering that the USB ID of my device was missing from the source
(added USB_DEVICE() to a table)

it is now seen and comes up as ethernet device ra0

the network manager does not see it, so I may need to configure it by hand.
Which would really stink when I change access points.

tom
Go to the top of the page
 
+Quote Post
merlin1
post Jul 26 2010, 09:27 AM
Post #3





Group: Members
Posts: 82
Joined: 15-December 09
From: Germany
Member No.: 56,976



IIRC the Netwalker uses wicd as network manager. You probably have to change its configuration as it normally looks for eth0, the internal WiFi. You have to change that to ra0 instead, options defining which interface to use as wired/wireless are in its settings.
Go to the top of the page
 
+Quote Post
Tom Moulton
post Jul 26 2010, 09:38 AM
Post #4





Group: Members
Posts: 20
Joined: 25-June 10
From: Tampa, FL, USA
Member No.: 77,866



QUOTE(merlin1 @ Jul 26 2010, 01:27 PM) *
IIRC the Netwalker uses wicd as network manager. You probably have to change its configuration as it normally looks for eth0, the internal WiFi. You have to change that to ra0 instead, options defining which interface to use as wired/wireless are in its settings.


Since I did compile the driver from scratch, maybe I should change RA0 to ETH0 !

I never did find out if it was possible to use the /lib/firmware/rt2870.bin file that Sharp installed on the system.

I'll report back how it goes...

I am trying this because I saw eth0 in a lot of config files (dhcp, samba etc) and I figure why not fix the problem at the source?

tom
Go to the top of the page
 
+Quote Post
Tom Moulton
post Jul 26 2010, 11:29 AM
Post #5





Group: Members
Posts: 20
Joined: 25-June 10
From: Tampa, FL, USA
Member No.: 77,866



QUOTE(merlin1 @ Jul 26 2010, 01:27 PM) *
IIRC the Netwalker uses wicd as network manager.


Odd my system says NetworkManager Applet 0.7.0.100 and a link to NetworkManager
Go to the top of the page
 
+Quote Post
Tom Moulton
post Jul 26 2010, 08:05 PM
Post #6





Group: Members
Posts: 20
Joined: 25-June 10
From: Tampa, FL, USA
Member No.: 77,866



QUOTE(merlin1 @ Jul 26 2010, 01:27 PM) *
IIRC the Netwalker uses wicd as network manager. You probably have to change its configuration as it normally looks for eth0, the internal WiFi. You have to change that to ra0 instead, options defining which interface to use as wired/wireless are in its settings.


Ok, I disabled NetworkManager and installed wicd

it does create ra0 (ifconfig) and I do see it transmitting, but I do not RX anything or see any networks.

I did rebuild the driver to use ralink legacy mode.

I may need to rebuild switching one more option...

anyone use ralink legacy mode? (likely not, most use built-in wifi smile.gif)

tom
------------------
Ok I had the wrong driver 2870 vs 3070 I also had to switch to WICD - Thanks for the tip!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd April 2014 - 11:13 PM