OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Developer Image 1.6 Configuration Question
Meyer
post Jan 18 2011, 06:04 PM
Post #1





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



I have a question about the Zaurus Developer Image version 1.6 package published by Anton Maslovsky on the Embedded Linux Software Index (www.elsix.org) back in 2005.

The setup scripts call for both a mount point for the image squashfs file and a symbolic link to the mount point at /home/zaurus/develop. Then additional symbolic links are created in the standard file hierarchy (/usr/bin, /usr/lib, /usr/local/include, etc.) to the various compilers, libraries, and tools in the image, all referencing the link /home/zaurus/develop. Why is the link /home/zaurus/develop necessary? Couldn't all the compiler, library, and tool links reference the squashfs mount point directly?

Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
stefb
post Jan 20 2011, 06:03 AM
Post #2





Group: Members
Posts: 19
Joined: 22-April 08
From: Germany
Member No.: 21,662



I'm not an expert.

All tools need some sort of standard path to tools, include dirs, lib dirs... without links all these settings need the addition of the mount location. This is a lot of work.

For the mount location itself: /home/zaurus/develop is as good as every other location. When you use the default /home/zaurus/develop you don't need to change the settings in the install script (and other settngs in the image if there are such)

My questions: Are the dev_img16.img from elsix for Sharp ROM and OpenZaurus the same? Can the Image be used on the SL5500, too?
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 10:29 PM