OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Prism 2.5 Firmware Trouble, Trying to get my wifi card to work on Cacko 1.23 with updated firmware
post Oct 19 2011, 09:17 PM
Post #1

Group: Members
Posts: 13
Joined: 26-April 09
From: Japan
Member No.: 37,769

I have a Buffalo WLI-CF-S11G wireless card for my SL-C1000. It is running Cacko 1.23 (heavy?).
I want to be able to connect the Zaurus to my secure WPA network at home and I am interested in testing 'aircrack-ng' . From their website it seems one must use Station firmware >=1.5.6.

My card was running older firmware; here is the output of
# dmesg | grep wifi

wifi0: NIC: id=0x800c v1.0.0
wifi0: PRI: id=0x15 v1.0.5
wifi0: STA: id=0x1f v1.3.4

I followed Jun Sun's mini-HOWTO guide and flashed the card on my Windows XP laptop using the WinUpdate program. It didn't go so smoothly and I had to select 'Disable' in the 'Firmware Download' section of the card's properties (explained clearer here).
After that, flashing with WinUpdate seemed to work and the card now has Primary firmware 1.1.1 and Secondary (Station) firware 1.7.4.
But, now the card is not functioning well. It appears that the card is working for about 1 second after insertion - as the lights come on, and then it is susended or somesuch - as the lights go off.
The command
# dmesg | grep wifi

spits out repetitions of this
wifi0: hfa384x_cmd: interrupted; err=-110
wifi0: hfa384x_get_red: CMDCODE_ACCESS failed (res=-110, rid=fd51, len=6)
wifi0: hfa384x_cmd_issue: cmd reg was busy for 5000 usec
wifi0: hfa384x_cmd_issue - timeout - reg-0x8888
wifi0: hfa384x_cmd: entry still in list? (entry-c3a64be0, type=0, res=-1)

(but an odd thing happened as I ran that last code, appended to the end was this
wifi0: hfa384x_cmd: interrupted; err=-110
wifi0: hfa384x_get_red: CMDCODE_ACCESS failed (res=-110, rid=fd51, len=6)
wifi0: NIC: id=0x0800c v1.0.0
wifi0: PRI: id=0x15 v1.1.1
wifi0: STA: id=0x1f v1.7.4

When I ran the command again it was back to the usual repetitions without the above appendage.

I decided to try and download and compile hostap-utils-0.4.7 as suggested here.
I downloaded the file from here and then followed these commands but when I came to the command

This message was returned
-bash: make: command not found

What am I doing wrong?
Should I be using a different ROM?
Why won't my card function properly in Cacko 1.23 with the updated firmware?

Could you give me a little help if you are able to please?
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th March 2018 - 07:22 PM