OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #zaurus and #alarmz chat on freenode.net | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> repair advice for bad NAND blocks
post Apr 9 2004, 12:54 PM
Post #1

Group: Members
Posts: 18
Joined: 2-April 04
From: Council Bluffs, Iowa
Member No.: 2,634

I have a 14 month old SL-C700 with hardware problems. Tonight I'm going over to my Japanese teacher's house, and together we're going to call Sharp Japan tech support and try to get help. She warned me that Japanese are typically very regimented, so I may have problems getting detailed technical information from line-level support staff. I'd like to pose my question to the group here also:

First: I've flashed replacement OS images and erased and reloaded dozens of times. This is not a simple newbie issue. :)

I know I have bad "NAND" flash in my C700. I may or may not have other hardware problems. I'm trying to determine whether it would be a waste of time to hire an experienced electronics technician to replace the flash chips in my C700, or if I should instead just send the C700 to Japan.

I'll first describe what my C700 is doing now, and then will describe the symptoms I saw before the C700 failed completely.

Currently the C700 can get into the D+M menu, but only intermittently. (I've been in this menu dozens of times, so this is not a user training issue.) Usually if I press and hold D+M and toggle the battery lock, the flashing email light stops its flashing temporarily, and then starts again. I've been unable to get into the D+M menu for the past two days -- except for today, when I tried and it worked.

I have a SYSTC700.DBK file on a write-protected SD card. When I use the D+M menu's "NAND Flash Restore" option, the restore process runs for a few seconds (maybe 10 to 15 lines worth of green bar) and then says:

NAND Restore from SD


Execute restore?

Delete all flash data?


format error

If I go into EXTRA MENU, then Zaurus Test, then NAND Flash (Full), this test runs a destructive write-read test of my flash and tells me I have 2001 bad flash blocks:

NAND Flash (Full)

checking ecc... OK.

writing all 1...

adr = 4000000

Bad Block Num = 2001

verifying 1...

adr = 4000000

Bad Block Num = 2001

writing all 2...

adr = 4000000

Bad Block Num = 2001

verifying 2...

adr = 4000000

Bad Block Num = 2001

checking number...OK.


Also, interestingly, as it tests flash it counts forward in 2^20 increments, starting from 100000 and counting upward toward 4000000. Between ranges c00000 and 2900000 it counts very quickly, as if each block is failing completely and the test is being aborted on each block in that range.

So that's where I'm at right now. The problem seemed to start Tuesday before last (March 30). Here's what I observed back then: (quoted from my April 2 post at externe.net's older C700 forum)

I think I have a specific kind of hardware failure, but I'm not sure what's wrong. I probably can't fix it on my own, but I'd like to understand the problem. This isn't really flashing-related: I've been running the same Sukoshi rom for several weeks. I'm noticing three kinds of failures:

first failure type: the machine will occasionally lock up, hard. The clock stops, the battery meter stops playing its 'plugged into power' animation, and no key presses, card inserts and removals, or other inputs will make it react. I can toggle the battery lock switch and it'll restart.

second failure type: sometimes after toggling the battery lock switch, the email light will flash, as if to say it can't boot. Sometimes if I just toggle the switch again it'll boot normally; sometimes I have to toggle the switch several times; or sometimes I have to take the battery completely out and leave it without power for several minutes before trying again. It's running again right now though.

third failure type: occasionally I'll have programs refuse to start, or crash in the middle of running. Qtopia will restart sometimes. I've had some odd filesystem corruption also, and the system has been unable to find important executables (like cardctl).

After I started seeing that third type of failure, I backed everything up and flashed the latest Cacko QT ROM. This ROM has one important difference: when Qtopia starts I get a "wait 5, 4, 3, 2, 1" screen that gives me a chance to bail out of Qtopia and get a console-only command prompt. When I do that after Qtopia crashes and restarts, I see the following in my system log (dmesg command):

sharp_sl_nand_read_ecc: Failed ECC read, page 0x00003a5b
sharp_sl_nand_read_ecc: Failed ECC read, page 0x00003a5b
mtd->read(0x44 bytes from 0x4b7a4) returned ECC error
Node CRC 1c614139 != calculated CRC 51a10890 for node at 0004b7a4

These four lines are repeated dozens of times, filling the entire buffer printed by dmesg.

While in console-only mode, sometimes my shell will crash and I'll be back at a login screen again. After several crashes I would be able to log in, but when I tried to execute a single command I'd be back at a login prompt again. After several repeats of *that*, the login manager is unable to start correctly and starts spawning repeatedly, causing init to shut it down for 5 minutes.

For a while I was able to run Qtopia, and I ran the 'badblocks' program to look for bad Flash blocks. Strangely enough, I didn't find any:

OK, now this is weird:

Right now I'm sitting here running:
badblocks -p 1000 /dev/mtdblock0 &
badblocks -p 1000 /dev/mtdblock1 &
badblocks -p 1000 /dev/mtdblock2 &
badblocks -p 1000 /dev/mtdblock3 &

and it's just sitting there making the whole system unusably slow, but thrashing NAND like crazy. It's not finding *any* bad blocks. (Hopefully I'll get a chance to see the error messages when it finally finds problems.)

But it's been running this for over 30 minutes now, and hasn't found any bad blocks.

So might this mean I have some kind of intermittent problem that makes the whole flash memory subsystem flaky? Maybe it'll sit here and run fine for a while, and then suddenly be unable to read *anything*. I'm not sure.

The C700 is an amazing device -- I never realized how much I used it every day until I was without it. I'd love to get it back up and running soon, and hopefully without sending it back to Japan.

Thanks again for your help, guys! I'll post back here if I find out anything new from my call to Sharp Japan.

--Michael Spencer
Go to the top of the page
+Quote Post
Start new topic
post May 6 2005, 09:19 AM
Post #2

Group: Members
Posts: 257
Joined: 1-June 04
From: Budapest, Hungary
Member No.: 3,518

Hello! Good news! biggrin.gif
For all the Z owners with this problem, there's hope!
I managed to revive my Zaurus. I don't know _exactly_ what did it, because I wandered a lot in the Service menu.

I write here the process of my restore. (which I think lead to success)

- The objective is to clean up the NAND.
You have to get into the service menu for this:
  1. Open the battery cover
  2. Take out the battery for about 5 seconds
  3. Put it back
  4. Hold down the D+M keys on the keyboard
  5. Close the battery cover while holding the keys
  6. You will find yourself in the service menu
  7. Get in the 3rd page (with the "up" arrow)
  8. Choose "7.EXTRA MENU"
  9. Choose "1.Zaurus Test"
  10. Get to the 2nd page and select "10.NAND Flash Full Erase"
  11. This is the tricky part. If this doesn't work for you (gives an error message) then I don't know... There are other NAND Erase options in the Service menu, try all (at least I tried every one I saw). If it doesn't help, try them again (especially this NAND Flash Full Erase). I tried it a good couple of times before it worked. If you can put your NAND in a good shape, you won.
  12. If you managed to do it, then you won't see error messages in the different parts of the service menu.
Your Zaurus is most likely in a better, but still bad shape now, so you need to recover it.
- The C+D recover:
  1. Get the recovery package from here: http://pocketworkstation.org/files/recover/
  2. Read the included README. Read it again. You really want to do it? If you got this far, I think you do.
  3. Copy the files on a CF card and put the CF in the Zaurus
  4. Use your AC adapter in the process and make sure your battery is not low
  5. Open the battery cover and take out the battery for about 5 seconds
  6. Put it back
  7. Hold down the C+D keys on the keyboard
  8. Close the battery cover while holding the keys
  9. The mail and charge leds will continously light and will turn off after 30secs-2mins
Time for a NAND Restore!
The NAND backup file that has everything on your NAND flash. You can download original NAND files for different Z versions from here:
Use only the same version as your Zaurus!
  1. Put it on a CF card (make sure it is formated FAT16!)
  2. Get into the Service menu again, make sure you are using AC adapter.
  3. Go to the 3rd page in the service menu and select "10.NAND Flash Restore"
  4. If the Z doesn't find the NAND image, although it is there, try reformat it. If that doesn't help, try to get a different CF card.
  5. If the restore process fails ("format error" with red letters) then the NAND flash is still not OK, go back to the previous steps
  6. If the green line reach the right side of the screen and it says OK, then your Zaurus is living again!
You can now flash your favourite ROM on your revived Z! smile.gif
This tale was about a SL-C700, I read somewhere that you can use SD card for NAND Restore with greater versions.

I hope you will have luck with this too!
Zumi smile.gif
Go to the top of the page
+Quote Post
post Jun 2 2005, 11:10 AM
Post #3

Group: Members
Posts: 23
Joined: 20-September 04
Member No.: 4,668

QUOTE(Zumi @ May 6 2005, 05:19 PM)
9. The mail and charge leds will continously light and will turn off after 30secs-2mins

The first time I tried the recovery, this worked as you described. I was able to perform a NAND restore as well, but I couldn't install a ROM. I am running through the whole process again -- full NAND erase; recovery; NAND restore. This time, while doing the recovery, the mail and charge lights have been lit for over 10 minutes and are still! ph34r.gif Any idea why this would happen?


Go to the top of the page
+Quote Post

Posts in this topic
mspencer   repair advice for bad NAND blocks   Apr 9 2004, 12:54 PM
mspencer   I finished my phone call with Sharp Japan tech sup...   Apr 9 2004, 06:46 PM
gene   I wouldn't risk it. Having them replaced here may ...   Apr 9 2004, 07:00 PM
Pentad   Hi Michael, Here is my info for working with Shar...   Apr 9 2004, 09:37 PM
mspencer   I think I can understand why they might choose to ...   Apr 10 2004, 08:58 AM
Pentad   Michael, Do we (the community) have anybody in Ja...   Apr 10 2004, 09:51 AM
mspencer   Well, Take-sensei said she's going home to visit s...   Apr 10 2004, 09:44 PM
Stubear   Very little is done on credit card here in Japan, ...   Apr 11 2004, 03:15 AM
mspencer   I went ahead and sent my device to Dynamism. Acco...   May 15 2004, 01:10 PM
vishnja   Ouch! That is much more than we expected, right? D...   May 15 2004, 01:41 PM
kitsnews   mspencer, I got the same as yours. I also find b...   May 22 2004, 10:21 AM
padishah_emperor   QUOTEI went ahead and sent my device to Dynamism. ...   May 22 2004, 01:45 PM
mspencer   QUOTEmspencer, I got the same as yours. I also f...   May 22 2004, 06:40 PM
kitsnews   QUOTEYou might consider trying to erase flash, and...   May 24 2004, 09:39 AM
DrWowe   If you're careful, you could try erasing the flash...   May 24 2004, 10:53 AM
Zuber   You did all this, and you did not ask them when t...   May 24 2004, 01:19 PM
kitsnews   QUOTEIf you're careful, you could try erasing the ...   May 24 2004, 08:56 PM
jchung   Hi all, I just recently bought a c760 from ebay w...   Aug 11 2004, 06:42 PM
Stubear   QUOTE(jchung @ Aug 12 2004, 11:42 AM)Hi all, ...   Aug 12 2004, 03:41 PM
jchung   QUOTE(Stubear @ Aug 12 2004, 06:41 PM)QUOTE(j...   Aug 13 2004, 06:08 AM
mspencer   My C700, which I just got back from Japan a few mo...   Dec 4 2004, 11:48 AM
speculatrix   QUOTE(mspencer @ Dec 4 2004, 07:48 PM)My C700...   Apr 6 2005, 12:40 PM
Zumi   I got exactly the same problem that was described ...   May 5 2005, 03:16 PM
Zumi   Hello! Good news! For all the Z owners wi...   May 6 2005, 09:19 AM
jasonakay   QUOTE(Zumi @ May 6 2005, 05:19 PM)9. The mail...   Jun 2 2005, 11:10 AM
jasonakay   Well, now it's really toast! All 8 blocks...   Jun 8 2005, 03:08 PM
Zumi   So, the bad news... The repair is only temporary...   May 8 2005, 12:32 AM
jasonakay   QUOTE(Zumi @ May 8 2005, 08:32 AM)So, the bad...   Jun 1 2005, 12:09 AM
Stubear   QUOTE(jasonakay @ Jun 1 2005, 05:09 PM)Great....   Jun 1 2005, 07:32 AM
jasonakay   QUOTE(Stubear @ Jun 1 2005, 03:32 PM)Bad NAND...   Jun 2 2005, 11:05 AM
badog   "Get the recovery package from here: http://p...   Jul 13 2005, 07:24 PM
the_ph1lth   I expect the result on how to repair Z's with ...   Oct 20 2005, 03:42 PM
propofol   I have just recently purchased a brand new C3100 f...   Dec 7 2005, 03:36 PM
drnick   QUOTE(propofol @ Dec 7 2005, 11:36 PM)carmfs:...   Dec 7 2005, 04:04 PM
GadgetGuy   QUOTE(propofol @ Dec 7 2005, 06:36 PM)I have ...   Dec 8 2005, 07:58 AM
lindenle   Can you do a NAND restore from an SD card in the D...   Jun 27 2006, 07:45 AM
mspencer   I think someone earlier said only models later tha...   Dec 2 2006, 03:31 PM
Wildherb   QUOTE(mspencer @ Apr 9 2004, 09:54 PM) I ...   Dec 13 2008, 05:40 PM
speculatrix   good news you restored it, and I hope you'll s...   Dec 14 2008, 10:34 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th January 2018 - 02:01 AM